summaryrefslogtreecommitdiffstats
path: root/compiler/rustc_abi/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/rustc_abi/Cargo.toml')
-rw-r--r--compiler/rustc_abi/Cargo.toml24
1 files changed, 24 insertions, 0 deletions
diff --git a/compiler/rustc_abi/Cargo.toml b/compiler/rustc_abi/Cargo.toml
new file mode 100644
index 000000000..48b199cb8
--- /dev/null
+++ b/compiler/rustc_abi/Cargo.toml
@@ -0,0 +1,24 @@
+[package]
+name = "rustc_abi"
+version = "0.0.0"
+edition = "2021"
+
+[dependencies]
+bitflags = "1.2.1"
+tracing = "0.1"
+rand = { version = "0.8.4", default-features = false, optional = true }
+rand_xoshiro = { version = "0.6.0", optional = true }
+rustc_data_structures = { path = "../rustc_data_structures", optional = true }
+rustc_index = { path = "../rustc_index", default-features = false }
+rustc_macros = { path = "../rustc_macros", optional = true }
+rustc_serialize = { path = "../rustc_serialize", optional = true }
+
+[features]
+default = ["nightly", "randomize"]
+randomize = ["rand", "rand_xoshiro"]
+nightly = [
+ "rustc_data_structures",
+ "rustc_index/nightly",
+ "rustc_macros",
+ "rustc_serialize",
+]