summaryrefslogtreecommitdiffstats
path: root/compiler/rustc_index/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/rustc_index/Cargo.toml')
-rw-r--r--compiler/rustc_index/Cargo.toml8
1 files changed, 5 insertions, 3 deletions
diff --git a/compiler/rustc_index/Cargo.toml b/compiler/rustc_index/Cargo.toml
index e1cda5a9e..856f8a67d 100644
--- a/compiler/rustc_index/Cargo.toml
+++ b/compiler/rustc_index/Cargo.toml
@@ -3,14 +3,16 @@ name = "rustc_index"
version = "0.0.0"
edition = "2021"
-[lib]
-
[dependencies]
+# tidy-alphabetical-start
arrayvec = { version = "0.7", default-features = false }
-rustc_serialize = { path = "../rustc_serialize", optional = true }
rustc_macros = { path = "../rustc_macros", optional = true }
+rustc_serialize = { path = "../rustc_serialize", optional = true }
smallvec = "1.8.1"
+# tidy-alphabetical-end
[features]
+# tidy-alphabetical-start
default = ["nightly"]
nightly = ["rustc_serialize", "rustc_macros"]
+# tidy-alphabetical-end