summaryrefslogtreecommitdiffstats
path: root/compiler/rustc_lexer/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/rustc_lexer/Cargo.toml')
-rw-r--r--compiler/rustc_lexer/Cargo.toml23
1 files changed, 23 insertions, 0 deletions
diff --git a/compiler/rustc_lexer/Cargo.toml b/compiler/rustc_lexer/Cargo.toml
new file mode 100644
index 000000000..35af11053
--- /dev/null
+++ b/compiler/rustc_lexer/Cargo.toml
@@ -0,0 +1,23 @@
+[package]
+name = "rustc_lexer"
+version = "0.1.0"
+license = "MIT OR Apache-2.0"
+edition = "2021"
+
+repository = "https://github.com/rust-lang/rust/"
+description = """
+Rust lexer used by rustc. No stability guarantees are provided.
+"""
+
+# Note: do not remove this blank `[lib]` section.
+# This will be used when publishing this crate as `rustc-ap-rustc_lexer`.
+[lib]
+doctest = false
+
+# Note that this crate purposefully does not depend on other rustc crates
+[dependencies]
+unicode-xid = "0.2.0"
+unic-emoji-char = "0.9.0"
+
+[dev-dependencies]
+expect-test = "1.0"