summaryrefslogtreecommitdiffstats
path: root/compiler/rustc_lint/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/rustc_lint/Cargo.toml')
-rw-r--r--compiler/rustc_lint/Cargo.toml25
1 files changed, 25 insertions, 0 deletions
diff --git a/compiler/rustc_lint/Cargo.toml b/compiler/rustc_lint/Cargo.toml
new file mode 100644
index 000000000..7c0f2c440
--- /dev/null
+++ b/compiler/rustc_lint/Cargo.toml
@@ -0,0 +1,25 @@
+[package]
+name = "rustc_lint"
+version = "0.0.0"
+edition = "2021"
+
+[dependencies]
+tracing = "0.1"
+unicode-security = "0.0.5"
+rustc_middle = { path = "../rustc_middle" }
+rustc_ast_pretty = { path = "../rustc_ast_pretty" }
+rustc_attr = { path = "../rustc_attr" }
+rustc_errors = { path = "../rustc_errors" }
+rustc_hir = { path = "../rustc_hir" }
+rustc_target = { path = "../rustc_target" }
+rustc_ast = { path = "../rustc_ast" }
+rustc_span = { path = "../rustc_span" }
+rustc_data_structures = { path = "../rustc_data_structures" }
+rustc_feature = { path = "../rustc_feature" }
+rustc_index = { path = "../rustc_index" }
+rustc_session = { path = "../rustc_session" }
+rustc_trait_selection = { path = "../rustc_trait_selection" }
+rustc_parse_format = { path = "../rustc_parse_format" }
+rustc_infer = { path = "../rustc_infer" }
+rustc_type_ir = { path = "../rustc_type_ir" }
+rustc_macros = { path = "../rustc_macros" }