summaryrefslogtreecommitdiffstats
path: root/compiler/rustc_save_analysis/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'compiler/rustc_save_analysis/Cargo.toml')
-rw-r--r--compiler/rustc_save_analysis/Cargo.toml19
1 files changed, 19 insertions, 0 deletions
diff --git a/compiler/rustc_save_analysis/Cargo.toml b/compiler/rustc_save_analysis/Cargo.toml
new file mode 100644
index 000000000..15a89d82f
--- /dev/null
+++ b/compiler/rustc_save_analysis/Cargo.toml
@@ -0,0 +1,19 @@
+[package]
+name = "rustc_save_analysis"
+version = "0.0.0"
+edition = "2021"
+
+[dependencies]
+tracing = "0.1"
+rustc_middle = { path = "../rustc_middle" }
+rustc_ast = { path = "../rustc_ast" }
+rustc_ast_pretty = { path = "../rustc_ast_pretty" }
+rustc_data_structures = { path = "../rustc_data_structures" }
+rustc_hir = { path = "../rustc_hir" }
+rustc_hir_pretty = { path = "../rustc_hir_pretty" }
+rustc_lexer = { path = "../rustc_lexer" }
+serde_json = "1"
+rustc_session = { path = "../rustc_session" }
+rustc_span = { path = "../rustc_span" }
+rls-data = "0.19"
+rls-span = "0.5"