summaryrefslogtreecommitdiffstats
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control28
1 files changed, 15 insertions, 13 deletions
diff --git a/debian/control b/debian/control
index ac8ad1d15..ef68ffe11 100644
--- a/debian/control
+++ b/debian/control
@@ -14,19 +14,20 @@ Rules-Requires-Root: no
Build-Depends:
debhelper (>= 9),
debhelper-compat (= 13),
- dpkg-dev (>= 1.17.14),
python3:native,
- cargo:native (>= 1.70.0+dfsg) <!pkg.rustc.dlstage0>,
- rustc:native (>= 1.70.0+dfsg) <!pkg.rustc.dlstage0>,
- rustc:native (<= 1.71.1++) <!pkg.rustc.dlstage0>,
+ cargo:native (>= 1.75.0+dfsg) <!pkg.rustc.dlstage0>,
+ rustc:native (>= 1.75.0+dfsg) <!pkg.rustc.dlstage0>,
+ rustc:native (<= 1.76.0++) <!pkg.rustc.dlstage0>,
llvm-16-dev:native,
llvm-16-tools:native,
gcc-mingw-w64-x86-64-posix:native [amd64] <!nowindows>,
gcc-mingw-w64-i686-posix:native [i386] <!nowindows>,
libllvm16 (>= 1:16.0.0),
libclang-rt-16-dev:native,
+ libclang-rt-16-dev,
cmake (>= 3.0),
# needed by some vendor crates
+ pkgconf:native,
pkgconf,
# this is sometimes needed by rustc_llvm
zlib1g-dev:native,
@@ -38,6 +39,7 @@ Build-Depends:
libcurl4-openssl-dev | libcurl4-gnutls-dev,
libssh2-1-dev,
libssl-dev,
+ libsqlite3-dev,
libgit2-dev (>= 1.7.1),
libgit2-dev (<< 1.8~~),
libhttp-parser-dev,
@@ -52,8 +54,8 @@ Build-Depends:
curl <pkg.rustc.dlstage0>,
ca-certificates <pkg.rustc.dlstage0>,
Build-Depends-Indep:
- wasi-libc (>= 0.0~git20230113.4362b18-2~) <!nowasm>,
- wasi-libc (<= 0.0~git20230113.4362b18++) <!nowasm>,
+ wasi-libc (>= 0.0~git20230821.ec4566b~~) <!nowasm>,
+ wasi-libc (<= 0.0~git20230821.ec4566b++) <!nowasm>,
clang-16:native,
Build-Conflicts: gdb-minimal <!nocheck>
Standards-Version: 4.6.2
@@ -89,7 +91,7 @@ Description: Rust systems programming language
generic programming and meta-programming, in both static and dynamic
styles.
-Package: libstd-rust-1.71
+Package: libstd-rust-1.76
Section: libs
Architecture: any
Multi-Arch: same
@@ -116,7 +118,7 @@ Section: libdevel
Architecture: any
Multi-Arch: same
Depends: ${shlibs:Depends}, ${misc:Depends},
- libstd-rust-1.71 (= ${binary:Version}),
+ libstd-rust-1.76 (= ${binary:Version}),
Description: Rust standard libraries - development files
Rust is a curly-brace, block-structured expression language. It
visually resembles the C language family, but differs significantly
@@ -236,8 +238,8 @@ Package: rust-llvm
Architecture: all
Breaks:
rustc (<< 1.71.1+dfsg1-1~exp1),
- rust-web (<< 1.71.1+dfsg1-1~exp1),
- rust-mozilla (<< 1.71.1+dfsg1-1~exp1),
+ rustc-web (<< 1.71.1+dfsg1-1~exp1),
+ rustc-mozilla (<< 1.71.1+dfsg1-1~exp1),
Replaces:
rustc (<< 1.71.1+dfsg1-1~exp1),
rustc-web (<< 1.71.1+dfsg1-1~exp1),
@@ -311,7 +313,7 @@ Package: rust-clippy
Architecture: any
Multi-Arch: allowed
Depends: ${misc:Depends}, ${shlibs:Depends},
- libstd-rust-1.71 (= ${binary:Version})
+ libstd-rust-1.76 (= ${binary:Version})
Recommends: cargo
Description: Rust linter
Rust is a curly-brace, block-structured expression language. It
@@ -408,7 +410,7 @@ Description: Rust package manager
your project.
* Introduces conventions, making working with Rust projects easier.
.
- Cargo downloads your Rust project’s dependencies and compiles your
+ Cargo downloads your Rust project's dependencies and compiles your
project.
Package: cargo-doc
@@ -428,7 +430,7 @@ Description: Rust package manager, documentation
your project.
* Introduces conventions, making working with Rust projects easier.
.
- Cargo downloads your Rust project’s dependencies and compiles your
+ Cargo downloads your Rust project's dependencies and compiles your
project.
.
This package contains the documentation.