summaryrefslogtreecommitdiffstats
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control58
1 files changed, 56 insertions, 2 deletions
diff --git a/debian/control b/debian/control
index 1e8f62990..4c7a5254f 100644
--- a/debian/control
+++ b/debian/control
@@ -16,7 +16,7 @@ Build-Depends:
debhelper-compat (= 13),
dpkg-dev (>= 1.17.14),
python3:native,
- cargo:native (>= 0.60.0) <!pkg.rustc.dlstage0>,
+ cargo:native (>= 0.69.0+dfsg) <!pkg.rustc.dlstage0>,
rustc:native (>= 1.69.0+dfsg) <!pkg.rustc.dlstage0>,
rustc:native (<= 1.70.0++) <!pkg.rustc.dlstage0>,
llvm-16-dev:native,
@@ -33,6 +33,13 @@ Build-Depends:
zlib1g-dev,
# used by rust-installer
liblzma-dev:native,
+# used by cargo
+ bash-completion,
+ libcurl4-gnutls-dev | libcurl4-openssl-dev,
+ libssh2-1-dev,
+ libgit2-dev (>= 1.7.1),
+ libgit2-dev (<< 1.8~~),
+ libhttp-parser-dev,
# test dependencies:
binutils (>= 2.26) <!nocheck> | binutils-2.26 <!nocheck>,
# temporarily disabled cause of #1066794 / t64 transition
@@ -329,7 +336,7 @@ Depends: ${misc:Depends}, ${shlibs:Depends},
rust-gdb (>= ${binary:Version}) | rust-lldb (>= ${binary:Version}),
cargo,
Recommends:
- cargo (>= 0.71.0~~), cargo (<< 0.72.0~~)
+ cargo (= ${binary:Version})
Suggests:
rust-doc (>= ${binary:Version}),
rust-src (>= ${binary:Version}),
@@ -350,3 +357,50 @@ Description: Rust systems programming language - all developer tools
.
This package is an empty metapackage that depends on all developer tools
in the standard rustc distribution that have been packaged for Debian.
+
+# Cargo binaries
+Package: cargo
+Architecture: any
+Multi-Arch: allowed
+Depends: ${shlibs:Depends}, ${misc:Depends},
+ rustc (= ${binary:Version}),
+ binutils,
+ gcc | clang | c-compiler
+Suggests: cargo-doc, python3
+Description: Rust package manager
+ Cargo is a tool that allows Rust projects to declare their various
+ dependencies, and ensure that you'll always get a repeatable build.
+ .
+ To accomplish this goal, Cargo does four things:
+ * Introduces two metadata files with various bits of project information.
+ * Fetches and builds your project's dependencies.
+ * Invokes rustc or another build tool with the correct parameters to build
+ your project.
+ * Introduces conventions, making working with Rust projects easier.
+ .
+ Cargo downloads your Rust project’s dependencies and compiles your
+ project.
+
+Package: cargo-doc
+Section: doc
+Architecture: all
+Build-Profiles: <!nodoc>
+Recommends: rust-doc
+Depends: ${misc:Depends}
+Description: Rust package manager, documentation
+ Cargo is a tool that allows Rust projects to declare their various
+ dependencies, and ensure that you'll always get a repeatable build.
+ .
+ To accomplish this goal, Cargo does four things:
+ * Introduces two metadata files with various bits of project information.
+ * Fetches and builds your project's dependencies.
+ * Invokes rustc or another build tool with the correct parameters to build
+ your project.
+ * Introduces conventions, making working with Rust projects easier.
+ .
+ Cargo downloads your Rust project’s dependencies and compiles your
+ project.
+ .
+ This package contains the documentation.
+
+# TODO: add a cargo-src package