summaryrefslogtreecommitdiffstats
path: root/debian/control
diff options
context:
space:
mode:
Diffstat (limited to 'debian/control')
-rw-r--r--debian/control31
1 files changed, 16 insertions, 15 deletions
diff --git a/debian/control b/debian/control
index e951514ee..050af7f13 100644
--- a/debian/control
+++ b/debian/control
@@ -17,13 +17,14 @@ Build-Depends:
dpkg-dev (>= 1.17.14),
python3:native,
cargo:native (>= 0.60.0) <!pkg.rustc.dlstage0>,
- rustc:native (>= 1.68.0+dfsg) <!pkg.rustc.dlstage0>,
- rustc:native (<= 1.69.0++) <!pkg.rustc.dlstage0>,
- llvm-15-dev:native,
- llvm-15-tools:native,
+ rustc:native (>= 1.69.0+dfsg) <!pkg.rustc.dlstage0>,
+ rustc:native (<= 1.70.0++) <!pkg.rustc.dlstage0>,
+ llvm-16-dev:native,
+ llvm-16-tools:native,
gcc-mingw-w64-x86-64-posix:native [amd64] <!nowindows>,
gcc-mingw-w64-i686-posix:native [i386] <!nowindows>,
- libllvm15 (>= 1:15.0.0),
+ libllvm16 (>= 1:16.0.0),
+ libclang-rt-16-dev:native,
cmake (>= 3.0) | cmake3,
# needed by some vendor crates
pkg-config,
@@ -44,7 +45,7 @@ Build-Depends:
Build-Depends-Indep:
wasi-libc (>= 0.0~git20230113.4362b18-2~) <!nowasm>,
wasi-libc (<= 0.0~git20230113.4362b18++) <!nowasm>,
- clang-15:native,
+ clang-16:native,
Build-Conflicts: gdb-minimal <!nocheck>
Standards-Version: 4.6.2
Homepage: http://www.rust-lang.org/
@@ -61,12 +62,12 @@ Depends: ${shlibs:Depends}, ${misc:Depends},
libstd-rust-dev (= ${binary:Version}),
gcc, libc-dev, binutils (>= 2.26)
Recommends:
- cargo (>= 0.70.0~~), cargo (<< 0.71.0~~),
+ cargo (>= 0.71.0~~), cargo (<< 0.72.0~~),
# llvm is needed for llvm-dwp for -C split-debuginfo=packed
- llvm-15,
+ llvm-16,
Suggests:
# lld and clang are needed for wasm compilation
- lld-15, clang-15,
+ lld-16, clang-16,
Replaces: libstd-rust-dev (<< 1.25.0+dfsg1-2~~)
Breaks: libstd-rust-dev (<< 1.25.0+dfsg1-2~~)
Description: Rust systems programming language
@@ -82,7 +83,7 @@ Description: Rust systems programming language
generic programming and meta-programming, in both static and dynamic
styles.
-Package: libstd-rust-1.69
+Package: libstd-rust-1.70
Section: libs
Architecture: any
Multi-Arch: same
@@ -109,7 +110,7 @@ Section: libdevel
Architecture: any
Multi-Arch: same
Depends: ${shlibs:Depends}, ${misc:Depends},
- libstd-rust-1.69 (= ${binary:Version}),
+ libstd-rust-1.70 (= ${binary:Version}),
Description: Rust standard libraries - development files
Rust is a curly-brace, block-structured expression language. It
visually resembles the C language family, but differs significantly
@@ -161,7 +162,7 @@ Depends: ${shlibs:Depends}, ${misc:Depends}
# Embeds wasi-libc so doesn't need to depend on it
# None of its licenses require source redistrib, so no need for Built-Using
Recommends:
- lld-15, clang-15,
+ lld-16, clang-16,
Suggests:
# nodejs contains wasi-node for running the program
nodejs (>= 12.16),
@@ -207,7 +208,7 @@ Description: Rust debugger (gdb)
Package: rust-lldb
Architecture: all
# When updating, also update rust-lldb.links
-Depends: lldb-15, ${misc:Depends}, python3-lldb-15
+Depends: lldb-16, ${misc:Depends}, python3-lldb-16
Replaces: rustc (<< 1.1.0+dfsg1-1)
Description: Rust debugger (lldb)
Rust is a curly-brace, block-structured expression language. It
@@ -272,7 +273,7 @@ Package: rust-clippy
Architecture: any
Multi-Arch: allowed
Depends: ${misc:Depends}, ${shlibs:Depends},
- libstd-rust-1.69 (= ${binary:Version})
+ libstd-rust-1.70 (= ${binary:Version})
Recommends: cargo
Description: Rust linter
Rust is a curly-brace, block-structured expression language. It
@@ -327,7 +328,7 @@ Depends: ${misc:Depends}, ${shlibs:Depends},
rust-gdb (>= ${binary:Version}) | rust-lldb (>= ${binary:Version}),
cargo,
Recommends:
- cargo (>= 0.70.0~~), cargo (<< 0.71.0~~)
+ cargo (>= 0.71.0~~), cargo (<< 0.72.0~~)
Suggests:
rust-doc (>= ${binary:Version}),
rust-src (>= ${binary:Version}),