summaryrefslogtreecommitdiffstats
path: root/debian/patches/c-update-libgit2.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/c-update-libgit2.patch')
-rw-r--r--debian/patches/c-update-libgit2.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/debian/patches/c-update-libgit2.patch b/debian/patches/c-update-libgit2.patch
new file mode 100644
index 000000000..b004ed095
--- /dev/null
+++ b/debian/patches/c-update-libgit2.patch
@@ -0,0 +1,37 @@
+Index: rust/src/tools/cargo/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/cargo/Cargo.toml
++++ rust/src/tools/cargo/Cargo.toml
+@@ -28,8 +28,8 @@ curl-sys = "0.4.61"
+ env_logger = "0.10.0"
+ filetime = "0.2.9"
+ flate2 = { version = "1.0.3", default-features = false, features = ["zlib"] }
+-git2 = "0.17.0"
+-git2-curl = "0.18.0"
++git2 = "0.18.0"
++git2-curl = "0.19.0"
+ gix = { version = "0.39.0", default-features = false, features = ["blocking-http-transport-curl", "progress-tree"] }
+ gix-features-for-configuration-only = { version = "0.28.0", package = "gix-features", features = [ "parallel" ] }
+ glob = "0.3.0"
+@@ -47,7 +47,7 @@ jobserver = "0.1.26"
+ lazy_static = "1.2.0"
+ lazycell = "1.2.0"
+ libc = "0.2"
+-libgit2-sys = "0.15.0"
++libgit2-sys = "0.16.1"
+ log = "0.4.6"
+ memchr = "2.1.3"
+ opener = "0.5"
+Index: rust/src/tools/cargo/crates/cargo-test-support/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/cargo/crates/cargo-test-support/Cargo.toml
++++ rust/src/tools/cargo/crates/cargo-test-support/Cargo.toml
+@@ -14,7 +14,7 @@ cargo-util = { path = "../cargo-util" }
+ crates-io = { path = "../crates-io" }
+ filetime = "0.2"
+ flate2 = { version = "1.0", default-features = false, features = ["zlib"] }
+-git2 = "0.17.0"
++git2 = "0.18.0"
+ glob = "0.3"
+ itertools = "0.10.0"
+ lazy_static = "1.0"