summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-0000-ignore-removed-submodules.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-0000-ignore-removed-submodules.patch')
-rw-r--r--debian/patches/d-0000-ignore-removed-submodules.patch143
1 files changed, 70 insertions, 73 deletions
diff --git a/debian/patches/d-0000-ignore-removed-submodules.patch b/debian/patches/d-0000-ignore-removed-submodules.patch
index 3dfaf06cb..26d1e4361 100644
--- a/debian/patches/d-0000-ignore-removed-submodules.patch
+++ b/debian/patches/d-0000-ignore-removed-submodules.patch
@@ -3,21 +3,22 @@ Date: Sat, 2 Oct 2021 01:07:59 +0100
Subject: d-0000-ignore-removed-submodules
---
- Cargo.toml | 36 ++++++++----------------------------
- src/bootstrap/bootstrap.py | 4 ----
- src/bootstrap/builder.rs | 7 +------
- src/bootstrap/doc.rs | 1 -
- src/bootstrap/test.rs | 12 +-----------
- src/tools/clippy/Cargo.toml | 5 -----
- src/tools/rustfmt/Cargo.toml | 5 -----
- src/tools/tidy/src/deps.rs | 2 +-
- 8 files changed, 11 insertions(+), 61 deletions(-)
+ Cargo.toml | 15 ---------------
+ src/bootstrap/bootstrap.py | 4 ----
+ src/bootstrap/builder.rs | 11 +----------
+ src/bootstrap/doc.rs | 1 -
+ src/bootstrap/test.rs | 12 +-----------
+ src/tools/clippy/Cargo.toml | 5 -----
+ src/tools/rust-analyzer/Cargo.toml | 11 ++++++++++-
+ src/tools/rustfmt/Cargo.toml | 5 -----
+ src/tools/tidy/src/deps.rs | 2 +-
+ 9 files changed, 13 insertions(+), 53 deletions(-)
diff --git a/Cargo.toml b/Cargo.toml
-index ffc886d..7231b60 100644
+index e49fe5e..863c800 100644
--- a/Cargo.toml
+++ b/Cargo.toml
-@@ -16,25 +16,14 @@ members = [
+@@ -16,27 +16,15 @@ members = [
"src/tools/tidy",
"src/tools/tier-check",
"src/tools/build-manifest",
@@ -38,38 +39,16 @@ index ffc886d..7231b60 100644
"src/tools/unicode-table-generator",
- "src/tools/expand-yaml-anchors",
"src/tools/jsondocck",
+ "src/tools/jsondoclint",
"src/tools/html-checker",
- "src/tools/bump-stage0",
+- "src/tools/replace-version-placeholder",
"src/tools/lld-wrapper",
]
-@@ -96,25 +85,16 @@ gimli.debug = 0
- miniz_oxide.debug = 0
+@@ -99,9 +87,6 @@ miniz_oxide.debug = 0
object.debug = 0
--# We want the RLS to use the version of Cargo that we've got vendored in this
--# repository to ensure that the same exact version of Cargo is used by both the
--# RLS and the Cargo binary itself. The RLS depends on Cargo as a git repository
--# so we use a `[patch]` here to override the github repository with our local
--# vendored copy.
--[patch."https://github.com/rust-lang/cargo"]
--cargo = { path = "src/tools/cargo" }
--cargo-util = { path = "src/tools/cargo/crates/cargo-util" }
--
--[patch."https://github.com/rust-lang/rustfmt"]
--# Similar to Cargo above we want the RLS to use a vendored version of `rustfmt`
--# that we're shipping as well (to ensure that the rustfmt in RLS and the
--# `rustfmt` executable are the same exact version).
--rustfmt-nightly = { path = "src/tools/rustfmt" }
-+# The only package that ever uses debug builds is bootstrap.
-+# We care a lot about bootstrap's compile times, so don't include debug info for
-+# dependencies, only bootstrap itself.
-+[profile.dev]
-+debug = 0
-+[profile.dev.package]
-+# Only use debuginfo=1 to further reduce compile times.
-+bootstrap.debug = 1
-
[patch.crates-io]
-# See comments in `src/tools/rustc-workspace-hack/README.md` for what's going on
-# here
@@ -78,7 +57,7 @@ index ffc886d..7231b60 100644
# See comments in `library/rustc-std-workspace-core/README.md` for what's going on
# here
diff --git a/src/bootstrap/bootstrap.py b/src/bootstrap/bootstrap.py
-index 03eec02..c40811f 100644
+index cc08ae5..bf7d696 100644
--- a/src/bootstrap/bootstrap.py
+++ b/src/bootstrap/bootstrap.py
@@ -759,10 +759,6 @@ class RustBuild(object):
@@ -93,34 +72,36 @@ index 03eec02..c40811f 100644
args.append("--features")
args.append("build-metrics")
diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
-index 0ab4824..629e1bb 100644
+index 14e8ebd..6d43333 100644
--- a/src/bootstrap/builder.rs
+++ b/src/bootstrap/builder.rs
-@@ -600,7 +600,6 @@ impl<'a> Builder<'a> {
+@@ -600,8 +600,6 @@ impl<'a> Builder<'a> {
+ tool::RemoteTestClient,
tool::RustInstaller,
tool::Cargo,
- tool::Rls,
+- tool::Rls,
- tool::RustAnalyzer,
tool::RustAnalyzerProcMacroSrv,
tool::RustDemangler,
tool::Rustdoc,
-@@ -622,7 +620,6 @@ impl<'a> Builder<'a> {
+@@ -622,8 +621,6 @@ impl<'a> Builder<'a> {
+ check::CodegenBackend,
check::Clippy,
check::Miri,
- check::Rls,
+- check::Rls,
- check::RustAnalyzer,
check::Rustfmt,
check::Bootstrap
),
-@@ -650,7 +647,6 @@ impl<'a> Builder<'a> {
+@@ -650,7 +648,6 @@ impl<'a> Builder<'a> {
+ test::ReplacePlaceholderTest,
test::Cargotest,
test::Cargo,
- test::Rls,
- test::RustAnalyzer,
test::ErrorIndex,
test::Distcheck,
test::RunMakeFullDeps,
-@@ -698,10 +694,8 @@ impl<'a> Builder<'a> {
+@@ -698,10 +695,8 @@ impl<'a> Builder<'a> {
doc::RustdocBook,
doc::RustByExample,
doc::RustcBook,
@@ -131,7 +112,15 @@ index 0ab4824..629e1bb 100644
doc::EmbeddedBook,
doc::EditionGuide,
),
-@@ -723,7 +717,6 @@ impl<'a> Builder<'a> {
+@@ -715,15 +712,12 @@ impl<'a> Builder<'a> {
+ dist::Analysis,
+ dist::Src,
+ dist::Cargo,
+- dist::Rls,
+- dist::RustAnalyzer,
+ dist::Rustfmt,
+ dist::RustDemangler,
+ dist::Clippy,
dist::Miri,
dist::LlvmTools,
dist::RustDev,
@@ -139,7 +128,15 @@ index 0ab4824..629e1bb 100644
// It seems that PlainSourceTarball somehow changes how some of the tools
// perceive their dependencies (see #93033) which would invalidate fingerprints
// and force us to rebuild tools after vendoring dependencies.
-@@ -2054,10 +2047,7 @@ impl<'a> Builder<'a> {
+@@ -736,7 +725,6 @@ impl<'a> Builder<'a> {
+ install::Docs,
+ install::Std,
+ install::Cargo,
+- install::RustAnalyzer,
+ install::Rustfmt,
+ install::RustDemangler,
+ install::Clippy,
+@@ -2056,10 +2050,7 @@ impl<'a> Builder<'a> {
}
}
@@ -152,7 +149,7 @@ index 0ab4824..629e1bb 100644
}
diff --git a/src/bootstrap/doc.rs b/src/bootstrap/doc.rs
-index 2852442..5faa8e5 100644
+index f909ecc..8bf71b1 100644
--- a/src/bootstrap/doc.rs
+++ b/src/bootstrap/doc.rs
@@ -73,7 +73,6 @@ macro_rules! book {
@@ -164,10 +161,10 @@ index 2852442..5faa8e5 100644
EditionGuide, "src/doc/edition-guide", "edition-guide", submodule;
EmbeddedBook, "src/doc/embedded-book", "embedded-book", submodule;
diff --git a/src/bootstrap/test.rs b/src/bootstrap/test.rs
-index c0fa8c9..8fbc390 100644
+index dd41f84..ba6227c 100644
--- a/src/bootstrap/test.rs
+++ b/src/bootstrap/test.rs
-@@ -1910,17 +1910,7 @@ impl Step for RustcGuide {
+@@ -1886,17 +1886,7 @@ impl Step for RustcGuide {
}
fn run(self, builder: &Builder<'_>) {
@@ -187,7 +184,7 @@ index c0fa8c9..8fbc390 100644
}
diff --git a/src/tools/clippy/Cargo.toml b/src/tools/clippy/Cargo.toml
-index 1c875c3..1aad7cf 100644
+index b7e136c..a844a5d 100644
--- a/src/tools/clippy/Cargo.toml
+++ b/src/tools/clippy/Cargo.toml
@@ -36,11 +36,6 @@ walkdir = "2.3"
@@ -202,6 +199,26 @@ index 1c875c3..1aad7cf 100644
# UI test dependencies
clippy_utils = { path = "clippy_utils" }
derive-new = "0.5"
+diff --git a/src/tools/rust-analyzer/Cargo.toml b/src/tools/rust-analyzer/Cargo.toml
+index 6b68ca8..93f755c 100644
+--- a/src/tools/rust-analyzer/Cargo.toml
++++ b/src/tools/rust-analyzer/Cargo.toml
+@@ -1,5 +1,14 @@
+ [workspace]
+-members = ["xtask/", "lib/*", "crates/*"]
++members = [
++ "xtask/",
++ "lib/*",
++ "crates/proc-macro-srv",
++ "crates/proc-macro-srv-cli",
++ "crates/tt",
++ "crates/mbe",
++ "crates/paths",
++ "crates/proc-macro-api",
++]
+ exclude = ["crates/proc-macro-test/imp"]
+
+ [profile.dev]
diff --git a/src/tools/rustfmt/Cargo.toml b/src/tools/rustfmt/Cargo.toml
index 7a4e02d..27b91f2 100644
--- a/src/tools/rustfmt/Cargo.toml
@@ -219,10 +236,10 @@ index 7a4e02d..27b91f2 100644
[package.metadata.rust-analyzer]
diff --git a/src/tools/tidy/src/deps.rs b/src/tools/tidy/src/deps.rs
-index 333f85f..4df2b54 100644
+index cbd8cfa..6b39fd6 100644
--- a/src/tools/tidy/src/deps.rs
+++ b/src/tools/tidy/src/deps.rs
-@@ -306,7 +306,7 @@ const FORBIDDEN_TO_HAVE_DUPLICATES: &[&str] = &[
+@@ -308,7 +308,7 @@ const FORBIDDEN_TO_HAVE_DUPLICATES: &[&str] = &[
// These two crates take quite a long time to build, so don't allow two versions of them
// to accidentally sneak into our dependency graph, in order to ensure we keep our CI times
// under control.
@@ -231,23 +248,3 @@ index 333f85f..4df2b54 100644
];
/// Dependency checks.
-diff --git a/src/tools/rust-analyzer/Cargo.toml b/src.tools/rust-analyzer/Cargo.toml
-index 6b68ca82389..7bc5d1bc5a0 100644
---- a/src/tools/rust-analyzer/Cargo.toml
-+++ b/src/tools/rust-analyzer/Cargo.toml
-@@ -1,5 +1,14 @@
- [workspace]
--members = ["xtask/", "lib/*", "crates/*"]
-+members = [
-+ "xtask/",
-+ "lib/*",
-+ "crates/proc-macro-srv",
-+ "crates/proc-macro-srv-cli",
-+ "crates/tt",
-+ "crates/mbe",
-+ "crates/paths",
-+ "crates/proc-macro-api",
-+]
- exclude = ["crates/proc-macro-test/imp"]
-
- [profile.dev]