summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-0000-ignore-removed-submodules.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-0000-ignore-removed-submodules.patch')
-rw-r--r--debian/patches/d-0000-ignore-removed-submodules.patch130
1 files changed, 30 insertions, 100 deletions
diff --git a/debian/patches/d-0000-ignore-removed-submodules.patch b/debian/patches/d-0000-ignore-removed-submodules.patch
index 588e53b3b..3b11a1b63 100644
--- a/debian/patches/d-0000-ignore-removed-submodules.patch
+++ b/debian/patches/d-0000-ignore-removed-submodules.patch
@@ -18,7 +18,7 @@ Index: rust/Cargo.toml
===================================================================
--- rust.orig/Cargo.toml
+++ rust/Cargo.toml
-@@ -18,28 +18,15 @@ members = [
+@@ -18,28 +18,18 @@ members = [
"src/tools/tidy",
"src/tools/tier-check",
"src/tools/build-manifest",
@@ -26,11 +26,11 @@ Index: rust/Cargo.toml
- "src/tools/remote-test-server",
"src/tools/rust-installer",
"src/tools/rust-demangler",
-- "src/tools/cargo",
-- "src/tools/cargo/crates/credential/cargo-credential-1password",
+ "src/tools/cargo",
+ "src/tools/cargo/crates/credential/cargo-credential-1password",
- "src/tools/cargo/crates/credential/cargo-credential-macos-keychain",
- "src/tools/cargo/crates/credential/cargo-credential-wincred",
-- "src/tools/cargo/crates/mdman",
+ "src/tools/cargo/crates/mdman",
- # "src/tools/cargo/crates/resolver-tests",
"src/tools/rustdoc",
- "src/tools/rls",
@@ -47,16 +47,6 @@ Index: rust/Cargo.toml
"src/tools/replace-version-placeholder",
"src/tools/lld-wrapper",
"src/tools/collect-license-metadata",
-@@ -106,9 +93,6 @@ miniz_oxide.debug = 0
- object.debug = 0
-
- [patch.crates-io]
--# See comments in `src/tools/rustc-workspace-hack/README.md` for what's going on
--# here
--rustc-workspace-hack = { path = 'src/tools/rustc-workspace-hack' }
-
- # See comments in `library/rustc-std-workspace-core/README.md` for what's going on
- # here
Index: rust/src/bootstrap/bootstrap.py
===================================================================
--- rust.orig/src/bootstrap/bootstrap.py
@@ -109,14 +99,14 @@ Index: rust/src/bootstrap/builder.rs
submodules_paths
};
-@@ -658,24 +658,13 @@ impl<'a> Builder<'a> {
+@@ -658,24 +658,14 @@ impl<'a> Builder<'a> {
tool::Linkchecker,
tool::CargoTest,
tool::Compiletest,
- tool::RemoteTestServer,
- tool::RemoteTestClient,
tool::RustInstaller,
-- tool::Cargo,
+ tool::Cargo,
- tool::Rls,
- tool::RustAnalyzer,
tool::RustAnalyzerProcMacroSrv,
@@ -134,7 +124,7 @@ Index: rust/src/bootstrap/builder.rs
),
Kind::Check | Kind::Clippy | Kind::Fix => describe!(
check::Std,
-@@ -683,11 +672,6 @@ impl<'a> Builder<'a> {
+@@ -683,11 +673,6 @@ impl<'a> Builder<'a> {
check::Rustdoc,
check::CodegenBackend,
check::Clippy,
@@ -146,16 +136,15 @@ Index: rust/src/bootstrap/builder.rs
check::Rustfmt,
check::Bootstrap
),
-@@ -717,8 +701,6 @@ impl<'a> Builder<'a> {
- test::TierCheck,
+@@ -717,7 +702,6 @@ impl<'a> Builder<'a> {
test::ReplacePlaceholderTest,
test::Cargotest,
-- test::Cargo,
+ test::Cargo,
- test::RustAnalyzer,
test::ErrorIndex,
test::Distcheck,
test::RunMakeFullDeps,
-@@ -734,7 +716,6 @@ impl<'a> Builder<'a> {
+@@ -734,7 +717,6 @@ impl<'a> Builder<'a> {
test::EmbeddedBook,
test::EditionGuide,
test::Rustfmt,
@@ -163,23 +152,18 @@ Index: rust/src/bootstrap/builder.rs
test::Clippy,
test::RustDemangler,
test::CompiletestTest,
-@@ -767,11 +748,8 @@ impl<'a> Builder<'a> {
- doc::RustdocBook,
- doc::RustByExample,
- doc::RustcBook,
-- doc::Cargo,
-- doc::CargoBook,
+@@ -771,7 +753,6 @@ impl<'a> Builder<'a> {
+ doc::CargoBook,
doc::Clippy,
doc::ClippyBook,
- doc::Miri,
doc::EmbeddedBook,
doc::EditionGuide,
doc::StyleGuide,
-@@ -787,13 +765,9 @@ impl<'a> Builder<'a> {
- dist::RustcDev,
+@@ -787,12 +768,9 @@ impl<'a> Builder<'a> {
dist::Analysis,
dist::Src,
-- dist::Cargo,
+ dist::Cargo,
- dist::Rls,
- dist::RustAnalyzer,
dist::Rustfmt,
@@ -189,11 +173,10 @@ Index: rust/src/bootstrap/builder.rs
dist::LlvmTools,
dist::RustDev,
dist::Bootstrap,
-@@ -809,12 +783,9 @@ impl<'a> Builder<'a> {
- Kind::Install => describe!(
+@@ -809,11 +786,9 @@ impl<'a> Builder<'a> {
install::Docs,
install::Std,
-- install::Cargo,
+ install::Cargo,
- install::RustAnalyzer,
install::Rustfmt,
install::RustDemangler,
@@ -202,7 +185,7 @@ Index: rust/src/bootstrap/builder.rs
install::LlvmTools,
install::Src,
install::Rustc
-@@ -824,7 +795,6 @@ impl<'a> Builder<'a> {
+@@ -824,7 +798,6 @@ impl<'a> Builder<'a> {
run::BuildManifest,
run::BumpStage0,
run::ReplaceVersionPlaceholder,
@@ -210,7 +193,7 @@ Index: rust/src/bootstrap/builder.rs
run::CollectLicenseMetadata,
run::GenerateCopyright,
),
-@@ -1949,10 +1919,7 @@ impl<'a> Builder<'a> {
+@@ -1949,10 +1922,7 @@ impl<'a> Builder<'a> {
}
}
@@ -222,18 +205,6 @@ Index: rust/src/bootstrap/builder.rs
cargo.arg("--frozen");
}
-Index: rust/src/bootstrap/doc.rs
-===================================================================
---- rust.orig/src/bootstrap/doc.rs
-+++ rust/src/bootstrap/doc.rs
-@@ -76,7 +76,6 @@ macro_rules! book {
- // FIXME: Make checking for a submodule automatic somehow (maybe by having a list of all submodules
- // and checking against it?).
- book!(
-- CargoBook, "src/tools/cargo/src/doc", "cargo", submodule = "src/tools/cargo";
- ClippyBook, "src/tools/clippy/book", "clippy";
- EditionGuide, "src/doc/edition-guide", "edition-guide", submodule;
- EmbeddedBook, "src/doc/embedded-book", "embedded-book", submodule;
Index: rust/src/bootstrap/test.rs
===================================================================
--- rust.orig/src/bootstrap/test.rs
@@ -257,22 +228,6 @@ Index: rust/src/bootstrap/test.rs
}
}
-Index: rust/src/tools/clippy/Cargo.toml
-===================================================================
---- rust.orig/src/tools/clippy/Cargo.toml
-+++ rust/src/tools/clippy/Cargo.toml
-@@ -36,11 +36,6 @@ walkdir = "2.3"
- # This is used by the `collect-metadata` alias.
- filetime = "0.2"
-
--# A noop dependency that changes in the Rust repository, it's a bit of a hack.
--# See the `src/tools/rustc-workspace-hack/README.md` file in `rust-lang/rust`
--# for more information.
--rustc-workspace-hack = "1.0"
--
- # UI test dependencies
- clap = { version = "4.1.4", features = ["derive"] }
- clippy_utils = { path = "clippy_utils" }
Index: rust/src/tools/rust-analyzer/Cargo.toml
===================================================================
--- rust.orig/src/tools/rust-analyzer/Cargo.toml
@@ -293,41 +248,16 @@ Index: rust/src/tools/rust-analyzer/Cargo.toml
exclude = ["crates/proc-macro-test/imp"]
[workspace.package]
-Index: rust/src/tools/rustfmt/Cargo.toml
-===================================================================
---- rust.orig/src/tools/rustfmt/Cargo.toml
-+++ rust/src/tools/rustfmt/Cargo.toml
-@@ -59,11 +59,6 @@ unicode_categories = "0.1"
-
- rustfmt-config_proc_macro = { version = "0.3", path = "config_proc_macro" }
-
--# A noop dependency that changes in the Rust repository, it's a bit of a hack.
--# See the `src/tools/rustc-workspace-hack/README.md` file in `rust-lang/rust`
--# for more information.
--rustc-workspace-hack = "1.0.0"
--
- # Rustc dependencies are loaded from the sysroot, Cargo doesn't know about them.
-
- [package.metadata.rust-analyzer]
-Index: rust/src/tools/tidy/src/deps.rs
+Index: rust/src/tools/rustc-workspace-hack/Cargo.toml
===================================================================
---- rust.orig/src/tools/tidy/src/deps.rs
-+++ rust/src/tools/tidy/src/deps.rs
-@@ -337,7 +337,7 @@ const FORBIDDEN_TO_HAVE_DUPLICATES: &[&s
- // This crate takes quite a long time to build, so don't allow two versions of them
- // to accidentally sneak into our dependency graph, in order to ensure we keep our CI times
- // under control.
-- "cargo",
-+ //"cargo",
- ];
-
- /// Dependency checks.
-@@ -613,6 +613,8 @@ fn direct_deps_of<'a>(metadata: &'a Meta
- }
-
- fn check_rustfix(metadata: &Metadata, bad: &mut bool) {
-+ // Debian: we don't build cargo here, so this function doens't function.
-+ return;
- let cargo = pkg_from_name(metadata, "cargo");
- let compiletest = pkg_from_name(metadata, "compiletest");
- let cargo_deps = direct_deps_of(metadata, &cargo.id);
+--- rust.orig/src/tools/rustc-workspace-hack/Cargo.toml
++++ rust/src/tools/rustc-workspace-hack/Cargo.toml
+@@ -74,7 +74,7 @@ features = [
+ [dependencies]
+ bstr = { version = "0.2.17", features = ["default"] }
+ clap = { version = "3.1.1", features = ["derive", "clap_derive"]}
+-curl-sys = { version = "0.4.13", features = ["http2", "libnghttp2-sys"], optional = true }
++curl-sys = { version = "0.4.13", features = ["http2"], optional = true }
+ # Ensure `extra_traits` of libc, which is used transitively by Cargo.
+ libc = { version = "0.2", features = ["extra_traits"] }
+ # Ensure `js` of getrandom, which is (unfortunately) used transitively by Cargo.