summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-0000-ignore-removed-submodules.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-0000-ignore-removed-submodules.patch')
-rw-r--r--debian/patches/d-0000-ignore-removed-submodules.patch190
1 files changed, 133 insertions, 57 deletions
diff --git a/debian/patches/d-0000-ignore-removed-submodules.patch b/debian/patches/d-0000-ignore-removed-submodules.patch
index 2f1c323c3..588e53b3b 100644
--- a/debian/patches/d-0000-ignore-removed-submodules.patch
+++ b/debian/patches/d-0000-ignore-removed-submodules.patch
@@ -14,11 +14,11 @@ Subject: d-0000-ignore-removed-submodules
src/tools/tidy/src/deps.rs | 4 +++-
9 files changed, 15 insertions(+), 62 deletions(-)
-diff --git a/Cargo.toml b/Cargo.toml
-index 15cbb26..c012319 100644
---- a/Cargo.toml
-+++ b/Cargo.toml
-@@ -18,29 +18,15 @@ members = [
+Index: rust/Cargo.toml
+===================================================================
+--- rust.orig/Cargo.toml
++++ rust/Cargo.toml
+@@ -18,28 +18,15 @@ members = [
"src/tools/tidy",
"src/tools/tier-check",
"src/tools/build-manifest",
@@ -44,11 +44,10 @@ index 15cbb26..c012319 100644
"src/tools/jsondoclint",
"src/tools/html-checker",
- "src/tools/bump-stage0",
-- "src/tools/replace-version-placeholder",
+ "src/tools/replace-version-placeholder",
"src/tools/lld-wrapper",
"src/tools/collect-license-metadata",
- "src/tools/generate-copyright",
-@@ -105,9 +91,6 @@ miniz_oxide.debug = 0
+@@ -106,9 +93,6 @@ miniz_oxide.debug = 0
object.debug = 0
[patch.crates-io]
@@ -58,11 +57,11 @@ index 15cbb26..c012319 100644
# See comments in `library/rustc-std-workspace-core/README.md` for what's going on
# here
-diff --git a/src/bootstrap/bootstrap.py b/src/bootstrap/bootstrap.py
-index 013d1ab..f6fd37b 100644
---- a/src/bootstrap/bootstrap.py
-+++ b/src/bootstrap/bootstrap.py
-@@ -777,10 +777,6 @@ class RustBuild(object):
+Index: rust/src/bootstrap/bootstrap.py
+===================================================================
+--- rust.orig/src/bootstrap/bootstrap.py
++++ rust/src/bootstrap/bootstrap.py
+@@ -781,10 +781,6 @@ class RustBuild(object):
args = [self.cargo(), "build", "--manifest-path",
os.path.join(self.rust_root, "src/bootstrap/Cargo.toml")]
args.extend("--verbose" for _ in range(verbose_count))
@@ -73,23 +72,73 @@ index 013d1ab..f6fd37b 100644
if self.get_toml("metrics", "build"):
args.append("--features")
args.append("build-metrics")
-diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
-index b33fc02..4492577 100644
---- a/src/bootstrap/builder.rs
-+++ b/src/bootstrap/builder.rs
-@@ -629,8 +629,6 @@ impl<'a> Builder<'a> {
- tool::RemoteTestClient,
+Index: rust/src/bootstrap/builder.rs
+===================================================================
+--- rust.orig/src/bootstrap/builder.rs
++++ rust/src/bootstrap/builder.rs
+@@ -491,20 +491,20 @@ impl<'a> ShouldRun<'a> {
+ static SUBMODULES_PATHS: OnceCell<Vec<String>> = OnceCell::new();
+
+ let init_submodules_paths = |src: &PathBuf| {
+- let file = File::open(src.join(".gitmodules")).unwrap();
++ //let file = File::open(src.join(".gitmodules")).unwrap();
+
+ let mut submodules_paths = vec![];
+- for line in BufReader::new(file).lines() {
+- if let Ok(line) = line {
+- let line = line.trim();
+-
+- if line.starts_with("path") {
+- let actual_path =
+- line.split(' ').last().expect("Couldn't get value of path");
+- submodules_paths.push(actual_path.to_owned());
+- }
+- }
+- }
++ //for line in BufReader::new(file).lines() {
++ // if let Ok(line) = line {
++ // let line = line.trim();
++
++ // if line.starts_with("path") {
++ // let actual_path =
++ // line.split(' ').last().expect("Couldn't get value of path");
++ // submodules_paths.push(actual_path.to_owned());
++ // }
++ // }
++ //}
+
+ submodules_paths
+ };
+@@ -658,24 +658,13 @@ impl<'a> Builder<'a> {
+ tool::Linkchecker,
+ tool::CargoTest,
+ tool::Compiletest,
+- tool::RemoteTestServer,
+- tool::RemoteTestClient,
tool::RustInstaller,
- tool::Cargo,
+- tool::Cargo,
- tool::Rls,
- tool::RustAnalyzer,
tool::RustAnalyzerProcMacroSrv,
tool::RustDemangler,
tool::Rustdoc,
-@@ -651,10 +649,6 @@ impl<'a> Builder<'a> {
+ tool::Clippy,
+ tool::CargoClippy,
+- llvm::Llvm,
+- llvm::Sanitizers,
+ tool::Rustfmt,
+- tool::Miri,
+- tool::CargoMiri,
+- llvm::Lld,
+- llvm::CrtBeginEnd
+ ),
+ Kind::Check | Kind::Clippy | Kind::Fix => describe!(
+ check::Std,
+@@ -683,11 +672,6 @@ impl<'a> Builder<'a> {
+ check::Rustdoc,
check::CodegenBackend,
check::Clippy,
- check::Miri,
+- check::Miri,
- check::CargoMiri,
- check::MiroptTestTools,
- check::Rls,
@@ -97,15 +146,24 @@ index b33fc02..4492577 100644
check::Rustfmt,
check::Bootstrap
),
-@@ -684,7 +678,6 @@ impl<'a> Builder<'a> {
+@@ -717,8 +701,6 @@ impl<'a> Builder<'a> {
+ test::TierCheck,
test::ReplacePlaceholderTest,
test::Cargotest,
- test::Cargo,
+- test::Cargo,
- test::RustAnalyzer,
test::ErrorIndex,
test::Distcheck,
test::RunMakeFullDeps,
-@@ -732,11 +725,8 @@ impl<'a> Builder<'a> {
+@@ -734,7 +716,6 @@ impl<'a> Builder<'a> {
+ test::EmbeddedBook,
+ test::EditionGuide,
+ test::Rustfmt,
+- test::Miri,
+ test::Clippy,
+ test::RustDemangler,
+ test::CompiletestTest,
+@@ -767,11 +748,8 @@ impl<'a> Builder<'a> {
doc::RustdocBook,
doc::RustByExample,
doc::RustcBook,
@@ -117,24 +175,42 @@ index b33fc02..4492577 100644
doc::EmbeddedBook,
doc::EditionGuide,
doc::StyleGuide,
-@@ -752,8 +742,6 @@ impl<'a> Builder<'a> {
+@@ -787,13 +765,9 @@ impl<'a> Builder<'a> {
+ dist::RustcDev,
dist::Analysis,
dist::Src,
- dist::Cargo,
+- dist::Cargo,
- dist::Rls,
- dist::RustAnalyzer,
dist::Rustfmt,
dist::RustDemangler,
dist::Clippy,
-@@ -774,7 +762,6 @@ impl<'a> Builder<'a> {
+- dist::Miri,
+ dist::LlvmTools,
+ dist::RustDev,
+ dist::Bootstrap,
+@@ -809,12 +783,9 @@ impl<'a> Builder<'a> {
+ Kind::Install => describe!(
install::Docs,
install::Std,
- install::Cargo,
+- install::Cargo,
- install::RustAnalyzer,
install::Rustfmt,
install::RustDemangler,
install::Clippy,
-@@ -1878,10 +1865,7 @@ impl<'a> Builder<'a> {
+- install::Miri,
+ install::LlvmTools,
+ install::Src,
+ install::Rustc
+@@ -824,7 +795,6 @@ impl<'a> Builder<'a> {
+ run::BuildManifest,
+ run::BumpStage0,
+ run::ReplaceVersionPlaceholder,
+- run::Miri,
+ run::CollectLicenseMetadata,
+ run::GenerateCopyright,
+ ),
+@@ -1949,10 +1919,7 @@ impl<'a> Builder<'a> {
}
}
@@ -146,10 +222,10 @@ index b33fc02..4492577 100644
cargo.arg("--frozen");
}
-diff --git a/src/bootstrap/doc.rs b/src/bootstrap/doc.rs
-index cc80763..19754a2 100644
---- a/src/bootstrap/doc.rs
-+++ b/src/bootstrap/doc.rs
+Index: rust/src/bootstrap/doc.rs
+===================================================================
+--- rust.orig/src/bootstrap/doc.rs
++++ rust/src/bootstrap/doc.rs
@@ -76,7 +76,6 @@ macro_rules! book {
// FIXME: Make checking for a submodule automatic somehow (maybe by having a list of all submodules
// and checking against it?).
@@ -158,11 +234,11 @@ index cc80763..19754a2 100644
ClippyBook, "src/tools/clippy/book", "clippy";
EditionGuide, "src/doc/edition-guide", "edition-guide", submodule;
EmbeddedBook, "src/doc/embedded-book", "embedded-book", submodule;
-diff --git a/src/bootstrap/test.rs b/src/bootstrap/test.rs
-index b4f1506..27236f3 100644
---- a/src/bootstrap/test.rs
-+++ b/src/bootstrap/test.rs
-@@ -2024,17 +2024,7 @@ impl Step for RustcGuide {
+Index: rust/src/bootstrap/test.rs
+===================================================================
+--- rust.orig/src/bootstrap/test.rs
++++ rust/src/bootstrap/test.rs
+@@ -2070,17 +2070,7 @@ impl Step for RustcGuide {
}
fn run(self, builder: &Builder<'_>) {
@@ -181,10 +257,10 @@ index b4f1506..27236f3 100644
}
}
-diff --git a/src/tools/clippy/Cargo.toml b/src/tools/clippy/Cargo.toml
-index 70d1268..c7c6c3e 100644
---- a/src/tools/clippy/Cargo.toml
-+++ b/src/tools/clippy/Cargo.toml
+Index: rust/src/tools/clippy/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/clippy/Cargo.toml
++++ rust/src/tools/clippy/Cargo.toml
@@ -36,11 +36,6 @@ walkdir = "2.3"
# This is used by the `collect-metadata` alias.
filetime = "0.2"
@@ -197,10 +273,10 @@ index 70d1268..c7c6c3e 100644
# UI test dependencies
clap = { version = "4.1.4", features = ["derive"] }
clippy_utils = { path = "clippy_utils" }
-diff --git a/src/tools/rust-analyzer/Cargo.toml b/src/tools/rust-analyzer/Cargo.toml
-index 333f03c..2a0faa2 100644
---- a/src/tools/rust-analyzer/Cargo.toml
-+++ b/src/tools/rust-analyzer/Cargo.toml
+Index: rust/src/tools/rust-analyzer/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/rust-analyzer/Cargo.toml
++++ rust/src/tools/rust-analyzer/Cargo.toml
@@ -1,5 +1,14 @@
[workspace]
-members = ["xtask/", "lib/*", "crates/*"]
@@ -217,10 +293,10 @@ index 333f03c..2a0faa2 100644
exclude = ["crates/proc-macro-test/imp"]
[workspace.package]
-diff --git a/src/tools/rustfmt/Cargo.toml b/src/tools/rustfmt/Cargo.toml
-index 87ce59d..12ed654 100644
---- a/src/tools/rustfmt/Cargo.toml
-+++ b/src/tools/rustfmt/Cargo.toml
+Index: rust/src/tools/rustfmt/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/rustfmt/Cargo.toml
++++ rust/src/tools/rustfmt/Cargo.toml
@@ -59,11 +59,6 @@ unicode_categories = "0.1"
rustfmt-config_proc_macro = { version = "0.3", path = "config_proc_macro" }
@@ -233,11 +309,11 @@ index 87ce59d..12ed654 100644
# Rustc dependencies are loaded from the sysroot, Cargo doesn't know about them.
[package.metadata.rust-analyzer]
-diff --git a/src/tools/tidy/src/deps.rs b/src/tools/tidy/src/deps.rs
-index bddfdcf..9bac4b7 100644
---- a/src/tools/tidy/src/deps.rs
-+++ b/src/tools/tidy/src/deps.rs
-@@ -333,7 +333,7 @@ const FORBIDDEN_TO_HAVE_DUPLICATES: &[&str] = &[
+Index: rust/src/tools/tidy/src/deps.rs
+===================================================================
+--- rust.orig/src/tools/tidy/src/deps.rs
++++ rust/src/tools/tidy/src/deps.rs
+@@ -337,7 +337,7 @@ const FORBIDDEN_TO_HAVE_DUPLICATES: &[&s
// This crate takes quite a long time to build, so don't allow two versions of them
// to accidentally sneak into our dependency graph, in order to ensure we keep our CI times
// under control.
@@ -246,7 +322,7 @@ index bddfdcf..9bac4b7 100644
];
/// Dependency checks.
-@@ -609,6 +609,8 @@ fn direct_deps_of<'a>(metadata: &'a Metadata, pkg_id: &'a PackageId) -> Vec<&'a
+@@ -613,6 +613,8 @@ fn direct_deps_of<'a>(metadata: &'a Meta
}
fn check_rustfix(metadata: &Metadata, bad: &mut bool) {