summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-0000-ignore-removed-submodules.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-0000-ignore-removed-submodules.patch')
-rw-r--r--debian/patches/d-0000-ignore-removed-submodules.patch51
1 files changed, 22 insertions, 29 deletions
diff --git a/debian/patches/d-0000-ignore-removed-submodules.patch b/debian/patches/d-0000-ignore-removed-submodules.patch
index 26d1e4361..7fdae2bd9 100644
--- a/debian/patches/d-0000-ignore-removed-submodules.patch
+++ b/debian/patches/d-0000-ignore-removed-submodules.patch
@@ -5,14 +5,14 @@ Subject: d-0000-ignore-removed-submodules
---
Cargo.toml | 15 ---------------
src/bootstrap/bootstrap.py | 4 ----
- src/bootstrap/builder.rs | 11 +----------
+ src/bootstrap/builder.rs | 15 +--------------
src/bootstrap/doc.rs | 1 -
src/bootstrap/test.rs | 12 +-----------
src/tools/clippy/Cargo.toml | 5 -----
src/tools/rust-analyzer/Cargo.toml | 11 ++++++++++-
src/tools/rustfmt/Cargo.toml | 5 -----
src/tools/tidy/src/deps.rs | 2 +-
- 9 files changed, 13 insertions(+), 53 deletions(-)
+ 9 files changed, 13 insertions(+), 57 deletions(-)
diff --git a/Cargo.toml b/Cargo.toml
index e49fe5e..863c800 100644
@@ -57,10 +57,10 @@ index e49fe5e..863c800 100644
# See comments in `library/rustc-std-workspace-core/README.md` for what's going on
# here
diff --git a/src/bootstrap/bootstrap.py b/src/bootstrap/bootstrap.py
-index cc08ae5..bf7d696 100644
+index 5712868..5a6ab27 100644
--- a/src/bootstrap/bootstrap.py
+++ b/src/bootstrap/bootstrap.py
-@@ -759,10 +759,6 @@ class RustBuild(object):
+@@ -766,10 +766,6 @@ class RustBuild(object):
os.path.join(self.rust_root, "src/bootstrap/Cargo.toml")]
for _ in range(0, self.verbose):
args.append("--verbose")
@@ -72,10 +72,10 @@ index cc08ae5..bf7d696 100644
args.append("--features")
args.append("build-metrics")
diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
-index 14e8ebd..6d43333 100644
+index 8b144f1..c4bed1ec 100644
--- a/src/bootstrap/builder.rs
+++ b/src/bootstrap/builder.rs
-@@ -600,8 +600,6 @@ impl<'a> Builder<'a> {
+@@ -599,8 +599,6 @@ impl<'a> Builder<'a> {
tool::RemoteTestClient,
tool::RustInstaller,
tool::Cargo,
@@ -84,7 +84,7 @@ index 14e8ebd..6d43333 100644
tool::RustAnalyzerProcMacroSrv,
tool::RustDemangler,
tool::Rustdoc,
-@@ -622,8 +621,6 @@ impl<'a> Builder<'a> {
+@@ -621,8 +619,6 @@ impl<'a> Builder<'a> {
check::CodegenBackend,
check::Clippy,
check::Miri,
@@ -93,7 +93,7 @@ index 14e8ebd..6d43333 100644
check::Rustfmt,
check::Bootstrap
),
-@@ -650,7 +648,6 @@ impl<'a> Builder<'a> {
+@@ -650,7 +646,6 @@ impl<'a> Builder<'a> {
test::ReplacePlaceholderTest,
test::Cargotest,
test::Cargo,
@@ -101,7 +101,7 @@ index 14e8ebd..6d43333 100644
test::ErrorIndex,
test::Distcheck,
test::RunMakeFullDeps,
-@@ -698,10 +695,8 @@ impl<'a> Builder<'a> {
+@@ -698,10 +693,8 @@ impl<'a> Builder<'a> {
doc::RustdocBook,
doc::RustByExample,
doc::RustcBook,
@@ -111,8 +111,8 @@ index 14e8ebd..6d43333 100644
- doc::Miri,
doc::EmbeddedBook,
doc::EditionGuide,
- ),
-@@ -715,15 +712,12 @@ impl<'a> Builder<'a> {
+ doc::StyleGuide,
+@@ -717,8 +710,6 @@ impl<'a> Builder<'a> {
dist::Analysis,
dist::Src,
dist::Cargo,
@@ -121,14 +121,7 @@ index 14e8ebd..6d43333 100644
dist::Rustfmt,
dist::RustDemangler,
dist::Clippy,
- dist::Miri,
- dist::LlvmTools,
- dist::RustDev,
-- dist::Extended,
- // It seems that PlainSourceTarball somehow changes how some of the tools
- // perceive their dependencies (see #93033) which would invalidate fingerprints
- // and force us to rebuild tools after vendoring dependencies.
-@@ -736,7 +725,6 @@ impl<'a> Builder<'a> {
+@@ -739,7 +730,6 @@ impl<'a> Builder<'a> {
install::Docs,
install::Std,
install::Cargo,
@@ -136,7 +129,7 @@ index 14e8ebd..6d43333 100644
install::Rustfmt,
install::RustDemangler,
install::Clippy,
-@@ -2056,10 +2050,7 @@ impl<'a> Builder<'a> {
+@@ -2062,10 +2052,7 @@ impl<'a> Builder<'a> {
}
}
@@ -149,10 +142,10 @@ index 14e8ebd..6d43333 100644
}
diff --git a/src/bootstrap/doc.rs b/src/bootstrap/doc.rs
-index f909ecc..8bf71b1 100644
+index ea06caf..5d8247f 100644
--- a/src/bootstrap/doc.rs
+++ b/src/bootstrap/doc.rs
-@@ -73,7 +73,6 @@ macro_rules! book {
+@@ -74,7 +74,6 @@ macro_rules! book {
// FIXME: Make checking for a submodule automatic somehow (maybe by having a list of all submodules
// and checking against it?).
book!(
@@ -161,10 +154,10 @@ index f909ecc..8bf71b1 100644
EditionGuide, "src/doc/edition-guide", "edition-guide", submodule;
EmbeddedBook, "src/doc/embedded-book", "embedded-book", submodule;
diff --git a/src/bootstrap/test.rs b/src/bootstrap/test.rs
-index dd41f84..ba6227c 100644
+index 791c35c..964e2e0 100644
--- a/src/bootstrap/test.rs
+++ b/src/bootstrap/test.rs
-@@ -1886,17 +1886,7 @@ impl Step for RustcGuide {
+@@ -1909,17 +1909,7 @@ impl Step for RustcGuide {
}
fn run(self, builder: &Builder<'_>) {
@@ -184,7 +177,7 @@ index dd41f84..ba6227c 100644
}
diff --git a/src/tools/clippy/Cargo.toml b/src/tools/clippy/Cargo.toml
-index b7e136c..a844a5d 100644
+index 60200a8..3980db9 100644
--- a/src/tools/clippy/Cargo.toml
+++ b/src/tools/clippy/Cargo.toml
@@ -36,11 +36,6 @@ walkdir = "2.3"
@@ -200,7 +193,7 @@ index b7e136c..a844a5d 100644
clippy_utils = { path = "clippy_utils" }
derive-new = "0.5"
diff --git a/src/tools/rust-analyzer/Cargo.toml b/src/tools/rust-analyzer/Cargo.toml
-index 6b68ca8..93f755c 100644
+index 286ef1e..3d68711 100644
--- a/src/tools/rust-analyzer/Cargo.toml
+++ b/src/tools/rust-analyzer/Cargo.toml
@@ -1,5 +1,14 @@
@@ -236,11 +229,11 @@ index 7a4e02d..27b91f2 100644
[package.metadata.rust-analyzer]
diff --git a/src/tools/tidy/src/deps.rs b/src/tools/tidy/src/deps.rs
-index cbd8cfa..6b39fd6 100644
+index 8a0239e..9b35cba 100644
--- a/src/tools/tidy/src/deps.rs
+++ b/src/tools/tidy/src/deps.rs
-@@ -308,7 +308,7 @@ const FORBIDDEN_TO_HAVE_DUPLICATES: &[&str] = &[
- // These two crates take quite a long time to build, so don't allow two versions of them
+@@ -311,7 +311,7 @@ const FORBIDDEN_TO_HAVE_DUPLICATES: &[&str] = &[
+ // This crate takes quite a long time to build, so don't allow two versions of them
// to accidentally sneak into our dependency graph, in order to ensure we keep our CI times
// under control.
- "cargo",