summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-0004-clippy-feature-sync.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-0004-clippy-feature-sync.patch')
-rw-r--r--debian/patches/d-0004-clippy-feature-sync.patch37
1 files changed, 37 insertions, 0 deletions
diff --git a/debian/patches/d-0004-clippy-feature-sync.patch b/debian/patches/d-0004-clippy-feature-sync.patch
new file mode 100644
index 000000000..8c0c0fb97
--- /dev/null
+++ b/debian/patches/d-0004-clippy-feature-sync.patch
@@ -0,0 +1,37 @@
+From: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
+Date: Sat, 2 Oct 2021 01:08:00 +0100
+Subject: d-0004-clippy-feature-sync
+
+enable features needed by rustfmt to make build system happy and speedup build.
+this is what rustc_workspace_hack does in the upstream build.
+---
+ src/tools/clippy/Cargo.toml | 3 ++-
+ src/tools/rustfmt/Cargo.toml | 2 +-
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/src/tools/clippy/Cargo.toml b/src/tools/clippy/Cargo.toml
+index 1aad7cf..705a880 100644
+--- a/src/tools/clippy/Cargo.toml
++++ b/src/tools/clippy/Cargo.toml
+@@ -42,7 +43,7 @@ if_chain = "1.0"
+ itertools = "0.10.1"
+ quote = "1.0"
+ serde = { version = "1.0.125", features = ["derive"] }
+-syn = { version = "1.0", features = ["full"] }
++syn = { version = "1.0", features = ["full", "visit"] }
+ futures = "0.3"
+ parking_lot = "0.12"
+ tokio = { version = "1", features = ["io-util"] }
+diff --git a/src/tools/rustfmt/Cargo.toml b/src/tools/rustfmt/Cargo.toml
+index 27b91f2..12d1567 100644
+--- a/src/tools/rustfmt/Cargo.toml
++++ b/src/tools/rustfmt/Cargo.toml
+@@ -49,7 +49,7 @@ lazy_static = "1.4"
+ log = "0.4"
+ regex = "1.5"
+ serde = { version = "1.0", features = ["derive"] }
+-serde_json = "1.0"
++serde_json = { version = "1.0", features = ["unbounded_depth"] }
+ term = "0.7"
+ thiserror = "1.0"
+ toml = "0.5"