summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-0005-no-jemalloc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-0005-no-jemalloc.patch')
-rw-r--r--debian/patches/d-0005-no-jemalloc.patch46
1 files changed, 46 insertions, 0 deletions
diff --git a/debian/patches/d-0005-no-jemalloc.patch b/debian/patches/d-0005-no-jemalloc.patch
new file mode 100644
index 000000000..6d8620a01
--- /dev/null
+++ b/debian/patches/d-0005-no-jemalloc.patch
@@ -0,0 +1,46 @@
+From: Debian Rust Maintainers <pkg-rust-maintainers@alioth-lists.debian.net>
+Date: Sat, 2 Oct 2021 01:08:00 +0100
+Subject: d-0005-no-jemalloc
+
+---
+ compiler/rustc/Cargo.toml | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/compiler/rustc/Cargo.toml b/compiler/rustc/Cargo.toml
+index 27ee3dd..87fb29f 100644
+--- a/compiler/rustc/Cargo.toml
++++ b/compiler/rustc/Cargo.toml
+@@ -13,13 +13,7 @@ rustc_codegen_ssa = { path = "../rustc_codegen_ssa" }
+ # crate is intended to be used by stable MIR consumers, which are not in-tree
+ rustc_smir = { path = "../rustc_smir" }
+
+-[dependencies.jemalloc-sys]
+-version = "0.5.0"
+-optional = true
+-features = ['unprefixed_malloc_on_supported_platforms']
+-
+ [features]
+-jemalloc = ['jemalloc-sys']
+ llvm = ['rustc_driver/llvm']
+ max_level_info = ['rustc_driver/max_level_info']
+ rustc_use_parallel_compiler = ['rustc_driver/rustc_use_parallel_compiler']
+diff --git a/src/tools/rust-analyzer/crates/profile/Cargo.toml b/src/tools/rust-analyzer/crates/profile/Cargo.toml
+index 99d4179dc20..0b78a45a24b 100644
+--- a/src/tools/rust-analyzer/crates/profile/Cargo.toml
++++ b/src/tools/rust-analyzer/crates/profile/Cargo.toml
+@@ -15,7 +15,6 @@ cfg-if = "1.0.0"
+ libc = "0.2.126"
+ la-arena = { version = "0.3.0", path = "../../lib/la-arena" }
+ countme = { version = "3.0.1", features = ["enable"] }
+-jemalloc-ctl = { version = "0.5.0", package = "tikv-jemalloc-ctl", optional = true }
+
+ [target.'cfg(target_os = "linux")'.dependencies]
+ perf-event = "0.4.7"
+@@ -24,7 +25,6 @@ winapi = { version = "0.3.9", features = ["processthreadsapi", "psapi"] }
+
+ [features]
+ cpu_profiler = []
+-jemalloc = ["jemalloc-ctl"]
+
+ # Uncomment to enable for the whole crate graph
+ # default = [ "cpu_profiler" ]