summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-0020-remove-windows-dependencies.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-0020-remove-windows-dependencies.patch')
-rw-r--r--debian/patches/d-0020-remove-windows-dependencies.patch213
1 files changed, 213 insertions, 0 deletions
diff --git a/debian/patches/d-0020-remove-windows-dependencies.patch b/debian/patches/d-0020-remove-windows-dependencies.patch
new file mode 100644
index 000000000..0e5230716
--- /dev/null
+++ b/debian/patches/d-0020-remove-windows-dependencies.patch
@@ -0,0 +1,213 @@
+Index: rust/compiler/rustc_data_structures/Cargo.toml
+===================================================================
+--- rust.orig/compiler/rustc_data_structures/Cargo.toml
++++ rust/compiler/rustc_data_structures/Cargo.toml
+@@ -38,16 +38,6 @@ itertools = "0.10.1"
+ [dependencies.parking_lot]
+ version = "0.11"
+
+-[target.'cfg(windows)'.dependencies.windows]
+-version = "0.46.0"
+-features = [
+- "Win32_Foundation",
+- "Win32_Storage_FileSystem",
+- "Win32_System_IO",
+- "Win32_System_ProcessStatus",
+- "Win32_System_Threading",
+-]
+-
+ [target.'cfg(not(target_arch = "wasm32"))'.dependencies]
+ memmap2 = "0.2.1"
+
+Index: rust/compiler/rustc_driver_impl/Cargo.toml
+===================================================================
+--- rust.orig/compiler/rustc_driver_impl/Cargo.toml
++++ rust/compiler/rustc_driver_impl/Cargo.toml
+@@ -54,12 +54,6 @@ rustc_hir_analysis = { path = "../rustc_
+ [target.'cfg(unix)'.dependencies]
+ libc = "0.2"
+
+-[target.'cfg(windows)'.dependencies.windows]
+-version = "0.46.0"
+-features = [
+- "Win32_System_Diagnostics_Debug",
+-]
+-
+ [features]
+ llvm = ['rustc_interface/llvm']
+ max_level_info = ['rustc_log/max_level_info']
+Index: rust/compiler/rustc_errors/Cargo.toml
+===================================================================
+--- rust.orig/compiler/rustc_errors/Cargo.toml
++++ rust/compiler/rustc_errors/Cargo.toml
+@@ -25,14 +25,5 @@ termize = "0.1.1"
+ serde = { version = "1.0.125", features = [ "derive" ] }
+ serde_json = "1.0.59"
+
+-[target.'cfg(windows)'.dependencies.windows]
+-version = "0.46.0"
+-features = [
+- "Win32_Foundation",
+- "Win32_Security",
+- "Win32_System_Threading",
+- "Win32_System_WindowsProgramming",
+-]
+-
+ [features]
+ rustc_use_parallel_compiler = ['rustc_error_messages/rustc_use_parallel_compiler']
+Index: rust/compiler/rustc_session/Cargo.toml
+===================================================================
+--- rust.orig/compiler/rustc_session/Cargo.toml
++++ rust/compiler/rustc_session/Cargo.toml
+@@ -23,10 +23,3 @@ termize = "0.1.1"
+
+ [target.'cfg(unix)'.dependencies]
+ libc = "0.2"
+-
+-[target.'cfg(windows)'.dependencies.windows]
+-version = "0.46.0"
+-features = [
+- "Win32_Foundation",
+- "Win32_System_LibraryLoader",
+-]
+Index: rust/src/bootstrap/Cargo.toml
+===================================================================
+--- rust.orig/src/bootstrap/Cargo.toml
++++ rust/src/bootstrap/Cargo.toml
+@@ -61,25 +61,6 @@ sysinfo = { version = "0.26.0", optional
+ [target.'cfg(not(target_os = "solaris"))'.dependencies]
+ fd-lock = "3.0.8"
+
+-[target.'cfg(windows)'.dependencies.junction]
+-version = "1.0.0"
+-
+-[target.'cfg(windows)'.dependencies.windows]
+-version = "0.46.0"
+-features = [
+- "Win32_Foundation",
+- "Win32_Security",
+- "Win32_Storage_FileSystem",
+- "Win32_System_Diagnostics_Debug",
+- "Win32_System_IO",
+- "Win32_System_Ioctl",
+- "Win32_System_JobObjects",
+- "Win32_System_ProcessStatus",
+- "Win32_System_SystemServices",
+- "Win32_System_Threading",
+- "Win32_System_Time",
+-]
+-
+ [dev-dependencies]
+ pretty_assertions = "1.2"
+
+Index: rust/src/tools/compiletest/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/compiletest/Cargo.toml
++++ rust/src/tools/compiletest/Cargo.toml
+@@ -23,13 +23,3 @@ lazycell = "1.3.0"
+
+ [target.'cfg(unix)'.dependencies]
+ libc = "0.2"
+-
+-[target.'cfg(windows)'.dependencies]
+-miow = "0.5"
+-
+-[target.'cfg(windows)'.dependencies.windows]
+-version = "0.46.0"
+-features = [
+- "Win32_Foundation",
+- "Win32_System_Diagnostics_Debug",
+-]
+Index: rust/src/tools/rust-analyzer/crates/stdx/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/rust-analyzer/crates/stdx/Cargo.toml
++++ rust/src/tools/rust-analyzer/crates/stdx/Cargo.toml
+@@ -17,10 +17,6 @@ backtrace = { version = "0.3.65", option
+ always-assert = { version = "0.1.2", features = ["log"] }
+ # Think twice before adding anything here
+
+-[target.'cfg(windows)'.dependencies]
+-miow = "0.5.0"
+-winapi = { version = "0.3.9", features = ["winerror"] }
+-
+ [features]
+ # Uncomment to enable for the whole crate graph
+ # default = [ "backtrace" ]
+Index: rust/src/tools/rust-analyzer/crates/rust-analyzer/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/rust-analyzer/crates/rust-analyzer/Cargo.toml
++++ rust/src/tools/rust-analyzer/crates/rust-analyzer/Cargo.toml
+@@ -67,12 +67,6 @@ tt.workspace = true
+ vfs-notify.workspace = true
+ vfs.workspace = true
+
+-[target.'cfg(windows)'.dependencies]
+-winapi = "0.3.9"
+-
+-[target.'cfg(not(target_env = "msvc"))'.dependencies]
+-jemallocator = { version = "0.5.0", package = "tikv-jemallocator", optional = true }
+-
+ [dev-dependencies]
+ expect-test = "1.4.0"
+ jod-thread = "0.1.2"
+Index: rust/src/tools/cargo/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/cargo/Cargo.toml
++++ rust/src/tools/cargo/Cargo.toml
+@@ -82,22 +82,6 @@ walkdir = "2.2"
+ # for more information.
+ rustc-workspace-hack = "1.0.0"
+
+-[target.'cfg(windows)'.dependencies]
+-fwdansi = "1.1.0"
+-
+-[target.'cfg(windows)'.dependencies.windows-sys]
+-version = "0.45"
+-features = [
+- "Win32_Foundation",
+- "Win32_Storage_FileSystem",
+- "Win32_System_Console",
+- "Win32_System_IO",
+- "Win32_System_Threading",
+- "Win32_System_JobObjects",
+- "Win32_Security",
+- "Win32_System_SystemServices"
+-]
+-
+ [dev-dependencies]
+ cargo-test-macro = { path = "crates/cargo-test-macro" }
+ cargo-test-support = { path = "crates/cargo-test-support" }
+Index: rust/src/tools/cargo/crates/cargo-util/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/cargo/crates/cargo-util/Cargo.toml
++++ rust/src/tools/cargo/crates/cargo-util/Cargo.toml
+@@ -22,7 +22,3 @@ walkdir = "2.3.1"
+
+ [target.'cfg(target_os = "macos")'.dependencies]
+ core-foundation = { version = "0.9.0", features = ["mac_os_10_7_support"] }
+-
+-[target.'cfg(windows)'.dependencies]
+-miow = "0.5.0"
+-windows-sys = { version = "0.45.0", features = ["Win32_Storage_FileSystem", "Win32_Foundation", "Win32_System_Console"] }
+Index: rust/src/tools/cargo/crates/cargo-test-support/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/cargo/crates/cargo-test-support/Cargo.toml
++++ rust/src/tools/cargo/crates/cargo-test-support/Cargo.toml
+@@ -27,6 +27,3 @@ termcolor = "1.1.2"
+ time = { version = "0.3", features = ["parsing", "formatting"]}
+ toml = "0.7.0"
+ url = "2.2.2"
+-
+-[target.'cfg(windows)'.dependencies]
+-windows-sys = { version = "0.45.0", features = ["Win32_Storage_FileSystem"] }
+Index: rust/src/tools/cargo/crates/home/Cargo.toml
+===================================================================
+--- rust.orig/src/tools/cargo/crates/home/Cargo.toml
++++ rust/src/tools/cargo/crates/home/Cargo.toml
+@@ -15,6 +15,3 @@ license = "MIT OR Apache-2.0"
+ readme = "README.md"
+ repository = "https://github.com/rust-lang/cargo"
+ description = "Shared definitions of home directories."
+-
+-[target.'cfg(windows)'.dependencies]
+-windows-sys = { version = "0.45.0", features = ["Win32_Foundation", "Win32_UI_Shell"] }