summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-fix-rustix-outline.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-fix-rustix-outline.patch')
-rw-r--r--debian/patches/d-fix-rustix-outline.patch26
1 files changed, 11 insertions, 15 deletions
diff --git a/debian/patches/d-fix-rustix-outline.patch b/debian/patches/d-fix-rustix-outline.patch
index 1800de9e3..91b8530de 100644
--- a/debian/patches/d-fix-rustix-outline.patch
+++ b/debian/patches/d-fix-rustix-outline.patch
@@ -3,11 +3,9 @@ Always enable cc even if the feature is not enabled.
Some Debian architectures need outline asm, and Debian does not ship pre-built
outline asm.
-Index: rust/vendor/rustix/Cargo.toml
-===================================================================
---- rust.orig/vendor/rustix/Cargo.toml
-+++ rust/vendor/rustix/Cargo.toml
-@@ -103,9 +103,9 @@ version = "0.6"
+--- a/vendor/rustix/Cargo.toml
++++ b/vendor/rustix/Cargo.toml
+@@ -115,9 +115,9 @@
[dev-dependencies.tempfile]
version = "3.2.0"
@@ -19,18 +17,16 @@ Index: rust/vendor/rustix/Cargo.toml
[features]
all-apis = [
-@@ -168,6 +168,7 @@ use-libc = [
- "libc_errno",
- "libc",
+@@ -230,6 +230,7 @@
+ "Win32_NetworkManagement_IpHelper",
+ "Win32_System_Threading",
]
+cc = []
- [target."cfg(all(any(target_os = \"android\", target_os = \"linux\"), any(rustix_use_libc, miri, not(all(target_os = \"linux\", any(target_arch = \"x86\", all(target_arch = \"x86_64\", target_pointer_width = \"64\"), all(target_endian = \"little\", any(target_arch = \"arm\", all(target_arch = \"aarch64\", target_pointer_width = \"64\"), target_arch = \"powerpc64\", target_arch = \"riscv64\", target_arch = \"mips\", target_arch = \"mips64\"))))))))".dependencies.linux-raw-sys]
- version = "0.0.46"
-Index: rust/vendor/rustix/build.rs
-===================================================================
---- rust.orig/vendor/rustix/build.rs
-+++ rust/vendor/rustix/build.rs
+ [target."cfg(windows)".dev-dependencies.ctor]
+ version = "0.1.21"
+--- a/vendor/rustix/build.rs
++++ b/vendor/rustix/build.rs
@@ -1,5 +1,4 @@
-#[cfg(feature = "cc")]
-use cc::Build;
@@ -38,7 +34,7 @@ Index: rust/vendor/rustix/build.rs
use std::env::var;
use std::io::Write;
-@@ -113,16 +112,16 @@ fn link_in_librustix_outline(arch: &str,
+@@ -118,16 +117,16 @@
println!("cargo:rerun-if-changed={}", to);
// If "cc" is not enabled, use a pre-built library.