summaryrefslogtreecommitdiffstats
path: root/debian/patches/d-fix-rustix-outline.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/d-fix-rustix-outline.patch')
-rw-r--r--debian/patches/d-fix-rustix-outline.patch57
1 files changed, 54 insertions, 3 deletions
diff --git a/debian/patches/d-fix-rustix-outline.patch b/debian/patches/d-fix-rustix-outline.patch
index 91b8530de..f141bad58 100644
--- a/debian/patches/d-fix-rustix-outline.patch
+++ b/debian/patches/d-fix-rustix-outline.patch
@@ -5,9 +5,9 @@ outline asm.
--- a/vendor/rustix/Cargo.toml
+++ b/vendor/rustix/Cargo.toml
-@@ -115,9 +115,9 @@
+@@ -125,9 +125,9 @@
[dev-dependencies.tempfile]
- version = "3.2.0"
+ version = "3.4.0"
-[build-dependencies.cc]
+[build-dependencies.cc_dep]
@@ -17,7 +17,7 @@ outline asm.
[features]
all-apis = [
-@@ -230,6 +230,7 @@
+@@ -242,6 +242,7 @@
"Win32_NetworkManagement_IpHelper",
"Win32_System_Threading",
]
@@ -34,6 +34,57 @@ outline asm.
use std::env::var;
use std::io::Write;
+@@ -158,16 +157,16 @@
+ println!("cargo:rerun-if-changed={}", to);
+
+ // If "cc" is not enabled, use a pre-built library.
+- #[cfg(not(feature = "cc"))]
++ /*#[cfg(not(feature = "cc"))]
+ {
+ let _ = asm_name;
+ println!("cargo:rustc-link-search={}/{}", OUTLINE_PATH, profile);
+ println!("cargo:rustc-link-lib=static={}", name);
+- }
++ }*/
+
+ // If "cc" is enabled, build the library from source, update the pre-built
+ // version, and assert that the pre-built version is checked in.
+- #[cfg(feature = "cc")]
++ //#[cfg(feature = "cc")]
+ {
+ let out_dir = var("OUT_DIR").unwrap();
+ // Add `-gdwarf-3` so that we always get the same output, regardless of
+--- a/vendor/rustix-0.36.5/Cargo.toml
++++ b/vendor/rustix-0.36.5/Cargo.toml
+@@ -116,9 +116,9 @@
+ [dev-dependencies.tempfile]
+ version = "3.2.0"
+
+-[build-dependencies.cc]
++[build-dependencies.cc_dep]
+ version = "1.0.68"
+-optional = true
++package = "cc"
+
+ [features]
+ all-apis = [
+@@ -231,6 +231,7 @@
+ "Win32_NetworkManagement_IpHelper",
+ "Win32_System_Threading",
+ ]
++cc = []
+
+ [target."cfg(windows)".dev-dependencies.ctor]
+ version = "0.1.21"
+--- a/vendor/rustix-0.36.5/build.rs
++++ b/vendor/rustix-0.36.5/build.rs
+@@ -1,5 +1,4 @@
+-#[cfg(feature = "cc")]
+-use cc::Build;
++use cc_dep::Build;
+ use std::env::var;
+ use std::io::Write;
+
@@ -118,16 +117,16 @@
println!("cargo:rerun-if-changed={}", to);