summaryrefslogtreecommitdiffstats
path: root/debian/patches/prune/d-0021-vendor-remove-windows-dependencies.patch
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches/prune/d-0021-vendor-remove-windows-dependencies.patch')
-rw-r--r--debian/patches/prune/d-0021-vendor-remove-windows-dependencies.patch1007
1 files changed, 1007 insertions, 0 deletions
diff --git a/debian/patches/prune/d-0021-vendor-remove-windows-dependencies.patch b/debian/patches/prune/d-0021-vendor-remove-windows-dependencies.patch
new file mode 100644
index 000000000..025cfd8bd
--- /dev/null
+++ b/debian/patches/prune/d-0021-vendor-remove-windows-dependencies.patch
@@ -0,0 +1,1007 @@
+From: =?utf-8?q?Fabian_Gr=C3=BCnbichler?= <f.gruenbichler@proxmox.com>
+Date: Wed, 6 Sep 2023 13:23:24 -0600
+Subject: d-0021-vendor-remove-windows-dependencies
+MIME-Version: 1.0
+Content-Type: text/plain; charset="utf-8"
+Content-Transfer-Encoding: 8bit
+
+use something like
+
+ find vendor -iname Cargo.toml -exec grep -H -n -e 'windows-sys' -e 'winapi' -e 'ntapi' -e 'wincon' -e 'winreg' -e 'windows' {} \; > /tmp/files
+
+to find dependencies on windows targets in vendored crates. you will likely
+need to remove some hunks from this patch after pruning dependencies, since
+hopefully a few of the crates patched during early rebasing are eliminated.
+
+windows-bindgen and windows-metadata should not be removed, they are needed for
+the build and don't pull in windows-sys and friends.
+
+Forwarded: not-needed
+
+Signed-off-by: Fabian Grünbichler <f.gruenbichler@proxmox.com>
+---
+ vendor/android-tzdata/Cargo.toml | 1 +
+ vendor/ansi_term/Cargo.toml | 3 ---
+ vendor/anstream-0.5.0/Cargo.toml | 5 -----
+ vendor/anstream/Cargo.toml | 7 ------
+ vendor/anstyle-query/Cargo.toml | 6 -----
+ vendor/backtrace/Cargo.toml | 14 ------------
+ vendor/chrono/Cargo.toml | 12 ----------
+ vendor/colored/Cargo.toml | 7 ------
+ vendor/console/Cargo.toml | 11 ----------
+ vendor/ctrlc/Cargo.toml | 17 ---------------
+ vendor/curl-sys/Cargo.toml | 7 ------
+ vendor/curl/Cargo.toml | 10 ---------
+ vendor/dirs-sys-0.3.7/Cargo.toml | 3 ---
+ vendor/dirs-sys-next/Cargo.toml | 3 ---
+ vendor/errno/Cargo.toml | 6 -----
+ vendor/fd-lock/Cargo.toml | 8 -------
+ vendor/filetime/Cargo.toml | 7 ------
+ vendor/gix-sec/Cargo.toml | 12 ----------
+ vendor/home/Cargo.toml | 7 ------
+ vendor/iana-time-zone/Cargo.toml | 4 ----
+ vendor/ignore/Cargo.toml | 2 --
+ vendor/is-terminal/Cargo.toml | 11 ----------
+ vendor/libloading-0.7.4/Cargo.toml | 6 -----
+ vendor/libloading/Cargo.toml | 8 -------
+ vendor/libssh2-sys/Cargo.toml | 8 -------
+ vendor/mio/Cargo.toml | 11 ----------
+ vendor/native-tls/Cargo.toml | 3 ---
+ vendor/nu-ansi-term-0.46.0/Cargo.toml | 10 ---------
+ vendor/opener-0.5.2/Cargo.toml | 4 ----
+ vendor/opener/Cargo.toml | 9 --------
+ vendor/os_info/Cargo.toml | 15 -------------
+ vendor/parking_lot_core/Cargo.toml | 3 ---
+ vendor/reqwest/Cargo.toml | 3 ---
+ vendor/rustix/Cargo.toml | 17 ---------------
+ vendor/same-file/Cargo.toml | 2 --
+ vendor/snapbox/Cargo.toml | 6 -----
+ vendor/socket2/Cargo.toml | 7 ------
+ vendor/stacker/Cargo.toml | 10 ---------
+ vendor/sysinfo-0.26.7/Cargo.toml | 38 --------------------------------
+ vendor/sysinfo/Cargo.toml | 41 -----------------------------------
+ vendor/tempfile/Cargo.toml | 7 ------
+ vendor/term/Cargo.toml | 6 -----
+ vendor/termcolor/Cargo.toml | 3 ---
+ vendor/terminal_size/Cargo.toml | 7 ------
+ vendor/termize/Cargo.toml | 3 ---
+ vendor/tokio-native-tls/Cargo.toml | 17 ---------------
+ vendor/tokio/Cargo.toml | 21 ------------------
+ vendor/uuid/Cargo.toml | 4 ----
+ vendor/walkdir/Cargo.toml | 3 ---
+ vendor/yansi-term/Cargo.toml | 3 ---
+ 50 files changed, 1 insertion(+), 437 deletions(-)
+
+diff --git a/vendor/android-tzdata/Cargo.toml b/vendor/android-tzdata/Cargo.toml
+index 805128a..0682717 100644
+--- a/vendor/android-tzdata/Cargo.toml
++++ b/vendor/android-tzdata/Cargo.toml
+@@ -32,3 +32,4 @@ repository = "https://github.com/RumovZ/android-tzdata"
+
+ [dev-dependencies.zip]
+ version = "0.6.4"
++repository = "https://github.com/rust-cli/concolor"
+diff --git a/vendor/ansi_term/Cargo.toml b/vendor/ansi_term/Cargo.toml
+index 0e5feba..3256c75 100644
+--- a/vendor/ansi_term/Cargo.toml
++++ b/vendor/ansi_term/Cargo.toml
+@@ -38,6 +38,3 @@ version = "1.0.39"
+
+ [features]
+ derive_serde_style = ["serde"]
+-[target."cfg(target_os=\"windows\")".dependencies.winapi]
+-version = "0.3.4"
+-features = ["consoleapi", "errhandlingapi", "fileapi", "handleapi", "processenv"]
+diff --git a/vendor/anstream-0.5.0/Cargo.toml b/vendor/anstream-0.5.0/Cargo.toml
+index 1b5193c..9574485 100644
+--- a/vendor/anstream-0.5.0/Cargo.toml
++++ b/vendor/anstream-0.5.0/Cargo.toml
+@@ -131,10 +131,5 @@ auto = [
+ ]
+ default = [
+ "auto",
+- "wincon",
+ ]
+-wincon = ["dep:anstyle-wincon"]
+
+-[target."cfg(windows)".dependencies.anstyle-wincon]
+-version = "2.0.0"
+-optional = true
+diff --git a/vendor/anstream/Cargo.toml b/vendor/anstream/Cargo.toml
+index a64ec8d..34dd08f 100644
+--- a/vendor/anstream/Cargo.toml
++++ b/vendor/anstream/Cargo.toml
+@@ -134,11 +134,4 @@ auto = [
+ ]
+ default = [
+ "auto",
+- "wincon",
+ ]
+-test = []
+-wincon = ["dep:anstyle-wincon"]
+-
+-[target."cfg(windows)".dependencies.anstyle-wincon]
+-version = "3.0.1"
+-optional = true
+diff --git a/vendor/anstyle-query/Cargo.toml b/vendor/anstyle-query/Cargo.toml
+index 599e364..e32bc63 100644
+--- a/vendor/anstyle-query/Cargo.toml
++++ b/vendor/anstyle-query/Cargo.toml
+@@ -72,9 +72,3 @@ replace = """
+ [Unreleased]: https://github.com/rust-cli/anstyle/compare/{{tag_name}}...HEAD"""
+ search = "<!-- next-url -->"
+
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.52.0"
+-features = [
+- "Win32_System_Console",
+- "Win32_Foundation",
+-]
+diff --git a/vendor/backtrace/Cargo.toml b/vendor/backtrace/Cargo.toml
+index c13e7ee..7b01a6f 100644
+--- a/vendor/backtrace/Cargo.toml
++++ b/vendor/backtrace/Cargo.toml
+@@ -104,16 +104,6 @@ serialize-serde = ["serde"]
+ std = []
+ unix-backtrace = []
+ verify-winapi = [
+- "winapi/dbghelp",
+- "winapi/handleapi",
+- "winapi/libloaderapi",
+- "winapi/memoryapi",
+- "winapi/minwindef",
+- "winapi/processthreadsapi",
+- "winapi/synchapi",
+- "winapi/tlhelp32",
+- "winapi/winbase",
+- "winapi/winnt",
+ ]
+
+ [target."cfg(not(all(windows, target_env = \"msvc\", not(target_vendor = \"uwp\"))))".dependencies.addr2line]
+@@ -139,7 +129,3 @@ features = [
+ "archive",
+ ]
+ default-features = false
+-
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3.9"
+-optional = true
+diff --git a/vendor/chrono/Cargo.toml b/vendor/chrono/Cargo.toml
+index 7f49bad..6229f0a 100644
+--- a/vendor/chrono/Cargo.toml
++++ b/vendor/chrono/Cargo.toml
+@@ -107,7 +107,6 @@ __internal_bench = ["criterion"]
+ alloc = []
+ clock = [
+ "std",
+- "winapi",
+ "iana-time-zone",
+ ]
+ default = [
+@@ -146,14 +145,3 @@ version = "0.1.1"
+ version = "0.1.45"
+ features = ["fallback"]
+ optional = true
+-
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3.0"
+-features = [
+- "std",
+- "minwinbase",
+- "minwindef",
+- "timezoneapi",
+- "sysinfoapi",
+-]
+-optional = true
+diff --git a/vendor/colored/Cargo.toml b/vendor/colored/Cargo.toml
+index dda2951..05b76bd 100644
+--- a/vendor/colored/Cargo.toml
++++ b/vendor/colored/Cargo.toml
+@@ -42,10 +42,3 @@ version = "=1.0.0-beta.3"
+
+ [features]
+ no-color = []
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.48"
+-features = [
+- "Win32_Foundation",
+- "Win32_System_Console",
+-]
+diff --git a/vendor/console/Cargo.toml b/vendor/console/Cargo.toml
+index 85849e16..7c7be5a 100644
+--- a/vendor/console/Cargo.toml
++++ b/vendor/console/Cargo.toml
+@@ -59,14 +59,3 @@ default = [
+ ]
+ windows-console-colors = ["ansi-parsing"]
+
+-[target."cfg(windows)".dependencies.encode_unicode]
+-version = "0.3"
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.45.0"
+-features = [
+- "Win32_Foundation",
+- "Win32_System_Console",
+- "Win32_Storage_FileSystem",
+- "Win32_UI_Input_KeyboardAndMouse",
+-]
+diff --git a/vendor/ctrlc/Cargo.toml b/vendor/ctrlc/Cargo.toml
+index bb27f1b..93d7d7e 100644
+--- a/vendor/ctrlc/Cargo.toml
++++ b/vendor/ctrlc/Cargo.toml
+@@ -56,23 +56,6 @@ features = [
+ ]
+ default-features = false
+
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.48"
+-features = [
+- "Win32_Foundation",
+- "Win32_System_Threading",
+- "Win32_Security",
+- "Win32_System_Console",
+-]
+-
+-[target."cfg(windows)".dev-dependencies.windows-sys]
+-version = "0.48"
+-features = [
+- "Win32_Storage_FileSystem",
+- "Win32_Foundation",
+- "Win32_System_IO",
+- "Win32_System_Console",
+-]
+
+ [badges.maintenance]
+ status = "passively-maintained"
+diff --git a/vendor/curl-sys/Cargo.toml b/vendor/curl-sys/Cargo.toml
+index 624fabf..c66bbba 100644
+--- a/vendor/curl-sys/Cargo.toml
++++ b/vendor/curl-sys/Cargo.toml
+@@ -73,13 +73,6 @@ zlib-ng-compat = [
+ version = "0.9.64"
+ optional = true
+
+-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
+-version = "0.2"
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.48"
+-features = ["Win32_Networking_WinSock"]
+-
+ [badges.appveyor]
+ repository = "alexcrichton/curl-rust"
+
+diff --git a/vendor/curl/Cargo.toml b/vendor/curl/Cargo.toml
+index bfb59f4..d9f6854 100644
+--- a/vendor/curl/Cargo.toml
++++ b/vendor/curl/Cargo.toml
+@@ -107,16 +107,6 @@ optional = true
+ version = "0.9.43"
+ optional = true
+
+-[target."cfg(target_env = \"msvc\")".dependencies.schannel]
+-version = "0.1.13"
+-
+-[target."cfg(target_env = \"msvc\")".dependencies.winapi]
+-version = "0.3"
+-features = [
+- "libloaderapi",
+- "wincrypt",
+-]
+-
+ [badges.appveyor]
+ repository = "alexcrichton/curl-rust"
+
+diff --git a/vendor/dirs-sys-0.3.7/Cargo.toml b/vendor/dirs-sys-0.3.7/Cargo.toml
+index 9951d24..0a86f4d 100644
+--- a/vendor/dirs-sys-0.3.7/Cargo.toml
++++ b/vendor/dirs-sys-0.3.7/Cargo.toml
+@@ -22,6 +22,3 @@ version = "0.4"
+ default-features = false
+ [target."cfg(unix)".dependencies.libc]
+ version = "0.2"
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3"
+-features = ["knownfolders", "objbase", "shlobj", "winbase", "winerror"]
+diff --git a/vendor/dirs-sys-next/Cargo.toml b/vendor/dirs-sys-next/Cargo.toml
+index e9d8d0c..acb2eb7 100644
+--- a/vendor/dirs-sys-next/Cargo.toml
++++ b/vendor/dirs-sys-next/Cargo.toml
+@@ -25,8 +25,5 @@ version = "0.4.0"
+ default-features = false
+ [target."cfg(unix)".dependencies.libc]
+ version = "0.2"
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3"
+-features = ["knownfolders", "objbase", "shlobj", "winbase", "winerror"]
+ [badges.maintenance]
+ status = "as-is"
+diff --git a/vendor/errno/Cargo.toml b/vendor/errno/Cargo.toml
+index e1d0bf5..60eeb86 100644
+--- a/vendor/errno/Cargo.toml
++++ b/vendor/errno/Cargo.toml
+@@ -41,9 +41,3 @@ default-features = false
+ version = "0.2"
+ default-features = false
+
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.52"
+-features = [
+- "Win32_Foundation",
+- "Win32_System_Diagnostics_Debug",
+-]
+diff --git a/vendor/fd-lock/Cargo.toml b/vendor/fd-lock/Cargo.toml
+index 8d0b8f0..eb1ef13 100644
+--- a/vendor/fd-lock/Cargo.toml
++++ b/vendor/fd-lock/Cargo.toml
+@@ -43,11 +43,3 @@ version = "3.0.8"
+ [target."cfg(unix)".dependencies.rustix]
+ version = "0.38.0"
+ features = ["fs"]
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.48.0"
+-features = [
+- "Win32_Foundation",
+- "Win32_Storage_FileSystem",
+- "Win32_System_IO",
+-]
+diff --git a/vendor/filetime/Cargo.toml b/vendor/filetime/Cargo.toml
+index 0540ffb..2c65fa5 100644
+--- a/vendor/filetime/Cargo.toml
++++ b/vendor/filetime/Cargo.toml
+@@ -38,10 +38,3 @@ version = "0.4.1"
+
+ [target."cfg(unix)".dependencies.libc]
+ version = "0.2.27"
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.52.0"
+-features = [
+- "Win32_Foundation",
+- "Win32_Storage_FileSystem",
+-]
+diff --git a/vendor/gix-sec/Cargo.toml b/vendor/gix-sec/Cargo.toml
+index cf452ec..c405340 100644
+--- a/vendor/gix-sec/Cargo.toml
++++ b/vendor/gix-sec/Cargo.toml
+@@ -58,15 +58,3 @@ serde = [
+ [target."cfg(not(windows))".dependencies.libc]
+ version = "0.2.123"
+
+-[target."cfg(windows)".dependencies.gix-path]
+-version = "^0.10.1"
+-
+-[target."cfg(windows)".dependencies.windows]
+-version = "0.48"
+-features = [
+- "Win32_Foundation",
+- "Win32_Security_Authorization",
+- "Win32_Storage_FileSystem",
+- "Win32_System_Memory",
+- "Win32_System_Threading",
+-]
+diff --git a/vendor/home/Cargo.toml b/vendor/home/Cargo.toml
+index cd608b1..eecfb89 100644
+--- a/vendor/home/Cargo.toml
++++ b/vendor/home/Cargo.toml
+@@ -27,10 +27,3 @@ readme = "README.md"
+ license = "MIT OR Apache-2.0"
+ repository = "https://github.com/rust-lang/cargo"
+ resolver = "2"
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.48.0"
+-features = [
+- "Win32_Foundation",
+- "Win32_UI_Shell",
+-]
+diff --git a/vendor/iana-time-zone/Cargo.toml b/vendor/iana-time-zone/Cargo.toml
+index e06c705..572a8fd 100644
+--- a/vendor/iana-time-zone/Cargo.toml
++++ b/vendor/iana-time-zone/Cargo.toml
+@@ -52,7 +52,3 @@ version = "0.1.5"
+
+ [target."cfg(target_os = \"haiku\")".dependencies.iana-time-zone-haiku]
+ version = "0.1.1"
+-
+-[target."cfg(target_os = \"windows\")".dependencies.windows]
+-version = "0.48.0"
+-features = ["Globalization"]
+diff --git a/vendor/ignore/Cargo.toml b/vendor/ignore/Cargo.toml
+index 60ab32a..bf4109f 100644
+--- a/vendor/ignore/Cargo.toml
++++ b/vendor/ignore/Cargo.toml
+@@ -77,5 +77,3 @@ version = "0.5.8"
+ [features]
+ simd-accel = []
+
+-[target."cfg(windows)".dependencies.winapi-util]
+-version = "0.1.2"
+diff --git a/vendor/is-terminal/Cargo.toml b/vendor/is-terminal/Cargo.toml
+index 08933a7..b4b0482 100644
+--- a/vendor/is-terminal/Cargo.toml
++++ b/vendor/is-terminal/Cargo.toml
+@@ -54,14 +54,3 @@ features = ["stdio"]
+
+ [target."cfg(target_os = \"hermit\")".dependencies.hermit-abi]
+ version = "0.3.0"
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.48.0"
+-features = [
+- "Win32_Foundation",
+- "Win32_Storage_FileSystem",
+- "Win32_System_Console",
+-]
+-
+-[target."cfg(windows)".dev-dependencies.tempfile]
+-version = "3"
+diff --git a/vendor/libloading-0.7.4/Cargo.toml b/vendor/libloading-0.7.4/Cargo.toml
+index 65168d5..03df764 100644
+--- a/vendor/libloading-0.7.4/Cargo.toml
++++ b/vendor/libloading-0.7.4/Cargo.toml
+@@ -43,9 +43,3 @@ version = "1.1"
+ [target."cfg(unix)".dependencies.cfg-if]
+ version = "1"
+
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3"
+-features = [
+- "errhandlingapi",
+- "libloaderapi",
+-]
+diff --git a/vendor/libloading/Cargo.toml b/vendor/libloading/Cargo.toml
+index 0165453..0dfc3c0 100644
+--- a/vendor/libloading/Cargo.toml
++++ b/vendor/libloading/Cargo.toml
+@@ -42,11 +42,3 @@ version = "1.1"
+
+ [target."cfg(unix)".dependencies.cfg-if]
+ version = "1"
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.48"
+-features = [
+- "Win32_Foundation",
+- "Win32_System_Diagnostics_Debug",
+- "Win32_System_LibraryLoader",
+-]
+diff --git a/vendor/libssh2-sys/Cargo.toml b/vendor/libssh2-sys/Cargo.toml
+index 45f4a71..516644c 100644
+--- a/vendor/libssh2-sys/Cargo.toml
++++ b/vendor/libssh2-sys/Cargo.toml
+@@ -43,16 +43,8 @@ version = "1.0.25"
+ version = "0.3.11"
+
+ [features]
+-openssl-on-win32 = ["openssl-sys"]
+ vendored-openssl = ["openssl-sys/vendored"]
+ zlib-ng-compat = ["libz-sys/zlib-ng"]
+
+-[target."cfg(target_env = \"msvc\")".build-dependencies.vcpkg]
+-version = "0.2"
+-
+ [target."cfg(unix)".dependencies.openssl-sys]
+ version = "0.9.35"
+-
+-[target."cfg(windows)".dependencies.openssl-sys]
+-version = "0.9.35"
+-optional = true
+diff --git a/vendor/mio/Cargo.toml b/vendor/mio/Cargo.toml
+index 42e28d0..b689d7b 100644
+--- a/vendor/mio/Cargo.toml
++++ b/vendor/mio/Cargo.toml
+@@ -102,8 +102,6 @@ default = ["log"]
+ net = []
+ os-ext = [
+ "os-poll",
+- "windows-sys/Win32_System_Pipes",
+- "windows-sys/Win32_Security",
+ ]
+ os-poll = []
+
+@@ -116,12 +114,3 @@ version = "0.11.0"
+ [target."cfg(unix)".dependencies.libc]
+ version = "0.2.121"
+
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.48"
+-features = [
+- "Win32_Foundation",
+- "Win32_Networking_WinSock",
+- "Win32_Storage_FileSystem",
+- "Win32_System_IO",
+- "Win32_System_WindowsProgramming",
+-]
+diff --git a/vendor/native-tls/Cargo.toml b/vendor/native-tls/Cargo.toml
+index a059236..d36b44b 100644
+--- a/vendor/native-tls/Cargo.toml
++++ b/vendor/native-tls/Cargo.toml
+@@ -61,6 +61,3 @@ version = "0.1"
+
+ [target."cfg(not(any(target_os = \"windows\", target_os = \"macos\", target_os = \"ios\")))".dependencies.openssl-sys]
+ version = "0.9.55"
+-
+-[target."cfg(target_os = \"windows\")".dependencies.schannel]
+-version = "0.1.17"
+diff --git a/vendor/nu-ansi-term-0.46.0/Cargo.toml b/vendor/nu-ansi-term-0.46.0/Cargo.toml
+index 209e055..aa40f02 100644
+--- a/vendor/nu-ansi-term-0.46.0/Cargo.toml
++++ b/vendor/nu-ansi-term-0.46.0/Cargo.toml
+@@ -45,13 +45,3 @@ version = "1.0.39"
+
+ [features]
+ derive_serde_style = ["serde"]
+-
+-[target."cfg(target_os=\"windows\")".dependencies.winapi]
+-version = "0.3.4"
+-features = [
+- "consoleapi",
+- "errhandlingapi",
+- "fileapi",
+- "handleapi",
+- "processenv",
+-]
+diff --git a/vendor/opener-0.5.2/Cargo.toml b/vendor/opener-0.5.2/Cargo.toml
+index 8d91b5e..2d7313b 100644
+--- a/vendor/opener-0.5.2/Cargo.toml
++++ b/vendor/opener-0.5.2/Cargo.toml
+@@ -32,10 +32,6 @@ version = "0.9"
+ [target."cfg(target_os = \"linux\")".dependencies.bstr]
+ version = "1"
+
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3"
+-features = ["shellapi"]
+-
+ [badges.appveyor]
+ branch = "master"
+ repository = "Seeker14491/opener"
+diff --git a/vendor/opener/Cargo.toml b/vendor/opener/Cargo.toml
+index 79b4be9..69cc269 100644
+--- a/vendor/opener/Cargo.toml
++++ b/vendor/opener/Cargo.toml
+@@ -40,8 +40,6 @@ version = "0.9"
+ reveal = [
+ "dep:url",
+ "dep:dbus",
+- "winapi/shtypes",
+- "winapi/objbase",
+ ]
+
+ [target."cfg(target_os = \"linux\")".dependencies.bstr]
+@@ -56,13 +54,6 @@ optional = true
+ version = "2"
+ optional = true
+
+-[target."cfg(windows)".dependencies.normpath]
+-version = "1"
+-
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3"
+-features = ["shellapi"]
+-
+ [badges.appveyor]
+ branch = "master"
+ repository = "Seeker14491/opener"
+diff --git a/vendor/os_info/Cargo.toml b/vendor/os_info/Cargo.toml
+index 52a062f..e1f347b 100644
+--- a/vendor/os_info/Cargo.toml
++++ b/vendor/os_info/Cargo.toml
+@@ -48,18 +48,3 @@ version = "1"
+
+ [features]
+ default = ["serde"]
+-
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3.8"
+-features = [
+- "minwindef",
+- "ntdef",
+- "ntstatus",
+- "sysinfoapi",
+- "winnt",
+- "winuser",
+- "libloaderapi",
+- "processthreadsapi",
+- "winerror",
+- "winreg",
+-]
+diff --git a/vendor/parking_lot_core/Cargo.toml b/vendor/parking_lot_core/Cargo.toml
+index 83d9f23..dbe1534 100644
+--- a/vendor/parking_lot_core/Cargo.toml
++++ b/vendor/parking_lot_core/Cargo.toml
+@@ -61,6 +61,3 @@ version = "0.4"
+
+ [target."cfg(unix)".dependencies.libc]
+ version = "0.2.95"
+-
+-[target."cfg(windows)".dependencies.windows-targets]
+-version = "0.48.0"
+diff --git a/vendor/reqwest/Cargo.toml b/vendor/reqwest/Cargo.toml
+index bca6039..c735e2f 100644
+--- a/vendor/reqwest/Cargo.toml
++++ b/vendor/reqwest/Cargo.toml
+@@ -443,6 +443,3 @@ features = ["serde-serialize"]
+
+ [target."cfg(target_arch = \"wasm32\")".dev-dependencies.wasm-bindgen-test]
+ version = "0.3"
+-
+-[target."cfg(windows)".dependencies.winreg]
+-version = "0.10"
+diff --git a/vendor/rustix/Cargo.toml b/vendor/rustix/Cargo.toml
+index f05faec..970c4a9 100644
+--- a/vendor/rustix/Cargo.toml
++++ b/vendor/rustix/Cargo.toml
+@@ -252,20 +252,3 @@ package = "errno"
+ [target."cfg(any(target_os = \"android\", target_os = \"linux\"))".dependencies.once_cell]
+ version = "1.5.2"
+ optional = true
+-
+-[target."cfg(windows)".dependencies.libc_errno]
+-version = "0.3.8"
+-default-features = false
+-package = "errno"
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.52.0"
+-features = [
+- "Win32_Foundation",
+- "Win32_Networking_WinSock",
+- "Win32_NetworkManagement_IpHelper",
+- "Win32_System_Threading",
+-]
+-
+-[target."cfg(windows)".dev-dependencies.ctor]
+-version = "0.2.0"
+diff --git a/vendor/same-file/Cargo.toml b/vendor/same-file/Cargo.toml
+index 4f66820..11ef472 100644
+--- a/vendor/same-file/Cargo.toml
++++ b/vendor/same-file/Cargo.toml
+@@ -25,5 +25,3 @@ license = "Unlicense/MIT"
+ repository = "https://github.com/BurntSushi/same-file"
+ [dev-dependencies.doc-comment]
+ version = "0.3"
+-[target."cfg(windows)".dependencies.winapi-util]
+-version = "0.1.1"
+diff --git a/vendor/snapbox/Cargo.toml b/vendor/snapbox/Cargo.toml
+index 2cb92d6..52e12d2 100644
+--- a/vendor/snapbox/Cargo.toml
++++ b/vendor/snapbox/Cargo.toml
+@@ -161,7 +161,6 @@ cmd = [
+ "dep:os_pipe",
+ "dep:wait-timeout",
+ "dep:libc",
+- "dep:windows-sys",
+ ]
+ color = [
+ "dep:anstream",
+@@ -199,8 +198,3 @@ structured-data = ["dep:serde_json"]
+ [target."cfg(unix)".dependencies.libc]
+ version = "0.2.137"
+ optional = true
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.48.0"
+-features = ["Win32_Foundation"]
+-optional = true
+diff --git a/vendor/socket2/Cargo.toml b/vendor/socket2/Cargo.toml
+index ec3bc6a..59068eb 100644
+--- a/vendor/socket2/Cargo.toml
++++ b/vendor/socket2/Cargo.toml
+@@ -59,10 +59,3 @@ all = []
+ [target."cfg(unix)".dependencies.libc]
+ version = "0.2.149"
+
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3.9"
+-features = [
+- "handleapi",
+- "ws2ipdef",
+- "ws2tcpip",
+-]
+diff --git a/vendor/stacker/Cargo.toml b/vendor/stacker/Cargo.toml
+index 160cbc0..ba02aac 100644
+--- a/vendor/stacker/Cargo.toml
++++ b/vendor/stacker/Cargo.toml
+@@ -43,13 +43,3 @@ version = "0.1.7"
+
+ [build-dependencies.cc]
+ version = "1.0.2"
+-
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3.6"
+-features = [
+- "memoryapi",
+- "winbase",
+- "fibersapi",
+- "processthreadsapi",
+- "minwindef",
+-]
+diff --git a/vendor/sysinfo-0.26.7/Cargo.toml b/vendor/sysinfo-0.26.7/Cargo.toml
+index f8719a4..deb2e40 100644
+--- a/vendor/sysinfo-0.26.7/Cargo.toml
++++ b/vendor/sysinfo-0.26.7/Cargo.toml
+@@ -60,41 +60,3 @@ version = "1.0"
+
+ [target."cfg(not(any(target_os = \"unknown\", target_arch = \"wasm32\")))".dependencies.libc]
+ version = "^0.2.112"
+-
+-[target."cfg(windows)".dependencies.ntapi]
+-version = "0.4"
+-
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3.9"
+-features = [
+- "errhandlingapi",
+- "fileapi",
+- "handleapi",
+- "heapapi",
+- "ifdef",
+- "ioapiset",
+- "minwindef",
+- "pdh",
+- "psapi",
+- "synchapi",
+- "sysinfoapi",
+- "winbase",
+- "winerror",
+- "winioctl",
+- "winnt",
+- "oleauto",
+- "wbemcli",
+- "rpcdce",
+- "combaseapi",
+- "objidl",
+- "powerbase",
+- "netioapi",
+- "lmcons",
+- "lmaccess",
+- "lmapibuf",
+- "memoryapi",
+- "ntlsa",
+- "securitybaseapi",
+- "shellapi",
+- "std",
+-]
+diff --git a/vendor/sysinfo/Cargo.toml b/vendor/sysinfo/Cargo.toml
+index 2a21a72..d526f46 100644
+--- a/vendor/sysinfo/Cargo.toml
++++ b/vendor/sysinfo/Cargo.toml
+@@ -75,44 +75,3 @@ version = "1.0"
+
+ [target."cfg(not(any(target_os = \"unknown\", target_arch = \"wasm32\")))".dependencies.libc]
+ version = "^0.2.144"
+-
+-[target."cfg(windows)".dependencies.ntapi]
+-version = "0.4"
+-
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3.9"
+-features = [
+- "errhandlingapi",
+- "fileapi",
+- "handleapi",
+- "heapapi",
+- "ifdef",
+- "ioapiset",
+- "minwindef",
+- "pdh",
+- "psapi",
+- "synchapi",
+- "sysinfoapi",
+- "winbase",
+- "winerror",
+- "winioctl",
+- "winnt",
+- "oleauto",
+- "wbemcli",
+- "rpcdce",
+- "combaseapi",
+- "objidl",
+- "powerbase",
+- "netioapi",
+- "lmcons",
+- "lmaccess",
+- "lmapibuf",
+- "memoryapi",
+- "ntlsa",
+- "securitybaseapi",
+- "shellapi",
+- "std",
+- "iphlpapi",
+- "winsock2",
+- "sddl",
+-]
+diff --git a/vendor/tempfile/Cargo.toml b/vendor/tempfile/Cargo.toml
+index 84ea801..bd37853 100644
+--- a/vendor/tempfile/Cargo.toml
++++ b/vendor/tempfile/Cargo.toml
+@@ -50,10 +50,3 @@ features = ["fs"]
+
+ [target."cfg(target_os = \"redox\")".dependencies.redox_syscall]
+ version = "0.4"
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.48"
+-features = [
+- "Win32_Storage_FileSystem",
+- "Win32_Foundation",
+-]
+diff --git a/vendor/term/Cargo.toml b/vendor/term/Cargo.toml
+index e89261e..ad5d62b 100644
+--- a/vendor/term/Cargo.toml
++++ b/vendor/term/Cargo.toml
+@@ -28,12 +28,6 @@ version = "2"
+
+ [features]
+ default = []
+-[target."cfg(windows)".dependencies.rustversion]
+-version = "1"
+-
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3"
+-features = ["consoleapi", "wincon", "handleapi", "fileapi"]
+ [badges.appveyor]
+ repository = "Stebalien/term"
+
+diff --git a/vendor/termcolor/Cargo.toml b/vendor/termcolor/Cargo.toml
+index dbdb6e8..8edc73e 100644
+--- a/vendor/termcolor/Cargo.toml
++++ b/vendor/termcolor/Cargo.toml
+@@ -35,6 +35,3 @@ name = "termcolor"
+ bench = false
+
+ [dev-dependencies]
+-
+-[target."cfg(windows)".dependencies.winapi-util]
+-version = "0.1.3"
+diff --git a/vendor/terminal_size/Cargo.toml b/vendor/terminal_size/Cargo.toml
+index f810025..0fbe3a1 100644
+--- a/vendor/terminal_size/Cargo.toml
++++ b/vendor/terminal_size/Cargo.toml
+@@ -30,10 +30,3 @@ repository = "https://github.com/eminence/terminal-size"
+ [target."cfg(not(windows))".dependencies.rustix]
+ version = "0.38.0"
+ features = ["termios"]
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.48.0"
+-features = [
+- "Win32_Foundation",
+- "Win32_System_Console",
+-]
+diff --git a/vendor/termize/Cargo.toml b/vendor/termize/Cargo.toml
+index d248f4d..9bd9f37 100644
+--- a/vendor/termize/Cargo.toml
++++ b/vendor/termize/Cargo.toml
+@@ -49,8 +49,5 @@ rpath = false
+ [dependencies]
+ [target."cfg(unix)".dependencies.libc]
+ version = "0.2.66"
+-[target."cfg(windows)".dependencies.winapi]
+-version = "0.3.8"
+-features = ["handleapi", "processenv", "wincon", "winbase"]
+ [badges.cirrus-ci]
+ repository = "JohnTitor/termize"
+diff --git a/vendor/tokio-native-tls/Cargo.toml b/vendor/tokio-native-tls/Cargo.toml
+index 76be3d3..3ada811 100644
+--- a/vendor/tokio-native-tls/Cargo.toml
++++ b/vendor/tokio-native-tls/Cargo.toml
+@@ -76,20 +76,3 @@ version = "0.10"
+
+ [target."cfg(any(target_os = \"macos\", target_os = \"ios\"))".dev-dependencies.security-framework]
+ version = "0.2"
+-
+-[target."cfg(windows)".dev-dependencies.schannel]
+-version = "0.1"
+-
+-[target."cfg(windows)".dev-dependencies.winapi]
+-version = "0.3"
+-features = [
+- "lmcons",
+- "basetsd",
+- "minwinbase",
+- "minwindef",
+- "ntdef",
+- "sysinfoapi",
+- "timezoneapi",
+- "wincrypt",
+- "winerror",
+-]
+diff --git a/vendor/tokio/Cargo.toml b/vendor/tokio/Cargo.toml
+index da1e4d1..55afa86 100644
+--- a/vendor/tokio/Cargo.toml
++++ b/vendor/tokio/Cargo.toml
+@@ -122,11 +122,6 @@ net = [
+ "mio/os-ext",
+ "mio/net",
+ "socket2",
+- "windows-sys/Win32_Foundation",
+- "windows-sys/Win32_Security",
+- "windows-sys/Win32_Storage_FileSystem",
+- "windows-sys/Win32_System_Pipes",
+- "windows-sys/Win32_System_SystemServices",
+ ]
+ process = [
+ "bytes",
+@@ -135,9 +130,6 @@ process = [
+ "mio/os-ext",
+ "mio/net",
+ "signal-hook-registry",
+- "windows-sys/Win32_Foundation",
+- "windows-sys/Win32_System_Threading",
+- "windows-sys/Win32_System_WindowsProgramming",
+ ]
+ rt = []
+ rt-multi-thread = [
+@@ -150,8 +142,6 @@ signal = [
+ "mio/net",
+ "mio/os-ext",
+ "signal-hook-registry",
+- "windows-sys/Win32_Foundation",
+- "windows-sys/Win32_System_Console",
+ ]
+ stats = []
+ sync = []
+@@ -217,14 +207,3 @@ features = [
+ "socket",
+ ]
+ default-features = false
+-
+-[target."cfg(windows)".dependencies.windows-sys]
+-version = "0.48"
+-optional = true
+-
+-[target."cfg(windows)".dev-dependencies.windows-sys]
+-version = "0.48"
+-features = [
+- "Win32_Foundation",
+- "Win32_Security_Authorization",
+-]
+diff --git a/vendor/uuid/Cargo.toml b/vendor/uuid/Cargo.toml
+index b806036..4094678 100644
+--- a/vendor/uuid/Cargo.toml
++++ b/vendor/uuid/Cargo.toml
+@@ -185,10 +185,6 @@ version = "0.3"
+ version = "0.2"
+ package = "wasm-bindgen"
+
+-[target."cfg(windows)".dev-dependencies.windows-sys]
+-version = "0.48.0"
+-features = ["Win32_System_Com"]
+-
+ [badges.is-it-maintained-issue-resolution]
+ repository = "uuid-rs/uuid"
+
+diff --git a/vendor/walkdir/Cargo.toml b/vendor/walkdir/Cargo.toml
+index 4c29a20..725e320 100644
+--- a/vendor/walkdir/Cargo.toml
++++ b/vendor/walkdir/Cargo.toml
+@@ -39,9 +39,6 @@ version = "1.0.1"
+ [dev-dependencies.doc-comment]
+ version = "0.3"
+
+-[target."cfg(windows)".dependencies.winapi-util]
+-version = "0.1.1"
+-
+ [badges.appveyor]
+ repository = "BurntSushi/walkdir"
+
+diff --git a/vendor/yansi-term/Cargo.toml b/vendor/yansi-term/Cargo.toml
+index 0317866..88ce8ef 100644
+--- a/vendor/yansi-term/Cargo.toml
++++ b/vendor/yansi-term/Cargo.toml
+@@ -36,9 +36,6 @@ version = "1.0"
+
+ [features]
+ derive_serde_style = ["serde"]
+-[target."cfg(target_os=\"windows\")".dependencies.winapi]
+-version = "0.3.4"
+-features = ["consoleapi", "errhandlingapi", "fileapi", "handleapi", "processenv"]
+ [badges.maintenance]
+ status = "actively-developed"
+