summaryrefslogtreecommitdiffstats
path: root/debian/patches
diff options
context:
space:
mode:
Diffstat (limited to 'debian/patches')
-rw-r--r--debian/patches/d-0000-ignore-removed-submodules.patch57
-rw-r--r--debian/patches/d-0002-mdbook-strip-embedded-libs.patch74
-rw-r--r--debian/patches/d-0003-cc-psm-rebuild-wasm32.patch4
-rw-r--r--debian/patches/d-0004-clippy-feature-sync.patch2
-rw-r--r--debian/patches/d-bootstrap-cargo-doc-paths.patch133
-rw-r--r--debian/patches/d-bootstrap-custom-debuginfo-path.patch6
-rw-r--r--debian/patches/d-rustc-fix-mips64el-bootstrap.patch4
-rw-r--r--debian/patches/d-rustdoc-disable-embedded-fonts.patch4
-rw-r--r--debian/patches/d-test-ignore-avx-44056.patch6
-rw-r--r--debian/patches/u-fix-get-toml-when-test.patch21
-rw-r--r--debian/patches/u-ignore-endian-big-diff.patch46
-rw-r--r--debian/patches/u-ignore-reproducible-failure.patch6
-rw-r--r--debian/patches/u-make-tests-work-without-rpath.patch6
-rw-r--r--debian/patches/u-rustc-llvm-cross-flags.patch4
14 files changed, 256 insertions, 117 deletions
diff --git a/debian/patches/d-0000-ignore-removed-submodules.patch b/debian/patches/d-0000-ignore-removed-submodules.patch
index 5ce806e79..6c3b0cfad 100644
--- a/debian/patches/d-0000-ignore-removed-submodules.patch
+++ b/debian/patches/d-0000-ignore-removed-submodules.patch
@@ -3,22 +3,22 @@ Date: Sat, 2 Oct 2021 01:07:59 +0100
Subject: d-0000-ignore-removed-submodules
---
- Cargo.toml | 15 ---------------
+ Cargo.toml | 17 -----------------
src/bootstrap/bootstrap.py | 4 ----
- src/bootstrap/builder.rs | 17 +----------------
+ src/bootstrap/builder.rs | 18 +-----------------
src/bootstrap/doc.rs | 1 -
src/bootstrap/test.rs | 12 +-----------
src/tools/clippy/Cargo.toml | 5 -----
src/tools/rust-analyzer/Cargo.toml | 11 ++++++++++-
src/tools/rustfmt/Cargo.toml | 5 -----
- src/tools/tidy/src/deps.rs | 2 +-
- 9 files changed, 13 insertions(+), 59 deletions(-)
+ src/tools/tidy/src/deps.rs | 4 +++-
+ 9 files changed, 15 insertions(+), 62 deletions(-)
diff --git a/Cargo.toml b/Cargo.toml
-index 000c10a..7442a0e 100644
+index 15cbb26..c012319 100644
--- a/Cargo.toml
+++ b/Cargo.toml
-@@ -17,27 +17,15 @@ members = [
+@@ -18,29 +18,15 @@ members = [
"src/tools/tidy",
"src/tools/tier-check",
"src/tools/build-manifest",
@@ -30,6 +30,8 @@ index 000c10a..7442a0e 100644
- "src/tools/cargo/crates/credential/cargo-credential-1password",
- "src/tools/cargo/crates/credential/cargo-credential-macos-keychain",
- "src/tools/cargo/crates/credential/cargo-credential-wincred",
+- "src/tools/cargo/crates/mdman",
+- # "src/tools/cargo/crates/resolver-tests",
"src/tools/rustdoc",
- "src/tools/rls",
"src/tools/rustfmt",
@@ -46,7 +48,7 @@ index 000c10a..7442a0e 100644
"src/tools/lld-wrapper",
"src/tools/collect-license-metadata",
"src/tools/generate-copyright",
-@@ -102,9 +90,6 @@ miniz_oxide.debug = 0
+@@ -105,9 +91,6 @@ miniz_oxide.debug = 0
object.debug = 0
[patch.crates-io]
@@ -57,10 +59,10 @@ index 000c10a..7442a0e 100644
# See comments in `library/rustc-std-workspace-core/README.md` for what's going on
# here
diff --git a/src/bootstrap/bootstrap.py b/src/bootstrap/bootstrap.py
-index 2d5018d..cc2ae13 100644
+index 9cf43fc..39b985f 100644
--- a/src/bootstrap/bootstrap.py
+++ b/src/bootstrap/bootstrap.py
-@@ -767,10 +767,6 @@ class RustBuild(object):
+@@ -770,10 +770,6 @@ class RustBuild(object):
os.path.join(self.rust_root, "src/bootstrap/Cargo.toml")]
for _ in range(0, self.verbose):
args.append("--verbose")
@@ -72,10 +74,10 @@ index 2d5018d..cc2ae13 100644
args.append("--features")
args.append("build-metrics")
diff --git a/src/bootstrap/builder.rs b/src/bootstrap/builder.rs
-index 8ee6d49..8bc92c8 100644
+index b4fc1d4..2bb0659 100644
--- a/src/bootstrap/builder.rs
+++ b/src/bootstrap/builder.rs
-@@ -596,8 +596,6 @@ impl<'a> Builder<'a> {
+@@ -629,8 +629,6 @@ impl<'a> Builder<'a> {
tool::RemoteTestClient,
tool::RustInstaller,
tool::Cargo,
@@ -84,7 +86,7 @@ index 8ee6d49..8bc92c8 100644
tool::RustAnalyzerProcMacroSrv,
tool::RustDemangler,
tool::Rustdoc,
-@@ -618,10 +616,6 @@ impl<'a> Builder<'a> {
+@@ -651,10 +649,6 @@ impl<'a> Builder<'a> {
check::CodegenBackend,
check::Clippy,
check::Miri,
@@ -95,7 +97,7 @@ index 8ee6d49..8bc92c8 100644
check::Rustfmt,
check::Bootstrap
),
-@@ -650,7 +644,6 @@ impl<'a> Builder<'a> {
+@@ -684,7 +678,6 @@ impl<'a> Builder<'a> {
test::ReplacePlaceholderTest,
test::Cargotest,
test::Cargo,
@@ -103,10 +105,11 @@ index 8ee6d49..8bc92c8 100644
test::ErrorIndex,
test::Distcheck,
test::RunMakeFullDeps,
-@@ -698,10 +691,8 @@ impl<'a> Builder<'a> {
+@@ -732,11 +725,8 @@ impl<'a> Builder<'a> {
doc::RustdocBook,
doc::RustByExample,
doc::RustcBook,
+- doc::Cargo,
- doc::CargoBook,
doc::Clippy,
doc::ClippyBook,
@@ -114,7 +117,7 @@ index 8ee6d49..8bc92c8 100644
doc::EmbeddedBook,
doc::EditionGuide,
doc::StyleGuide,
-@@ -717,8 +708,6 @@ impl<'a> Builder<'a> {
+@@ -752,8 +742,6 @@ impl<'a> Builder<'a> {
dist::Analysis,
dist::Src,
dist::Cargo,
@@ -123,7 +126,7 @@ index 8ee6d49..8bc92c8 100644
dist::Rustfmt,
dist::RustDemangler,
dist::Clippy,
-@@ -739,7 +728,6 @@ impl<'a> Builder<'a> {
+@@ -774,7 +762,6 @@ impl<'a> Builder<'a> {
install::Docs,
install::Std,
install::Cargo,
@@ -131,7 +134,7 @@ index 8ee6d49..8bc92c8 100644
install::Rustfmt,
install::RustDemangler,
install::Clippy,
-@@ -1823,10 +1811,7 @@ impl<'a> Builder<'a> {
+@@ -1889,10 +1876,7 @@ impl<'a> Builder<'a> {
}
}
@@ -144,10 +147,10 @@ index 8ee6d49..8bc92c8 100644
}
diff --git a/src/bootstrap/doc.rs b/src/bootstrap/doc.rs
-index 2c6fd1e..52c3eba 100644
+index 9bad904..d02edb0 100644
--- a/src/bootstrap/doc.rs
+++ b/src/bootstrap/doc.rs
-@@ -74,7 +74,6 @@ macro_rules! book {
+@@ -75,7 +75,6 @@ macro_rules! book {
// FIXME: Make checking for a submodule automatic somehow (maybe by having a list of all submodules
// and checking against it?).
book!(
@@ -156,10 +159,10 @@ index 2c6fd1e..52c3eba 100644
EditionGuide, "src/doc/edition-guide", "edition-guide", submodule;
EmbeddedBook, "src/doc/embedded-book", "embedded-book", submodule;
diff --git a/src/bootstrap/test.rs b/src/bootstrap/test.rs
-index 39cedfd..7ed7d97 100644
+index 6078e39..1a385f5 100644
--- a/src/bootstrap/test.rs
+++ b/src/bootstrap/test.rs
-@@ -1975,17 +1975,7 @@ impl Step for RustcGuide {
+@@ -2005,17 +2005,7 @@ impl Step for RustcGuide {
}
fn run(self, builder: &Builder<'_>) {
@@ -179,7 +182,7 @@ index 39cedfd..7ed7d97 100644
}
diff --git a/src/tools/clippy/Cargo.toml b/src/tools/clippy/Cargo.toml
-index fe425a2..23beb15 100644
+index f8cb4b7..3aa9ec6 100644
--- a/src/tools/clippy/Cargo.toml
+++ b/src/tools/clippy/Cargo.toml
@@ -36,11 +36,6 @@ walkdir = "2.3"
@@ -231,10 +234,10 @@ index 7a4e02d..27b91f2 100644
[package.metadata.rust-analyzer]
diff --git a/src/tools/tidy/src/deps.rs b/src/tools/tidy/src/deps.rs
-index 296db9d..0369861 100644
+index bc2edf6..142c2e9 100644
--- a/src/tools/tidy/src/deps.rs
+++ b/src/tools/tidy/src/deps.rs
-@@ -333,7 +333,7 @@ const FORBIDDEN_TO_HAVE_DUPLICATES: &[&str] = &[
+@@ -332,7 +332,7 @@ const FORBIDDEN_TO_HAVE_DUPLICATES: &[&str] = &[
// This crate takes quite a long time to build, so don't allow two versions of them
// to accidentally sneak into our dependency graph, in order to ensure we keep our CI times
// under control.
@@ -243,12 +246,12 @@ index 296db9d..0369861 100644
];
/// Dependency checks.
-@@ -629,6 +629,8 @@
+@@ -608,6 +608,8 @@ fn direct_deps_of<'a>(metadata: &'a Metadata, pkg_id: &'a PackageId) -> Vec<&'a
}
-
+
fn check_rustfix(metadata: &Metadata, bad: &mut bool) {
+ // Debian: we don't build cargo here, so this function doens't function.
+ return;
let cargo = pkg_from_name(metadata, "cargo");
let compiletest = pkg_from_name(metadata, "compiletest");
- let cargo_deps = deps_of(metadata, &cargo.id);
+ let cargo_deps = direct_deps_of(metadata, &cargo.id);
diff --git a/debian/patches/d-0002-mdbook-strip-embedded-libs.patch b/debian/patches/d-0002-mdbook-strip-embedded-libs.patch
index c544053bc..cd17dc2e6 100644
--- a/debian/patches/d-0002-mdbook-strip-embedded-libs.patch
+++ b/debian/patches/d-0002-mdbook-strip-embedded-libs.patch
@@ -6,12 +6,12 @@ Comment: Use https://github.com/infinity0/mdBook/tree/debian to help you rebase
---
src/tools/linkchecker/main.rs | 28 ++++++-
vendor/mdbook/src/book/init.rs | 6 --
- .../src/renderer/html_handlebars/hbs_renderer.rs | 80 ++-----------------
+ .../src/renderer/html_handlebars/hbs_renderer.rs | 80 ++----------------
.../mdbook/src/renderer/html_handlebars/search.rs | 2 -
- vendor/mdbook/src/theme/index.hbs | 93 +---------------------
- vendor/mdbook/src/theme/mod.rs | 27 -------
+ vendor/mdbook/src/theme/index.hbs | 97 +---------------------
+ vendor/mdbook/src/theme/mod.rs | 27 ------
vendor/mdbook/src/theme/searcher/mod.rs | 2 -
- 7 files changed, 35 insertions(+), 203 deletions(-)
+ 7 files changed, 37 insertions(+), 205 deletions(-)
diff --git a/src/tools/linkchecker/main.rs b/src/tools/linkchecker/main.rs
index 4170c32..d7dcda7 100644
@@ -67,10 +67,10 @@ index 4170c32..d7dcda7 100644
report.links_ignored_exception += 1;
} else {
diff --git a/vendor/mdbook/src/book/init.rs b/vendor/mdbook/src/book/init.rs
-index 264c113..2b0ff3a 100644
+index dd3fa8b..a088517 100644
--- a/vendor/mdbook/src/book/init.rs
+++ b/vendor/mdbook/src/book/init.rs
-@@ -151,12 +151,6 @@ impl BookBuilder {
+@@ -152,12 +152,6 @@ impl BookBuilder {
let mut js = File::create(themedir.join("book.js"))?;
js.write_all(theme::JS)?;
@@ -84,7 +84,7 @@ index 264c113..2b0ff3a 100644
}
diff --git a/vendor/mdbook/src/renderer/html_handlebars/hbs_renderer.rs b/vendor/mdbook/src/renderer/html_handlebars/hbs_renderer.rs
-index b933a35..09b4a7a 100644
+index 1b648da..5fe813c 100644
--- a/vendor/mdbook/src/renderer/html_handlebars/hbs_renderer.rs
+++ b/vendor/mdbook/src/renderer/html_handlebars/hbs_renderer.rs
@@ -3,7 +3,7 @@ use crate::config::{BookConfig, Config, HtmlConfig, Playground, RustEdition};
@@ -104,7 +104,7 @@ index b933a35..09b4a7a 100644
use crate::utils::fs::get_404_output_file;
use handlebars::Handlebars;
-@@ -232,80 +233,13 @@ impl HtmlHandlebars {
+@@ -235,80 +236,13 @@ impl HtmlHandlebars {
if let Some(contents) = &theme.favicon_svg {
write_file(destination, "favicon.svg", contents)?;
}
@@ -191,10 +191,10 @@ index b933a35..09b4a7a 100644
Ok(())
}
diff --git a/vendor/mdbook/src/renderer/html_handlebars/search.rs b/vendor/mdbook/src/renderer/html_handlebars/search.rs
-index c3b944c..d4bbe35 100644
+index a9e2f5c..3e3f69c 100644
--- a/vendor/mdbook/src/renderer/html_handlebars/search.rs
+++ b/vendor/mdbook/src/renderer/html_handlebars/search.rs
-@@ -52,8 +52,6 @@ pub fn create_files(search_config: &Search, destination: &Path, book: &Book) ->
+@@ -53,8 +53,6 @@ pub fn create_files(search_config: &Search, destination: &Path, book: &Book) ->
format!("Object.assign(window.search, {});", index).as_bytes(),
)?;
utils::fs::write_file(destination, "searcher.js", searcher::JS)?;
@@ -204,10 +204,10 @@ index c3b944c..d4bbe35 100644
}
diff --git a/vendor/mdbook/src/theme/index.hbs b/vendor/mdbook/src/theme/index.hbs
-index 18d984a..4a0e2d1 100644
+index 147eb9a..27d358b 100644
--- a/vendor/mdbook/src/theme/index.hbs
+++ b/vendor/mdbook/src/theme/index.hbs
-@@ -34,10 +34,7 @@
+@@ -33,10 +33,7 @@
{{/if}}
<!-- Fonts -->
@@ -219,21 +219,21 @@ index 18d984a..4a0e2d1 100644
<!-- Highlight.js Stylesheets -->
<link rel="stylesheet" href="{{ path_to_root }}highlight.css">
-@@ -51,7 +48,7 @@
+@@ -50,7 +47,7 @@
{{#if mathjax_support}}
<!-- MathJax -->
-- <script async type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.1/MathJax.js?config=TeX-AMS-MML_HTMLorMML"></script>
-+ <script async type="text/javascript" src="MathJax.js?config=TeX-AMS-MML_HTMLorMML"></script>
+- <script async src="https://cdnjs.cloudflare.com/ajax/libs/mathjax/2.7.1/MathJax.js?config=TeX-AMS-MML_HTMLorMML"></script>
++ <script async src="MathJax.js?config=TeX-AMS-MML_HTMLorMML"></script>
{{/if}}
</head>
<body>
-@@ -61,46 +58,6 @@
+@@ -60,46 +57,6 @@
var default_theme = window.matchMedia("(prefers-color-scheme: dark)").matches ? "{{ preferred_dark_theme }}" : "{{ default_theme }}";
</script>
- <!-- Work around some values being stored in localStorage wrapped in quotes -->
-- <script type="text/javascript">
+- <script>
- try {
- var theme = localStorage.getItem('mdbook-theme');
- var sidebar = localStorage.getItem('mdbook-sidebar');
@@ -249,7 +249,7 @@ index 18d984a..4a0e2d1 100644
- </script>
-
- <!-- Set the theme before any content is loaded, prevents flash -->
-- <script type="text/javascript">
+- <script>
- var theme;
- try { theme = localStorage.getItem('mdbook-theme'); } catch(e) { }
- if (theme === null || theme === undefined) { theme = default_theme; }
@@ -261,7 +261,7 @@ index 18d984a..4a0e2d1 100644
- </script>
-
- <!-- Hide / unhide sidebar before it is displayed -->
-- <script type="text/javascript">
+- <script>
- var html = document.querySelector('html');
- var sidebar = 'hidden';
- if (document.body.clientWidth >= 1080) {
@@ -275,13 +275,13 @@ index 18d984a..4a0e2d1 100644
<nav id="sidebar" class="sidebar" aria-label="Table of contents">
<div class="sidebar-scrollbox">
{{#toc}}{{/toc}}
-@@ -238,52 +195,6 @@
+@@ -237,54 +194,8 @@
</script>
{{/if}}
- {{#if google_analytics}}
- <!-- Google Analytics Tag -->
-- <script type="text/javascript">
+- <script>
- var localAddrs = ["localhost", "127.0.0.1", ""];
-
- // make sure we don't activate google analytics if the developer is
@@ -299,37 +299,41 @@ index 18d984a..4a0e2d1 100644
- {{/if}}
-
- {{#if playground_line_numbers}}
-- <script type="text/javascript">
+- <script>
- window.playground_line_numbers = true;
- </script>
- {{/if}}
-
- {{#if playground_copyable}}
-- <script type="text/javascript">
+- <script>
- window.playground_copyable = true;
- </script>
- {{/if}}
-
- {{#if playground_js}}
-- <script src="{{ path_to_root }}ace.js" type="text/javascript" charset="utf-8"></script>
-- <script src="{{ path_to_root }}editor.js" type="text/javascript" charset="utf-8"></script>
-- <script src="{{ path_to_root }}mode-rust.js" type="text/javascript" charset="utf-8"></script>
-- <script src="{{ path_to_root }}theme-dawn.js" type="text/javascript" charset="utf-8"></script>
-- <script src="{{ path_to_root }}theme-tomorrow_night.js" type="text/javascript" charset="utf-8"></script>
+- <script src="{{ path_to_root }}ace.js"></script>
+- <script src="{{ path_to_root }}editor.js"></script>
+- <script src="{{ path_to_root }}mode-rust.js"></script>
+- <script src="{{ path_to_root }}theme-dawn.js"></script>
+- <script src="{{ path_to_root }}theme-tomorrow_night.js"></script>
- {{/if}}
-
- {{#if search_js}}
-- <script src="{{ path_to_root }}elasticlunr.min.js" type="text/javascript" charset="utf-8"></script>
-- <script src="{{ path_to_root }}mark.min.js" type="text/javascript" charset="utf-8"></script>
-- <script src="{{ path_to_root }}searcher.js" type="text/javascript" charset="utf-8"></script>
+- <script src="{{ path_to_root }}elasticlunr.min.js"></script>
+- <script src="{{ path_to_root }}mark.min.js"></script>
+- <script src="{{ path_to_root }}searcher.js"></script>
- {{/if}}
-
-- <script src="{{ path_to_root }}clipboard.min.js" type="text/javascript" charset="utf-8"></script>
- <script src="{{ path_to_root }}highlight.js" type="text/javascript" charset="utf-8"></script>
- <script src="{{ path_to_root }}book.js" type="text/javascript" charset="utf-8"></script>
+- <script src="{{ path_to_root }}clipboard.min.js"></script>
+- <script src="{{ path_to_root }}highlight.js"></script>
+- <script src="{{ path_to_root }}book.js"></script>
++ <script src="{{ path_to_root }}highlight.js" type="text/javascript" charset="utf-8"></script>
++ <script src="{{ path_to_root }}book.js" type="text/javascript" charset="utf-8"></script>
+ <!-- Custom JS scripts -->
+ {{#each additional_js}}
diff --git a/vendor/mdbook/src/theme/mod.rs b/vendor/mdbook/src/theme/mod.rs
-index a1ee18a..d059f01 100644
+index 7af5e2b..3086fcf 100644
--- a/vendor/mdbook/src/theme/mod.rs
+++ b/vendor/mdbook/src/theme/mod.rs
@@ -1,9 +1,5 @@
diff --git a/debian/patches/d-0003-cc-psm-rebuild-wasm32.patch b/debian/patches/d-0003-cc-psm-rebuild-wasm32.patch
index 9446070f0..d17b24beb 100644
--- a/debian/patches/d-0003-cc-psm-rebuild-wasm32.patch
+++ b/debian/patches/d-0003-cc-psm-rebuild-wasm32.patch
@@ -8,10 +8,10 @@ Subject: d-0003-cc-psm-rebuild-wasm32
2 files changed, 3 insertions(+), 6 deletions(-)
diff --git a/vendor/cc/src/lib.rs b/vendor/cc/src/lib.rs
-index a89e353..ccf99d2 100644
+index 486d67e..723b2e9 100644
--- a/vendor/cc/src/lib.rs
+++ b/vendor/cc/src/lib.rs
-@@ -2341,7 +2341,7 @@ impl Build {
+@@ -2369,7 +2369,7 @@ impl Build {
|| target == "wasm32-unknown-wasi"
|| target == "wasm32-unknown-unknown"
{
diff --git a/debian/patches/d-0004-clippy-feature-sync.patch b/debian/patches/d-0004-clippy-feature-sync.patch
index f92cfd4bd..086ece034 100644
--- a/debian/patches/d-0004-clippy-feature-sync.patch
+++ b/debian/patches/d-0004-clippy-feature-sync.patch
@@ -10,7 +10,7 @@ this is what rustc_workspace_hack does in the upstream build.
2 files changed, 2 insertions(+), 2 deletions(-)
diff --git a/src/tools/clippy/Cargo.toml b/src/tools/clippy/Cargo.toml
-index 23beb15..ad8231a 100644
+index 3aa9ec6..0bb813d 100644
--- a/src/tools/clippy/Cargo.toml
+++ b/src/tools/clippy/Cargo.toml
@@ -43,7 +43,7 @@ if_chain = "1.0"
diff --git a/debian/patches/d-bootstrap-cargo-doc-paths.patch b/debian/patches/d-bootstrap-cargo-doc-paths.patch
index 235c93a50..baba25534 100644
--- a/debian/patches/d-bootstrap-cargo-doc-paths.patch
+++ b/debian/patches/d-bootstrap-cargo-doc-paths.patch
@@ -241,3 +241,136 @@ index a22dc5f..c8d521a 100644
if is_exception(file, &target_pretty_path) {
report.links_ignored_exception += 1;
} else {
+Index: rust/compiler/rustc_error_codes/src/error_codes/E0462.md
+===================================================================
+--- rust.orig/compiler/rustc_error_codes/src/error_codes/E0462.md
++++ rust/compiler/rustc_error_codes/src/error_codes/E0462.md
+@@ -26,7 +26,7 @@ prefer `staticlib` for linking with C pr
+ `crate_type`s in [this section of the Reference](../reference/linkage.html).
+
+ This error can be fixed by:
+- * Using [Cargo](../cargo/index.html), the Rust package manager, automatically
++ * Using [Cargo](../../cargo-doc/doc/index.html), the Rust package manager, automatically
+ fixing this issue.
+ * Recompiling the crate as a `rlib` or `dylib`; formats suitable for Rust
+ linking.
+Index: rust/compiler/rustc_error_codes/src/error_codes/E0460.md
+===================================================================
+--- rust.orig/compiler/rustc_error_codes/src/error_codes/E0460.md
++++ rust/compiler/rustc_error_codes/src/error_codes/E0460.md
+@@ -68,4 +68,4 @@ This error can be fixed by:
+ * Recompiling crate `a` so that both crate `b` and `main` have a uniform
+ version to depend on.
+
+-[Cargo]: ../cargo/index.html
++[Cargo]: ../../cargo-doc/doc/index.html
+Index: rust/compiler/rustc_error_codes/src/error_codes/E0514.md
+===================================================================
+--- rust.orig/compiler/rustc_error_codes/src/error_codes/E0514.md
++++ rust/compiler/rustc_error_codes/src/error_codes/E0514.md
+@@ -27,7 +27,7 @@ the compiler cannot be sure about *how*
+ versions, and therefore this error occurs.
+
+ This error can be fixed by:
+- * Using [Cargo](../cargo/index.html), the Rust package manager and
++ * Using [Cargo](../../cargo-doc/doc/index.html), the Rust package manager and
+ [Rustup](https://rust-lang.github.io/rustup/), the Rust toolchain installer,
+ automatically fixing this issue.
+ * Recompiling the crates with a uniform `rustc` version.
+Index: rust/src/doc/unstable-book/src/compiler-flags/branch-protection.md
+===================================================================
+--- rust.orig/src/doc/unstable-book/src/compiler-flags/branch-protection.md
++++ rust/src/doc/unstable-book/src/compiler-flags/branch-protection.md
+@@ -15,4 +15,4 @@ For example, `-Z branch-protection=bti,p
+
+ Rust's standard library does not ship with BTI or pointer authentication enabled by default.
+ In Cargo projects the standard library can be recompiled with pointer authentication using the nightly
+-[build-std](../../cargo/reference/unstable.html#build-std) feature.
++[build-std](../../../cargo-doc/doc/reference/unstable.html#build-std) feature.
+Index: rust/src/doc/unstable-book/src/compiler-flags/control-flow-guard.md
+===================================================================
+--- rust.orig/src/doc/unstable-book/src/compiler-flags/control-flow-guard.md
++++ rust/src/doc/unstable-book/src/compiler-flags/control-flow-guard.md
+@@ -39,7 +39,7 @@ It is strongly recommended to also enabl
+
+ To enable CFG in the standard library, use the [cargo `-Z build-std` functionality][build-std] to recompile the standard library with the same configuration options as the main program.
+
+-[build-std]: ../../cargo/reference/unstable.html#build-std
++[build-std]: ../../../cargo-doc/doc/reference/unstable.html#build-std
+
+ For example:
+ ```cmd
+Index: rust/src/doc/unstable-book/src/compiler-flags/sanitizer.md
+===================================================================
+--- rust.orig/src/doc/unstable-book/src/compiler-flags/sanitizer.md
++++ rust/src/doc/unstable-book/src/compiler-flags/sanitizer.md
+@@ -691,7 +691,7 @@ It is strongly recommended to combine sa
+ instrumented standard library, for example using [cargo `-Zbuild-std`
+ functionality][build-std].
+
+-[build-std]: ../../cargo/reference/unstable.html#build-std
++[build-std]: ../../../cargo-doc/doc/reference/unstable.html#build-std
+
+ # Build scripts and procedural macros
+
+Index: rust/compiler/rustc_error_codes/src/error_codes/E0461.md
+===================================================================
+--- rust.orig/compiler/rustc_error_codes/src/error_codes/E0461.md
++++ rust/compiler/rustc_error_codes/src/error_codes/E0461.md
+@@ -25,6 +25,6 @@ architectures. This issue also extends t
+ `std` is operating-system specific.
+
+ This error can be fixed by:
+- * Using [Cargo](../cargo/index.html), the Rust package manager, automatically
++ * Using [Cargo](../../cargo-doc/doc/index.html), the Rust package manager, automatically
+ fixing this issue.
+ * Recompiling either crate so that they target a consistent target triple.
+Index: rust/compiler/rustc_error_codes/src/error_codes/E0519.md
+===================================================================
+--- rust.orig/compiler/rustc_error_codes/src/error_codes/E0519.md
++++ rust/compiler/rustc_error_codes/src/error_codes/E0519.md
+@@ -34,7 +34,7 @@ The above example compiles two crates wi
+ impossible for the compiler to distinguish between symbols (`pub` item names).
+
+ This error can be fixed by:
+- * Using [Cargo](../cargo/index.html), the Rust package manager, automatically
++ * Using [Cargo](../../cargo-doc/doc/index.html), the Rust package manager, automatically
+ fixing this issue.
+ * Recompiling the crate with different metadata (different name/
+ `crate_type`).
+Index: rust/src/doc/rustc/src/linker-plugin-lto.md
+===================================================================
+--- rust.orig/src/doc/rustc/src/linker-plugin-lto.md
++++ rust/src/doc/rustc/src/linker-plugin-lto.md
+@@ -112,7 +112,7 @@ targeting Windows-like targets
+ This is fixed if you explicitly set the target, for example
+ `cargo build --target x86_64-pc-windows-msvc`
+ Without an explicit --target the flags will be passed to all compiler invocations (including build
+-scripts and proc macros), see [cargo docs on rustflags](../cargo/reference/config.html#buildrustflags)
++scripts and proc macros), see [cargo docs on rustflags](../../cargo-doc/doc/reference/config.html#buildrustflags)
+
+ If you have dependencies using the `cc` crate, you will need to set these
+ environment variables:
+Index: rust/src/doc/rustc/src/platform-support/fuchsia.md
+===================================================================
+--- rust.orig/src/doc/rustc/src/platform-support/fuchsia.md
++++ rust/src/doc/rustc/src/platform-support/fuchsia.md
+@@ -870,7 +870,7 @@ ${SDK_PATH}/tools/${ARCH}/ffx debug conn
+ [Fuchsia]: https://fuchsia.dev/
+ [source tree]: https://fuchsia.dev/fuchsia-src/get-started/learn/build
+ [rustup]: https://rustup.rs/
+-[cargo]: ../../cargo/index.html
++[cargo]: ../../../cargo-doc/doc/index.html
+ [Fuchsia SDK]: https://chrome-infra-packages.appspot.com/p/fuchsia/sdk/core
+ [overview of CML]: https://fuchsia.dev/fuchsia-src/concepts/components/v2/component_manifests
+ [reference for the file format]: https://fuchsia.dev/reference/cml
+Index: rust/src/doc/rustc/src/targets/custom.md
+===================================================================
+--- rust.orig/src/doc/rustc/src/targets/custom.md
++++ rust/src/doc/rustc/src/targets/custom.md
+@@ -14,4 +14,4 @@ To see it for a different target, add th
+ rustc +nightly -Z unstable-options --target=wasm32-unknown-unknown --print target-spec-json
+ ```
+
+-To use a custom target, see the (unstable) [`build-std` feature](../../cargo/reference/unstable.html#build-std) of `cargo`.
++To use a custom target, see the (unstable) [`build-std` feature](../../../cargo-doc/doc/reference/unstable.html#build-std) of `cargo`.
diff --git a/debian/patches/d-bootstrap-custom-debuginfo-path.patch b/debian/patches/d-bootstrap-custom-debuginfo-path.patch
index 955b1e905..21aaf1f6b 100644
--- a/debian/patches/d-bootstrap-custom-debuginfo-path.patch
+++ b/debian/patches/d-bootstrap-custom-debuginfo-path.patch
@@ -23,10 +23,10 @@ Subject: d-bootstrap-custom-debuginfo-path
}
}
-diff --git a/src/test/codegen/remap_path_prefix/issue-73167-remap-std.rs b/src/test/codegen/remap_path_prefix/issue-73167-remap-std.rs
+diff --git a/tests/codegen/remap_path_prefix/issue-73167-remap-std.rs b/tests/codegen/remap_path_prefix/issue-73167-remap-std.rs
index b66abc6..f6efe1e 100644
---- a/src/test/codegen/remap_path_prefix/issue-73167-remap-std.rs
-+++ b/src/test/codegen/remap_path_prefix/issue-73167-remap-std.rs
+--- a/tests/codegen/remap_path_prefix/issue-73167-remap-std.rs
++++ b/tests/codegen/remap_path_prefix/issue-73167-remap-std.rs
@@ -7,7 +7,7 @@
// true automatically. If paths to std library hasn't been remapped, we use the
// above simulate-remapped-rust-src-base option to do it temporarily
diff --git a/debian/patches/d-rustc-fix-mips64el-bootstrap.patch b/debian/patches/d-rustc-fix-mips64el-bootstrap.patch
index 2c09c60c9..8c1625e6c 100644
--- a/debian/patches/d-rustc-fix-mips64el-bootstrap.patch
+++ b/debian/patches/d-rustc-fix-mips64el-bootstrap.patch
@@ -49,8 +49,8 @@ index e0d5f6f..57ad8c4 100644
target_features = []
if self.get_toml("crt-static", build_section) == "true":
target_features += ["+crt-static"]
---- a/src/test/assembly/asm/mips-types.rs
-+++ b/src/test/assembly/asm/mips-types.rs
+--- a/tests/assembly/asm/mips-types.rs
++++ b/tests/assembly/asm/mips-types.rs
@@ -1,3 +1,4 @@
+// ignore-test
// revisions: mips32 mips64
diff --git a/debian/patches/d-rustdoc-disable-embedded-fonts.patch b/debian/patches/d-rustdoc-disable-embedded-fonts.patch
index 5ec7bacb6..3213db6a5 100644
--- a/debian/patches/d-rustdoc-disable-embedded-fonts.patch
+++ b/debian/patches/d-rustdoc-disable-embedded-fonts.patch
@@ -24,8 +24,8 @@ Subject: d-rustdoc-disable-embedded-fonts
-}
-
* {
- -webkit-box-sizing: border-box;
- -moz-box-sizing: border-box;
+ box-sizing: border-box;
+ }
--- a/src/librustdoc/html/static_files.rs
+++ b/src/librustdoc/html/static_files.rs
@@ -126,8 +126,6 @@
diff --git a/debian/patches/d-test-ignore-avx-44056.patch b/debian/patches/d-test-ignore-avx-44056.patch
index c399e32f6..5448b7ad5 100644
--- a/debian/patches/d-test-ignore-avx-44056.patch
+++ b/debian/patches/d-test-ignore-avx-44056.patch
@@ -9,10 +9,10 @@ Bug: https://github.com/rust-lang/rust/pull/55667
src/test/ui/issues/issue-44056.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/src/test/ui/issues/issue-44056.rs b/src/test/ui/issues/issue-44056.rs
+diff --git a/tests/ui/issues/issue-44056.rs b/tests/ui/issues/issue-44056.rs
index a4903ed..ebe8402 100644
---- a/src/test/ui/issues/issue-44056.rs
-+++ b/src/test/ui/issues/issue-44056.rs
+--- a/tests/ui/issues/issue-44056.rs
++++ b/tests/ui/issues/issue-44056.rs
@@ -1,5 +1,5 @@
// build-pass (FIXME(55996): should be run on targets supporting avx)
-// only-x86_64
diff --git a/debian/patches/u-fix-get-toml-when-test.patch b/debian/patches/u-fix-get-toml-when-test.patch
index a9dd0fee0..2b170977c 100644
--- a/debian/patches/u-fix-get-toml-when-test.patch
+++ b/debian/patches/u-fix-get-toml-when-test.patch
@@ -8,28 +8,29 @@ Last-Update: 2023-03-29
This patch header follows DEP-3: http://dep.debian.net/deps/dep3/
--- a/src/bootstrap/config.rs
+++ b/src/bootstrap/config.rs
-@@ -907,9 +907,9 @@
-
- config.stage0_metadata = t!(serde_json::from_slice::<Stage0Metadata>(&stage0_json));
+@@ -823,9 +823,9 @@
+ }
+ pub fn parse(args: &[String]) -> Config {
- #[cfg(test)]
+ /*#[cfg(test)]
- let get_toml = |_| TomlConfig::default();
+ let get_toml = |_: &_| TomlConfig::default();
- #[cfg(not(test))]
+ #[cfg(not(test))]*/
let get_toml = |file: &Path| {
let contents =
t!(fs::read_to_string(file), format!("config file {} not found", file.display()));
-@@ -907,7 +907,22 @@
+@@ -834,7 +834,23 @@
match toml::from_str(&contents)
.and_then(|table: toml::Value| TomlConfig::deserialize(table))
{
- Ok(table) => table,
-+ /// Debian: We use previous version as a custom rustc, which unfortunately won't be
-+ /// picked up because config.toml isn't read when cfg!(test). Making tests use the
-+ /// entirety of our config.toml isn't feasible either as it panicks on GitRepo::Llvm
-+ /// (d-bootstrap-custom-debuginfo-path.patch), so only give paths of initial rustc
-+ /// and cargo.
++ // Debian: We use previous version as a custom rustc, which
++ // unfortunately won't be picked up because config.toml isn't
++ // read when cfg!(test). Making tests use the entirety of our
++ // config.toml isn't feasible either as it panicks on
++ // GitRepo::Llvm (d-bootstrap-custom-debuginfo-path.patch), so
++ // only give paths of initial rustc and cargo.
+ Ok(table) => if !cfg!(test) || table.build.is_none() {
+ table
+ } else {
diff --git a/debian/patches/u-ignore-endian-big-diff.patch b/debian/patches/u-ignore-endian-big-diff.patch
index aec8c5255..73bb776c3 100644
--- a/debian/patches/u-ignore-endian-big-diff.patch
+++ b/debian/patches/u-ignore-endian-big-diff.patch
@@ -14,45 +14,45 @@ Bug: https://github.com/rust-lang/rust/issues/89577
src/test/ui/consts/const-eval/ub-wide-ptr.rs | 1 +
6 files changed, 6 insertions(+)
---- a/src/test/ui/consts/const-eval/ub-enum.rs
-+++ b/src/test/ui/consts/const-eval/ub-enum.rs
+--- a/tests/ui/consts/const-eval/ub-enum.rs
++++ b/tests/ui/consts/const-eval/ub-enum.rs
@@ -1,3 +1,4 @@
+// ignore-test
// stderr-per-bitwidth
- #![feature(never_type)]
- #![allow(invalid_value)]
---- a/src/test/ui/consts/const-eval/ub-int-array.rs
-+++ b/src/test/ui/consts/const-eval/ub-int-array.rs
+ // Strip out raw byte dumps to make comparison platform-independent:
+ // normalize-stderr-test "(the raw bytes of the constant) \(size: [0-9]*, align: [0-9]*\)" -> "$1 (size: $$SIZE, align: $$ALIGN)"
+--- a/tests/ui/consts/const-eval/ub-int-array.rs
++++ b/tests/ui/consts/const-eval/ub-int-array.rs
@@ -1,3 +1,4 @@
+// ignore-test
// stderr-per-bitwidth
//! Test the "array of int" fast path in validity checking, and in particular whether it
//! points at the right array element.
---- a/src/test/ui/consts/const-eval/ub-nonnull.rs
-+++ b/src/test/ui/consts/const-eval/ub-nonnull.rs
+--- a/tests/ui/consts/const-eval/ub-nonnull.rs
++++ b/tests/ui/consts/const-eval/ub-nonnull.rs
@@ -1,3 +1,4 @@
+// ignore-test
- // stderr-per-bitwidth
- #![feature(rustc_attrs, ptr_metadata)]
- #![allow(invalid_value)] // make sure we cannot allow away the errors tested here
---- a/src/test/ui/consts/const-eval/ub-ref-ptr.rs
-+++ b/src/test/ui/consts/const-eval/ub-ref-ptr.rs
+ // Strip out raw byte dumps to make comparison platform-independent:
+ // normalize-stderr-test "(the raw bytes of the constant) \(size: [0-9]*, align: [0-9]*\)" -> "$1 (size: $$SIZE, align: $$ALIGN)"
+ // normalize-stderr-test "([0-9a-f][0-9a-f] |╾─*a(lloc)?[0-9]+(\+[a-z0-9]+)?─*╼ )+ *│.*" -> "HEX_DUMP"
+--- a/tests/ui/consts/const-eval/ub-ref-ptr.rs
++++ b/tests/ui/consts/const-eval/ub-ref-ptr.rs
@@ -1,3 +1,4 @@
+// ignore-test
// ignore-tidy-linelength
- // stderr-per-bitwidth
- #![allow(invalid_value)]
---- a/src/test/ui/consts/const-eval/ub-uninhabit.rs
-+++ b/src/test/ui/consts/const-eval/ub-uninhabit.rs
+ // Strip out raw byte dumps to make comparison platform-independent:
+ // normalize-stderr-test "(the raw bytes of the constant) \(size: [0-9]*, align: [0-9]*\)" -> "$1 (size: $$SIZE, align: $$ALIGN)"
+--- a/tests/ui/consts/const-eval/ub-uninhabit.rs
++++ b/tests/ui/consts/const-eval/ub-uninhabit.rs
@@ -1,3 +1,4 @@
+// ignore-test
- // stderr-per-bitwidth
-
- use std::mem;
---- a/src/test/ui/consts/const-eval/ub-wide-ptr.rs
-+++ b/src/test/ui/consts/const-eval/ub-wide-ptr.rs
+ // Strip out raw byte dumps to make comparison platform-independent:
+ // normalize-stderr-test "(the raw bytes of the constant) \(size: [0-9]*, align: [0-9]*\)" -> "$1 (size: $$SIZE, align: $$ALIGN)"
+ // normalize-stderr-test "([0-9a-f][0-9a-f] |╾─*a(lloc)?[0-9]+(\+[a-z0-9]+)?─*╼ )+ *│.*" -> "HEX_DUMP"
+--- a/tests/ui/consts/const-eval/ub-wide-ptr.rs
++++ b/tests/ui/consts/const-eval/ub-wide-ptr.rs
@@ -1,3 +1,4 @@
+// ignore-test
- // stderr-per-bitwidth
// ignore-tidy-linelength
#![allow(unused)]
+
diff --git a/debian/patches/u-ignore-reproducible-failure.patch b/debian/patches/u-ignore-reproducible-failure.patch
index e0f9688b3..6ea14023d 100644
--- a/debian/patches/u-ignore-reproducible-failure.patch
+++ b/debian/patches/u-ignore-reproducible-failure.patch
@@ -7,10 +7,10 @@ Bug: https://github.com/rust-lang/rust/issues/89911
src/test/run-make-fulldeps/reproducible-build-2/Makefile | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/src/test/run-make-fulldeps/reproducible-build-2/Makefile b/src/test/run-make-fulldeps/reproducible-build-2/Makefile
+diff --git a/tests/run-make-fulldeps/reproducible-build-2/Makefile b/tests/run-make-fulldeps/reproducible-build-2/Makefile
index fd94516..957e1f4 100644
---- a/src/test/run-make-fulldeps/reproducible-build-2/Makefile
-+++ b/src/test/run-make-fulldeps/reproducible-build-2/Makefile
+--- a/tests/run-make-fulldeps/reproducible-build-2/Makefile
++++ b/tests/run-make-fulldeps/reproducible-build-2/Makefile
@@ -14,7 +14,7 @@ fat_lto:
$(RUSTC) reproducible-build.rs -C lto=fat
cp $(TMPDIR)/reproducible-build $(TMPDIR)/reproducible-build-a
diff --git a/debian/patches/u-make-tests-work-without-rpath.patch b/debian/patches/u-make-tests-work-without-rpath.patch
index 97cd89233..edd2127a9 100644
--- a/debian/patches/u-make-tests-work-without-rpath.patch
+++ b/debian/patches/u-make-tests-work-without-rpath.patch
@@ -9,10 +9,10 @@ Forwarded: TODO
src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile | 6 +++++-
1 file changed, 5 insertions(+), 1 deletion(-)
-diff --git a/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile b/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
+diff --git a/tests/run-make-fulldeps/sysroot-crates-are-unstable/Makefile b/tests/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
index 1e267fb..ac46c24 100644
---- a/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
-+++ b/src/test/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
+--- a/tests/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
++++ b/tests/run-make-fulldeps/sysroot-crates-are-unstable/Makefile
@@ -1,2 +1,6 @@
+include ../tools.mk
+
diff --git a/debian/patches/u-rustc-llvm-cross-flags.patch b/debian/patches/u-rustc-llvm-cross-flags.patch
index 6ee382aba..226485b08 100644
--- a/debian/patches/u-rustc-llvm-cross-flags.patch
+++ b/debian/patches/u-rustc-llvm-cross-flags.patch
@@ -7,8 +7,6 @@ Subject: u-rustc-llvm-cross-flags
compiler/rustc_llvm/build.rs | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
-diff --git a/compiler/rustc_llvm/build.rs b/compiler/rustc_llvm/build.rs
-index b8f67ee..e9b1d0a 100644
--- a/compiler/rustc_llvm/build.rs
+++ b/compiler/rustc_llvm/build.rs
@@ -304,7 +304,7 @@
@@ -19,4 +17,4 @@ index b8f67ee..e9b1d0a 100644
+ if stripped.contains(&host) { println!("cargo:rustc-link-search=native={}", stripped.replace(&host, &target)); }
}
} else if let Some(stripped) = lib.strip_prefix("-LIBPATH:") {
- println!("cargo:rustc-link-search=native={}", stripped);
+ println!("cargo:rustc-link-search=native={stripped}");