summaryrefslogtreecommitdiffstats
path: root/debian/upstream-tarball-unsuspicious.txt
diff options
context:
space:
mode:
Diffstat (limited to 'debian/upstream-tarball-unsuspicious.txt')
-rw-r--r--debian/upstream-tarball-unsuspicious.txt59
1 files changed, 33 insertions, 26 deletions
diff --git a/debian/upstream-tarball-unsuspicious.txt b/debian/upstream-tarball-unsuspicious.txt
index 4a769ceee..8b316de8b 100644
--- a/debian/upstream-tarball-unsuspicious.txt
+++ b/debian/upstream-tarball-unsuspicious.txt
@@ -19,16 +19,18 @@ vendor/regex/tests/unicode.rs
vendor/term/src/terminfo/parser/names.rs
# False-positive, "verylongtext" but OK
-README.md
CONTRIBUTING.md
+README.md
RELEASES.md
compiler/rustc_codegen_cranelift/docs/dwarf.md
compiler/rustc_codegen_gcc/Readme.md
compiler/rustc_codegen_ssa/locales/en-US.ftl
+compiler/rustc_codegen_ssa/messages.ftl
library/core/src/ffi/c_*.md
library/portable-simd/*.md
library/stdarch/CONTRIBUTING.md
library/stdarch/crates/core_arch/src/aarch64/neon/generated.rs
+library/stdarch/crates/std_detect/README.md
library/std/src/sys/sgx/abi/entry.S
src/bootstrap/CHANGELOG.md
src/doc/book/first-edition/src/the-stack-and-the-heap.md
@@ -66,12 +68,14 @@ tests/mir-opt/building/*.mir
tests/mir-opt/coverage_graphviz.*.InstrumentCoverage.0.dot
tests/mir-opt/inline/inline_generator.main.Inline.diff
tests/rustdoc/inline_cross/assoc_item_trait_bounds.out*.html
-tests/rustdoc-ui/z-help.stdout
+tests/rustdoc/notable-trait/doc-notable_trait*.html
+tests/rustdoc/notable-trait/spotlight-from-dependency.odd.html
tests/ui/lint/redundant-semicolon/redundant-semi-proc-macro.stderr
tests/ui/parser/raw/too-many-hash.stderr
vendor/ahash-0.7.6/FAQ.md
vendor/ahash/FAQ.md
vendor/ammonia/src/lib.rs
+vendor/anstyle-parse/src/state/table.rs
vendor/*/Cargo.toml
vendor/*/CHANGELOG.md
vendor/clap-*/examples/demo.md
@@ -104,15 +108,13 @@ vendor/tracing-subscriber/src/fmt/format/json.rs
vendor/unicase/src/lib.rs
vendor/unicode-normalization/src/stream_safe.rs
vendor/winapi/src/lib.rs
-vendor/windows-sys-0.*/src/Windows/Win32/*.rs
-vendor/windows-sys-0.*/src/Windows/Win32/*/*.rs
-vendor/windows-sys-0.*/src/Windows/Win32/*/*/*.rs
-vendor/windows-sys-0.*/src/Windows/Win32/*/*/*/*.rs
-vendor/windows-sys*/readme.md
-vendor/windows-sys/src/Windows/Win32/*.rs
-vendor/windows-sys/src/Windows/Win32/*/*.rs
-vendor/windows-sys/src/Windows/Win32/*/*/*.rs
-vendor/windows-sys/src/Windows/Win32/*/*/*/*.rs
+vendor/windows*/readme.md
+vendor/windows*/src/Windows/*.rs
+vendor/windows*/src/Windows/*/*.rs
+vendor/windows*/src/Windows/*/*/*.rs
+vendor/windows*/src/Windows/*/*/*/*.rs
+vendor/windows*/src/Windows/*/*/*/*/*.rs
+vendor/windows*/src/Windows/*/*/*/*/*/*.rs
vendor/zerovec/src/map2d/map.rs
# False-positive, audit-vendor-source automatically flags JS/C files
@@ -128,7 +130,9 @@ src/librustdoc/html/static/.eslintrc.js
src/librustdoc/html/static/js/*.js
src/tools/error_index_generator/*.js
src/tools/rustdoc-gui/tester.js
+src/tools/rustdoc-gui/.eslintrc.js
src/tools/rustdoc-js/tester.js
+src/tools/rustdoc-js/.eslintrc.js
# Embedded libraries, justified in README.source
vendor/dlmalloc/src/dlmalloc.c
@@ -146,8 +150,9 @@ vendor/errno-dragonfly/src/errno.c
vendor/stacker/src/arch/windows.c
# False-positive, misc
+src/ci/github-actions/problem_matchers.json
src/doc/rustc-dev-guide/src/queries/example-0.counts.txt
-src/etc/vscode_settings.json
+src/etc/rust_analyzer_settings.json
src/stage0.json
src/tools/clippy/.remarkrc
vendor/elasticlunr-rs/src/lang/*.rs
@@ -217,7 +222,6 @@ tests/*/*.rs
tests/*/*/*.rs
tests/*/*/*/*.rs
tests/run-make/*/*.c
-tests/run-make-fulldeps/*/*.c
tests/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/foo.c
tests/run-make/x86_64-fortanix-unknown-sgx-lvi/enclave/libcmake_foo/src/foo.c
tests/rustdoc-gui/src/huge_logo/src/lib.rs
@@ -232,6 +236,9 @@ tests/ui/nll/*/*.stderr
tests/ui/parser/issues/*.stderr
tests/ui/proc-macro/debug/*.stderr
vendor/annotate-snippets/tests/fixtures/no-color/strip_line_non_ws.toml
+vendor/basic-toml/tests/valid/*.json
+vendor/basic-toml/tests/valid/table-whitespace.toml
+vendor/basic-toml/tests/invalid-encoder/array-mixed-types-ints-and-floats.json
vendor/bstr-0.2.17/src/unicode/fsm/*.dfa
vendor/cargo_metadata*/tests/test_samples.rs
vendor/diff/tests/data/gitignores.chars.diff
@@ -326,7 +333,6 @@ vendor/ahash/src/fallback_hash.rs
vendor/ahash/src/hash_quality_test.rs
vendor/ahash/src/lib.rs
vendor/aho-corasick/src/nfa.rs
-vendor/askama_shared/src/generator.rs
vendor/block-buffer/tests/mod.rs
vendor/clap*/src/derive.rs
vendor/clap_derive/src/derives/args.rs
@@ -401,18 +407,19 @@ vendor/sha2/src/sha512.rs
vendor/shlex/src/lib.rs
vendor/snap/src/compress.rs
vendor/snap/src/decompress.rs
-vendor/syn/src/attr.rs
-vendor/syn/src/custom_punctuation.rs
-vendor/syn/src/data.rs
-vendor/syn/src/derive.rs
-vendor/syn/src/group.rs
-vendor/syn/src/path.rs
-vendor/syn/src/pat.rs
-vendor/syn/src/punctuated.rs
-vendor/syn/src/stmt.rs
-vendor/syn/src/token.rs
-vendor/syn/src/ty.rs
-vendor/syn/tests/test_meta.rs
+vendor/syn*/src/attr.rs
+vendor/syn*/src/custom_punctuation.rs
+vendor/syn*/src/data.rs
+vendor/syn*/src/derive.rs
+vendor/syn*/src/group.rs
+vendor/syn*/src/meta.rs
+vendor/syn*/src/path.rs
+vendor/syn*/src/pat.rs
+vendor/syn*/src/punctuated.rs
+vendor/syn*/src/stmt.rs
+vendor/syn*/src/token.rs
+vendor/syn*/src/ty.rs
+vendor/syn*/tests/test_meta.rs
vendor/thiserror-impl/src/attr.rs
vendor/time/src/parsing/combinator/mod.rs
vendor/time/src/parsing/combinator/rfc/*.rs