summaryrefslogtreecommitdiffstats
path: root/src/etc/vscode_settings.json
diff options
context:
space:
mode:
Diffstat (limited to 'src/etc/vscode_settings.json')
-rw-r--r--src/etc/vscode_settings.json28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/etc/vscode_settings.json b/src/etc/vscode_settings.json
new file mode 100644
index 000000000..dd01bfaa7
--- /dev/null
+++ b/src/etc/vscode_settings.json
@@ -0,0 +1,28 @@
+{
+ "rust-analyzer.check.invocationLocation": "root",
+ "rust-analyzer.check.invocationStrategy": "once",
+ "rust-analyzer.check.overrideCommand": [
+ "python3",
+ "x.py",
+ "check",
+ "--json-output"
+ ],
+ "rust-analyzer.linkedProjects": ["src/bootstrap/Cargo.toml", "Cargo.toml"],
+ "rust-analyzer.rustfmt.overrideCommand": [
+ "./build/host/rustfmt/bin/rustfmt",
+ "--edition=2021"
+ ],
+ "rust-analyzer.procMacro.server": "./build/host/stage0/libexec/rust-analyzer-proc-macro-srv",
+ "rust-analyzer.procMacro.enable": true,
+ "rust-analyzer.cargo.buildScripts.enable": true,
+ "rust-analyzer.cargo.buildScripts.invocationLocation": "root",
+ "rust-analyzer.cargo.buildScripts.invocationStrategy": "once",
+ "rust-analyzer.cargo.buildScripts.overrideCommand": [
+ "python3",
+ "x.py",
+ "check",
+ "--json-output"
+ ],
+ "rust-analyzer.cargo.sysrootSrc": "./library",
+ "rust-analyzer.rustc.source": "./Cargo.toml"
+}