summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/a-b-a-linker-guard/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/a-b-a-linker-guard/Makefile')
-rw-r--r--src/test/run-make-fulldeps/a-b-a-linker-guard/Makefile15
1 files changed, 0 insertions, 15 deletions
diff --git a/src/test/run-make-fulldeps/a-b-a-linker-guard/Makefile b/src/test/run-make-fulldeps/a-b-a-linker-guard/Makefile
deleted file mode 100644
index adc9e3d09..000000000
--- a/src/test/run-make-fulldeps/a-b-a-linker-guard/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-include ../tools.mk
-
-# Test that if we build `b` against a version of `a` that has one set
-# of types, it will not run with a dylib that has a different set of
-# types.
-
-# NOTE(eddyb) this test only works with the `legacy` mangling,
-# and will probably get removed once `legacy` is gone.
-
-all:
- $(RUSTC) a.rs --cfg x -C prefer-dynamic -Z unstable-options -C symbol-mangling-version=legacy
- $(RUSTC) b.rs -C prefer-dynamic -Z unstable-options -C symbol-mangling-version=legacy
- $(call RUN,b)
- $(RUSTC) a.rs --cfg y -C prefer-dynamic -Z unstable-options -C symbol-mangling-version=legacy
- $(call FAIL,b)