summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile')
-rw-r--r--src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile11
1 files changed, 0 insertions, 11 deletions
diff --git a/src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile b/src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
deleted file mode 100644
index 60d9c7c37..000000000
--- a/src/test/run-make-fulldeps/allow-non-lint-warnings-cmdline/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-include ../tools.mk
-
-# Test that -A warnings makes the 'empty trait list for derive' warning go away
-OUT=$(shell $(RUSTC) foo.rs -A warnings 2>&1 | grep "warning" )
-
-all: foo
- test -z '$(OUT)'
-
-# This is just to make sure the above command actually succeeds
-foo:
- $(RUSTC) foo.rs -A warnings