summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile')
-rw-r--r--src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile15
1 files changed, 0 insertions, 15 deletions
diff --git a/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile b/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile
deleted file mode 100644
index 1ce8d0ec2..000000000
--- a/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-include ../tools.mk
-
-# Test that -A warnings makes the 'empty trait list for derive' warning go away
-DEP=$(shell $(RUSTC) bar.rs)
-OUT=$(shell $(RUSTC) foo.rs -A warnings 2>&1 | grep "warning" )
-
-all: foo bar
- test -z '$(OUT)'
-
-# These are just to ensure that the above commands actually work
-bar:
- $(RUSTC) bar.rs
-
-foo: bar
- $(RUSTC) foo.rs -A warnings