summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile')
-rw-r--r--src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile b/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile
new file mode 100644
index 000000000..3eecaf931
--- /dev/null
+++ b/src/test/run-make-fulldeps/allow-warnings-cmdline-stability/Makefile
@@ -0,0 +1,15 @@
+-include ../tools.mk
+
+# Test that -A warnings makes the 'empty trait list for derive' warning go away
+DEP=$(shell $(RUSTC) bar.rs)
+OUT=$(shell $(RUSTC) foo.rs -A warnings 2>&1 | grep "warning" )
+
+all: foo bar
+ test -z '$(OUT)'
+
+# These are just to ensure that the above commands actually work
+bar:
+ $(RUSTC) bar.rs
+
+foo: bar
+ $(RUSTC) foo.rs -A warnings