summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/cdylib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/cdylib/Makefile')
-rw-r--r--src/test/run-make-fulldeps/cdylib/Makefile19
1 files changed, 0 insertions, 19 deletions
diff --git a/src/test/run-make-fulldeps/cdylib/Makefile b/src/test/run-make-fulldeps/cdylib/Makefile
deleted file mode 100644
index 47ec762b3..000000000
--- a/src/test/run-make-fulldeps/cdylib/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-include ../tools.mk
-
-all: $(call RUN_BINFILE,foo)
- $(call RUN,foo)
- rm $(call DYLIB,foo)
- $(RUSTC) foo.rs -C lto
- $(call RUN,foo)
-
-ifdef IS_MSVC
-$(call RUN_BINFILE,foo): $(call DYLIB,foo)
- $(CC) $(CFLAGS) foo.c $(TMPDIR)/foo.dll.lib $(call OUT_EXE,foo)
-else
-$(call RUN_BINFILE,foo): $(call DYLIB,foo)
- $(CC) $(CFLAGS) foo.c -lfoo -o $(call RUN_BINFILE,foo) -L $(TMPDIR)
-endif
-
-$(call DYLIB,foo):
- $(RUSTC) bar.rs
- $(RUSTC) foo.rs