summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/extern-flag-pathless/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/extern-flag-pathless/Makefile')
-rw-r--r--src/test/run-make-fulldeps/extern-flag-pathless/Makefile18
1 files changed, 0 insertions, 18 deletions
diff --git a/src/test/run-make-fulldeps/extern-flag-pathless/Makefile b/src/test/run-make-fulldeps/extern-flag-pathless/Makefile
deleted file mode 100644
index 0f23815b6..000000000
--- a/src/test/run-make-fulldeps/extern-flag-pathless/Makefile
+++ /dev/null
@@ -1,18 +0,0 @@
-include ../tools.mk
-
-# Test mixing pathless --extern with paths.
-
-all:
- $(RUSTC) bar-static.rs --crate-name=bar --crate-type=rlib
- $(RUSTC) bar-dynamic.rs --crate-name=bar --crate-type=dylib -C prefer-dynamic
- # rlib preferred over dylib
- $(RUSTC) foo.rs --extern bar
- $(call RUN,foo) | $(CGREP) 'static'
- $(RUSTC) foo.rs --extern bar=$(TMPDIR)/libbar.rlib --extern bar
- $(call RUN,foo) | $(CGREP) 'static'
- # explicit --extern overrides pathless
- $(RUSTC) foo.rs --extern bar=$(call DYLIB,bar) --extern bar
- $(call RUN,foo) | $(CGREP) 'dynamic'
- # prefer-dynamic does what it says
- $(RUSTC) foo.rs --extern bar -C prefer-dynamic
- $(call RUN,foo) | $(CGREP) 'dynamic'