summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/interdependent-c-libraries/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/interdependent-c-libraries/Makefile')
-rw-r--r--src/test/run-make-fulldeps/interdependent-c-libraries/Makefile14
1 files changed, 0 insertions, 14 deletions
diff --git a/src/test/run-make-fulldeps/interdependent-c-libraries/Makefile b/src/test/run-make-fulldeps/interdependent-c-libraries/Makefile
deleted file mode 100644
index dc5b55a99..000000000
--- a/src/test/run-make-fulldeps/interdependent-c-libraries/Makefile
+++ /dev/null
@@ -1,14 +0,0 @@
-include ../tools.mk
-
-# The rust crate foo will link to the native library foo, while the rust crate
-# bar will link to the native library bar. There is also a dependency between
-# the native library bar to the natibe library foo.
-#
-# This test ensures that the ordering of -lfoo and -lbar on the command line is
-# correct to complete the linkage. If passed as "-lfoo -lbar", then the 'foo'
-# library will be stripped out, and the linkage will fail.
-
-all: $(call NATIVE_STATICLIB,foo) $(call NATIVE_STATICLIB,bar)
- $(RUSTC) foo.rs
- $(RUSTC) bar.rs
- $(RUSTC) main.rs --print link-args