summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/intrinsic-unreachable/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/intrinsic-unreachable/Makefile')
-rw-r--r--src/test/run-make-fulldeps/intrinsic-unreachable/Makefile12
1 files changed, 0 insertions, 12 deletions
diff --git a/src/test/run-make-fulldeps/intrinsic-unreachable/Makefile b/src/test/run-make-fulldeps/intrinsic-unreachable/Makefile
deleted file mode 100644
index ff9cc5709..000000000
--- a/src/test/run-make-fulldeps/intrinsic-unreachable/Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
-include ../tools.mk
-
-# needs-asm-support
-# ignore-windows-msvc
-#
-# Because of Windows exception handling, the code is not necessarily any shorter.
-# https://github.com/llvm-mirror/llvm/commit/64b2297786f7fd6f5fa24cdd4db0298fbf211466
-
-all:
- $(RUSTC) -O --emit asm exit-ret.rs
- $(RUSTC) -O --emit asm exit-unreachable.rs
- test `wc -l < $(TMPDIR)/exit-unreachable.s` -lt `wc -l < $(TMPDIR)/exit-ret.s`