summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/issue-14500/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/issue-14500/Makefile')
-rw-r--r--src/test/run-make-fulldeps/issue-14500/Makefile13
1 files changed, 0 insertions, 13 deletions
diff --git a/src/test/run-make-fulldeps/issue-14500/Makefile b/src/test/run-make-fulldeps/issue-14500/Makefile
deleted file mode 100644
index 52550e570..000000000
--- a/src/test/run-make-fulldeps/issue-14500/Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
-include ../tools.mk
-
-# Test to make sure that reachable extern fns are always available in final
-# productcs, including when LTO is used. In this test, the `foo` crate has a
-# reahable symbol, and is a dependency of the `bar` crate. When the `bar` crate
-# is compiled with LTO, it shouldn't strip the symbol from `foo`, and that's the
-# only way that `foo.c` will successfully compile.
-
-all:
- $(RUSTC) foo.rs --crate-type=rlib
- $(RUSTC) bar.rs --crate-type=staticlib -C lto -L. -o $(TMPDIR)/libbar.a
- $(CC) foo.c $(TMPDIR)/libbar.a $(EXTRACFLAGS) $(call OUT_EXE,foo)
- $(call RUN,foo)