summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/issue-68794-textrel-on-minimal-lib/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/issue-68794-textrel-on-minimal-lib/Makefile')
-rw-r--r--src/test/run-make-fulldeps/issue-68794-textrel-on-minimal-lib/Makefile17
1 files changed, 0 insertions, 17 deletions
diff --git a/src/test/run-make-fulldeps/issue-68794-textrel-on-minimal-lib/Makefile b/src/test/run-make-fulldeps/issue-68794-textrel-on-minimal-lib/Makefile
deleted file mode 100644
index 13983f4ff..000000000
--- a/src/test/run-make-fulldeps/issue-68794-textrel-on-minimal-lib/Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-# Regression test for issue #68794
-#
-# Verify that no text relocations are accidentally introduced by linking a
-# minimal rust staticlib.
-#
-# The test links a rust static library into a shared library, and checks that
-# the linker doesn't have to flag the resulting file as containing TEXTRELs.
-
-include ../tools.mk
-
-# only-linux
-
-all:
- $(RUSTC) foo.rs
- $(CC) bar.c $(call STATICLIB,foo) -fPIC -shared -o $(call DYLIB,bar) \
- $(EXTRACFLAGS) $(EXTRACXXFLAGS)
- readelf -d $(call DYLIB,bar) | grep TEXTREL; test $$? -eq 1