summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/min-global-align
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/min-global-align')
-rw-r--r--src/test/run-make-fulldeps/min-global-align/Makefile22
-rw-r--r--src/test/run-make-fulldeps/min-global-align/min_global_align.rs32
2 files changed, 0 insertions, 54 deletions
diff --git a/src/test/run-make-fulldeps/min-global-align/Makefile b/src/test/run-make-fulldeps/min-global-align/Makefile
deleted file mode 100644
index 82f38749e..000000000
--- a/src/test/run-make-fulldeps/min-global-align/Makefile
+++ /dev/null
@@ -1,22 +0,0 @@
-include ../tools.mk
-
-# only-linux
-
-# This tests ensure that global variables respect the target minimum alignment.
-# The three bools `STATIC_BOOL`, `STATIC_MUT_BOOL`, and `CONST_BOOL` all have
-# type-alignment of 1, but some targets require greater global alignment.
-
-SRC = min_global_align.rs
-LL = $(TMPDIR)/min_global_align.ll
-
-all:
-# Most targets are happy with default alignment -- take i686 for example.
-ifeq ($(filter x86,$(LLVM_COMPONENTS)),x86)
- $(RUSTC) --target=i686-unknown-linux-gnu --emit=llvm-ir $(SRC)
- [ "$$(grep -c 'align 1' "$(LL)")" -eq "3" ]
-endif
-# SystemZ requires even alignment for PC-relative addressing.
-ifeq ($(filter systemz,$(LLVM_COMPONENTS)),systemz)
- $(RUSTC) --target=s390x-unknown-linux-gnu --emit=llvm-ir $(SRC)
- [ "$$(grep -c 'align 2' "$(LL)")" -eq "3" ]
-endif
diff --git a/src/test/run-make-fulldeps/min-global-align/min_global_align.rs b/src/test/run-make-fulldeps/min-global-align/min_global_align.rs
deleted file mode 100644
index 135792e93..000000000
--- a/src/test/run-make-fulldeps/min-global-align/min_global_align.rs
+++ /dev/null
@@ -1,32 +0,0 @@
-#![feature(no_core, lang_items)]
-#![crate_type = "rlib"]
-#![no_core]
-
-pub static STATIC_BOOL: bool = true;
-
-pub static mut STATIC_MUT_BOOL: bool = true;
-
-const CONST_BOOL: bool = true;
-pub static CONST_BOOL_REF: &'static bool = &CONST_BOOL;
-
-#[lang = "sized"]
-trait Sized {}
-
-#[lang = "copy"]
-trait Copy {}
-impl Copy for bool {}
-impl Copy for &bool {}
-
-#[lang = "freeze"]
-trait Freeze {}
-
-// No `UnsafeCell`, so everything is `Freeze`.
-impl<T: ?Sized> Freeze for T {}
-
-#[lang = "sync"]
-trait Sync {}
-impl Sync for bool {}
-impl Sync for &'static bool {}
-
-#[lang = "drop_in_place"]
-pub unsafe fn drop_in_place<T: ?Sized>(_: *mut T) {}