summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/mingw-export-call-convention
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/mingw-export-call-convention')
-rw-r--r--src/test/run-make-fulldeps/mingw-export-call-convention/Makefile9
-rw-r--r--src/test/run-make-fulldeps/mingw-export-call-convention/foo.rs4
2 files changed, 0 insertions, 13 deletions
diff --git a/src/test/run-make-fulldeps/mingw-export-call-convention/Makefile b/src/test/run-make-fulldeps/mingw-export-call-convention/Makefile
deleted file mode 100644
index 4a60059cc..000000000
--- a/src/test/run-make-fulldeps/mingw-export-call-convention/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-include ../tools.mk
-
-# only-windows-gnu
-
-all:
- $(RUSTC) foo.rs
- # FIXME: we should make sure __stdcall calling convention is used here
- # but that only works with LLD right now
- nm -g "$(call IMPLIB,foo)" | $(CGREP) bar
diff --git a/src/test/run-make-fulldeps/mingw-export-call-convention/foo.rs b/src/test/run-make-fulldeps/mingw-export-call-convention/foo.rs
deleted file mode 100644
index 1fec00311..000000000
--- a/src/test/run-make-fulldeps/mingw-export-call-convention/foo.rs
+++ /dev/null
@@ -1,4 +0,0 @@
-#![crate_type = "cdylib"]
-
-#[no_mangle]
-pub extern "system" fn bar() {}