summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/no-builtins-lto/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/no-builtins-lto/Makefile')
-rw-r--r--src/test/run-make-fulldeps/no-builtins-lto/Makefile9
1 files changed, 0 insertions, 9 deletions
diff --git a/src/test/run-make-fulldeps/no-builtins-lto/Makefile b/src/test/run-make-fulldeps/no-builtins-lto/Makefile
deleted file mode 100644
index c8f05d991..000000000
--- a/src/test/run-make-fulldeps/no-builtins-lto/Makefile
+++ /dev/null
@@ -1,9 +0,0 @@
-include ../tools.mk
-
-all:
- # Compile a `#![no_builtins]` rlib crate
- $(RUSTC) no_builtins.rs
- # Build an executable that depends on that crate using LTO. The no_builtins crate doesn't
- # participate in LTO, so its rlib must be explicitly linked into the final binary. Verify this by
- # grepping the linker arguments.
- $(RUSTC) main.rs -C lto --print link-args | $(CGREP) 'libno_builtins.rlib'