summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/obey-crate-type-flag/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/obey-crate-type-flag/Makefile')
-rw-r--r--src/test/run-make-fulldeps/obey-crate-type-flag/Makefile13
1 files changed, 0 insertions, 13 deletions
diff --git a/src/test/run-make-fulldeps/obey-crate-type-flag/Makefile b/src/test/run-make-fulldeps/obey-crate-type-flag/Makefile
deleted file mode 100644
index effcfc94c..000000000
--- a/src/test/run-make-fulldeps/obey-crate-type-flag/Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
-include ../tools.mk
-
-# check that rustc builds all crate_type attributes
-# delete rlib
-# delete whatever dylib is made for this system
-# check that rustc only builds --crate-type flags, ignoring attributes
-# fail if an rlib was built
-all:
- $(RUSTC) test.rs
- $(call REMOVE_RLIBS,test)
- $(call REMOVE_DYLIBS,test)
- $(RUSTC) --crate-type dylib test.rs
- $(call REMOVE_RLIBS,test) && exit 1 || exit 0