summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/output-filename-overwrites-input/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/output-filename-overwrites-input/Makefile')
-rw-r--r--src/test/run-make-fulldeps/output-filename-overwrites-input/Makefile13
1 files changed, 0 insertions, 13 deletions
diff --git a/src/test/run-make-fulldeps/output-filename-overwrites-input/Makefile b/src/test/run-make-fulldeps/output-filename-overwrites-input/Makefile
deleted file mode 100644
index 33069c06f..000000000
--- a/src/test/run-make-fulldeps/output-filename-overwrites-input/Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
-include ../tools.mk
-
-all:
- cp foo.rs $(TMPDIR)/foo
- $(RUSTC) $(TMPDIR)/foo -o $(TMPDIR)/foo 2>&1 \
- | $(CGREP) -e "the input file \".*foo\" would be overwritten by the generated executable"
- cp bar.rs $(TMPDIR)/bar.rlib
- $(RUSTC) $(TMPDIR)/bar.rlib -o $(TMPDIR)/bar.rlib 2>&1 \
- | $(CGREP) -e "the input file \".*bar.rlib\" would be overwritten by the generated executable"
- $(RUSTC) foo.rs 2>&1 && $(RUSTC) -Z ls $(TMPDIR)/foo 2>&1
- cp foo.rs $(TMPDIR)/foo.rs
- $(RUSTC) $(TMPDIR)/foo.rs -o $(TMPDIR)/foo.rs 2>&1 \
- | $(CGREP) -e "the input file \".*foo.rs\" would be overwritten by the generated executable"