summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/profile/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/profile/Makefile')
-rw-r--r--src/test/run-make-fulldeps/profile/Makefile12
1 files changed, 0 insertions, 12 deletions
diff --git a/src/test/run-make-fulldeps/profile/Makefile b/src/test/run-make-fulldeps/profile/Makefile
deleted file mode 100644
index fffc051ad..000000000
--- a/src/test/run-make-fulldeps/profile/Makefile
+++ /dev/null
@@ -1,12 +0,0 @@
-# needs-profiler-support
-
-include ../tools.mk
-
-all:
- $(RUSTC) -g -Z profile test.rs
- $(call RUN,test) || exit 1
- [ -e "$(TMPDIR)/test.gcno" ] || (echo "No .gcno file"; exit 1)
- [ -e "$(TMPDIR)/test.gcda" ] || (echo "No .gcda file"; exit 1)
- $(RUSTC) -g -Z profile -Z profile-emit=$(TMPDIR)/abc/abc.gcda test.rs
- $(call RUN,test) || exit 1
- [ -e "$(TMPDIR)/abc/abc.gcda" ] || (echo "gcda file not emitted to defined path"; exit 1)