summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/relocation-model/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/relocation-model/Makefile')
-rw-r--r--src/test/run-make-fulldeps/relocation-model/Makefile19
1 files changed, 0 insertions, 19 deletions
diff --git a/src/test/run-make-fulldeps/relocation-model/Makefile b/src/test/run-make-fulldeps/relocation-model/Makefile
deleted file mode 100644
index a31dbfd91..000000000
--- a/src/test/run-make-fulldeps/relocation-model/Makefile
+++ /dev/null
@@ -1,19 +0,0 @@
-include ../tools.mk
-
-all: others
- $(RUSTC) -C relocation-model=dynamic-no-pic foo.rs
- $(call RUN,foo)
-
- $(RUSTC) -C relocation-model=default foo.rs
- $(call RUN,foo)
-
- $(RUSTC) -C relocation-model=dynamic-no-pic --crate-type=dylib foo.rs --emit=link,obj
-
-ifdef IS_MSVC
-# FIXME(#28026)
-others:
-else
-others:
- $(RUSTC) -C relocation-model=static foo.rs
- $(call RUN,foo)
-endif