summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/rustdoc-themes
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/rustdoc-themes')
-rw-r--r--src/test/run-make-fulldeps/rustdoc-themes/Makefile10
-rw-r--r--src/test/run-make-fulldeps/rustdoc-themes/foo.rs4
2 files changed, 14 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/rustdoc-themes/Makefile b/src/test/run-make-fulldeps/rustdoc-themes/Makefile
new file mode 100644
index 000000000..f3d07b25c
--- /dev/null
+++ b/src/test/run-make-fulldeps/rustdoc-themes/Makefile
@@ -0,0 +1,10 @@
+-include ../tools.mk
+
+# Test that rustdoc will properly load in a theme file and display it in the theme selector.
+
+OUTPUT_DIR := "$(TMPDIR)/rustdoc-themes"
+
+all:
+ cp $(S)/src/librustdoc/html/static/css/themes/light.css $(TMPDIR)/test.css
+ $(RUSTDOC) -o $(OUTPUT_DIR) foo.rs --theme $(TMPDIR)/test.css
+ $(HTMLDOCCK) $(OUTPUT_DIR) foo.rs
diff --git a/src/test/run-make-fulldeps/rustdoc-themes/foo.rs b/src/test/run-make-fulldeps/rustdoc-themes/foo.rs
new file mode 100644
index 000000000..58efaf7d5
--- /dev/null
+++ b/src/test/run-make-fulldeps/rustdoc-themes/foo.rs
@@ -0,0 +1,4 @@
+// @has test.css
+// @has foo/struct.Foo.html
+// @has - '//link[@rel="stylesheet"]/@href' '../test.css'
+pub struct Foo;