summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/sanitizer-cdylib-link/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/sanitizer-cdylib-link/Makefile')
-rw-r--r--src/test/run-make-fulldeps/sanitizer-cdylib-link/Makefile16
1 files changed, 0 insertions, 16 deletions
diff --git a/src/test/run-make-fulldeps/sanitizer-cdylib-link/Makefile b/src/test/run-make-fulldeps/sanitizer-cdylib-link/Makefile
deleted file mode 100644
index 691585268..000000000
--- a/src/test/run-make-fulldeps/sanitizer-cdylib-link/Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
-# needs-sanitizer-support
-# needs-sanitizer-address
-
-include ../tools.mk
-
-LOG := $(TMPDIR)/log.txt
-
-# This test builds a shared object, then an executable that links it as a native
-# rust library (contrast to an rlib). The shared library and executable both
-# are compiled with address sanitizer, and we assert that a fault in the cdylib
-# is correctly detected.
-
-all:
- $(RUSTC) -g -Z sanitizer=address --crate-type cdylib --target $(TARGET) library.rs
- $(RUSTC) -g -Z sanitizer=address --crate-type bin --target $(TARGET) -llibrary program.rs
- LD_LIBRARY_PATH=$(TMPDIR) $(TMPDIR)/program 2>&1 | $(CGREP) stack-buffer-overflow