summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/sanitizer-staticlib-link/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/sanitizer-staticlib-link/Makefile')
-rw-r--r--src/test/run-make-fulldeps/sanitizer-staticlib-link/Makefile20
1 files changed, 0 insertions, 20 deletions
diff --git a/src/test/run-make-fulldeps/sanitizer-staticlib-link/Makefile b/src/test/run-make-fulldeps/sanitizer-staticlib-link/Makefile
deleted file mode 100644
index 7b1a286ed..000000000
--- a/src/test/run-make-fulldeps/sanitizer-staticlib-link/Makefile
+++ /dev/null
@@ -1,20 +0,0 @@
-# needs-sanitizer-support
-# needs-sanitizer-address
-
-include ../tools.mk
-
-# This test first builds a staticlib with AddressSanitizer and checks that
-# linking it to an executable fails due to the missing sanitizer runtime.
-# It then builds an executable linking to the staticlib and checks that
-# the fault in the staticlib is detected correctly.
-
-# Note that checking for the link failure actually checks two things at once:
-# 1) That the library has the sanitizer intrumentation
-# 2) and that library does not have the sanitizer runtime
-
-all:
- $(RUSTC) -g -Z sanitizer=address --crate-type staticlib --target $(TARGET) library.rs
- ! $(CC) program.c $(call STATICLIB,library) $(call OUT_EXE,program) $(EXTRACFLAGS) $(EXTRACXXFLAGS)
- $(RUSTC) -g -Z sanitizer=address --crate-type bin --target $(TARGET) -L . program.rs
- LD_LIBRARY_PATH=$(TMPDIR) $(TMPDIR)/program 2>&1 | $(CGREP) stack-buffer-overflow
-