summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/static-dylib-by-default/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/static-dylib-by-default/Makefile')
-rw-r--r--src/test/run-make-fulldeps/static-dylib-by-default/Makefile16
1 files changed, 0 insertions, 16 deletions
diff --git a/src/test/run-make-fulldeps/static-dylib-by-default/Makefile b/src/test/run-make-fulldeps/static-dylib-by-default/Makefile
deleted file mode 100644
index eedd0b320..000000000
--- a/src/test/run-make-fulldeps/static-dylib-by-default/Makefile
+++ /dev/null
@@ -1,16 +0,0 @@
-include ../tools.mk
-
-TO_LINK := $(call DYLIB,bar)
-ifdef IS_MSVC
-LINK_ARG = $(TO_LINK:dll=dll.lib)
-else
-LINK_ARG = $(TO_LINK)
-endif
-
-all:
- $(RUSTC) foo.rs
- $(RUSTC) bar.rs
- $(CC) main.c $(call OUT_EXE,main) $(LINK_ARG) $(EXTRACFLAGS)
- rm $(TMPDIR)/*.rlib
- rm $(call DYLIB,foo)
- $(call RUN,main)