summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/target-specs/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/target-specs/Makefile')
-rw-r--r--src/test/run-make-fulldeps/target-specs/Makefile11
1 files changed, 0 insertions, 11 deletions
diff --git a/src/test/run-make-fulldeps/target-specs/Makefile b/src/test/run-make-fulldeps/target-specs/Makefile
deleted file mode 100644
index a33f5368e..000000000
--- a/src/test/run-make-fulldeps/target-specs/Makefile
+++ /dev/null
@@ -1,11 +0,0 @@
-include ../tools.mk
-all:
- $(RUSTC) foo.rs --target=my-awesome-platform.json --crate-type=lib --emit=asm
- $(CGREP) -v morestack < $(TMPDIR)/foo.s
- $(RUSTC) foo.rs --target=my-invalid-platform.json 2>&1 | $(CGREP) "Error loading target specification"
- $(RUSTC) foo.rs --target=my-incomplete-platform.json 2>&1 | $(CGREP) 'Field llvm-target'
- RUST_TARGET_PATH=. $(RUSTC) foo.rs --target=my-awesome-platform --crate-type=lib --emit=asm
- RUST_TARGET_PATH=. $(RUSTC) foo.rs --target=my-x86_64-unknown-linux-gnu-platform --crate-type=lib --emit=asm
- $(RUSTC) -Z unstable-options --target=my-awesome-platform.json --print target-spec-json > $(TMPDIR)/test-platform.json && $(RUSTC) -Z unstable-options --target=$(TMPDIR)/test-platform.json --print target-spec-json | diff -q $(TMPDIR)/test-platform.json -
- $(RUSTC) foo.rs --target=definitely-not-builtin-target 2>&1 | $(CGREP) 'may not set is_builtin'
- $(RUSTC) foo.rs --target=mismatching-data-layout --crate-type=lib