summaryrefslogtreecommitdiffstats
path: root/src/test/run-make-fulldeps/test-harness/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make-fulldeps/test-harness/Makefile')
-rw-r--r--src/test/run-make-fulldeps/test-harness/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/src/test/run-make-fulldeps/test-harness/Makefile b/src/test/run-make-fulldeps/test-harness/Makefile
new file mode 100644
index 000000000..39477c07c
--- /dev/null
+++ b/src/test/run-make-fulldeps/test-harness/Makefile
@@ -0,0 +1,8 @@
+-include ../tools.mk
+
+all:
+ # check that #[cfg_attr(..., ignore)] does the right thing.
+ $(RUSTC) --test test-ignore-cfg.rs --cfg ignorecfg
+ $(call RUN,test-ignore-cfg) | $(CGREP) 'shouldnotignore ... ok' 'shouldignore ... ignored'
+ $(call RUN,test-ignore-cfg --quiet) | $(CGREP) -e "^i\.$$"
+ $(call RUN,test-ignore-cfg --quiet) | $(CGREP) -v 'should'