summaryrefslogtreecommitdiffstats
path: root/src/test/run-make/track-path-dep-info
diff options
context:
space:
mode:
Diffstat (limited to 'src/test/run-make/track-path-dep-info')
-rw-r--r--src/test/run-make/track-path-dep-info/Makefile13
-rw-r--r--src/test/run-make/track-path-dep-info/emojis.txt1
-rw-r--r--src/test/run-make/track-path-dep-info/macro_def.rs11
-rw-r--r--src/test/run-make/track-path-dep-info/macro_use.rs6
4 files changed, 0 insertions, 31 deletions
diff --git a/src/test/run-make/track-path-dep-info/Makefile b/src/test/run-make/track-path-dep-info/Makefile
deleted file mode 100644
index ee853943f..000000000
--- a/src/test/run-make/track-path-dep-info/Makefile
+++ /dev/null
@@ -1,13 +0,0 @@
-include ../../run-make-fulldeps/tools.mk
-
-# FIXME(eddyb) provide `HOST_RUSTC` and `TARGET_RUSTC`
-# instead of hardcoding them everywhere they're needed.
-ifeq ($(IS_MUSL_HOST),1)
-ADDITIONAL_ARGS := $(RUSTFLAGS)
-endif
-
-all:
- # Proc macro
- $(BARE_RUSTC) $(ADDITIONAL_ARGS) --out-dir $(TMPDIR) macro_def.rs
- EXISTING_PROC_MACRO_ENV=1 $(RUSTC) --emit dep-info macro_use.rs
- $(CGREP) "emojis.txt:" < $(TMPDIR)/macro_use.d
diff --git a/src/test/run-make/track-path-dep-info/emojis.txt b/src/test/run-make/track-path-dep-info/emojis.txt
deleted file mode 100644
index e1a728461..000000000
--- a/src/test/run-make/track-path-dep-info/emojis.txt
+++ /dev/null
@@ -1 +0,0 @@
-👾👾👾👾👾👾
diff --git a/src/test/run-make/track-path-dep-info/macro_def.rs b/src/test/run-make/track-path-dep-info/macro_def.rs
deleted file mode 100644
index 8777ce21f..000000000
--- a/src/test/run-make/track-path-dep-info/macro_def.rs
+++ /dev/null
@@ -1,11 +0,0 @@
-#![feature(track_path)]
-#![crate_type = "proc-macro"]
-
-extern crate proc_macro;
-use proc_macro::*;
-
-#[proc_macro]
-pub fn access_tracked_paths(_: TokenStream) -> TokenStream {
- tracked_path::path("emojis.txt");
- TokenStream::new()
-}
diff --git a/src/test/run-make/track-path-dep-info/macro_use.rs b/src/test/run-make/track-path-dep-info/macro_use.rs
deleted file mode 100644
index 3c49fd05d..000000000
--- a/src/test/run-make/track-path-dep-info/macro_use.rs
+++ /dev/null
@@ -1,6 +0,0 @@
-#[macro_use]
-extern crate macro_def;
-
-access_tracked_paths!();
-
-fn main() {}