summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/crates/cargo-test-macro
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/cargo/crates/cargo-test-macro')
-rw-r--r--src/tools/cargo/crates/cargo-test-macro/Cargo.toml3
-rw-r--r--src/tools/cargo/crates/cargo-test-macro/src/lib.rs9
2 files changed, 8 insertions, 4 deletions
diff --git a/src/tools/cargo/crates/cargo-test-macro/Cargo.toml b/src/tools/cargo/crates/cargo-test-macro/Cargo.toml
index 1e81ab314..17ca326f6 100644
--- a/src/tools/cargo/crates/cargo-test-macro/Cargo.toml
+++ b/src/tools/cargo/crates/cargo-test-macro/Cargo.toml
@@ -12,3 +12,6 @@ publish = false
[lib]
proc-macro = true
+
+[lints]
+workspace = true
diff --git a/src/tools/cargo/crates/cargo-test-macro/src/lib.rs b/src/tools/cargo/crates/cargo-test-macro/src/lib.rs
index 937fbce6b..14672ab94 100644
--- a/src/tools/cargo/crates/cargo-test-macro/src/lib.rs
+++ b/src/tools/cargo/crates/cargo-test-macro/src/lib.rs
@@ -208,10 +208,11 @@ fn has_command(command: &str) -> bool {
let output = match Command::new(command).arg("--version").output() {
Ok(output) => output,
Err(e) => {
- // hg is not installed on GitHub macOS or certain constrained
- // environments like Docker. Consider installing it if Cargo gains
- // more hg support, but otherwise it isn't critical.
- if is_ci() && command != "hg" {
+ // * hg is not installed on GitHub macOS or certain constrained
+ // environments like Docker. Consider installing it if Cargo
+ // gains more hg support, but otherwise it isn't critical.
+ // * lldb is not pre-installed on Ubuntu and Windows, so skip.
+ if is_ci() && !["hg", "lldb"].contains(&command) {
panic!(
"expected command `{}` to be somewhere in PATH: {}",
command, e