summaryrefslogtreecommitdiffstats
path: root/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc')
-rw-r--r--src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/in/main.rs4
-rw-r--r--src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/mod.rs22
-rw-r--r--src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/out/Cargo.toml12
-rw-r--r--src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/out/main.rs4
-rw-r--r--src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/stderr.log1
-rw-r--r--src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/stdout.log0
6 files changed, 43 insertions, 0 deletions
diff --git a/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/in/main.rs b/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/in/main.rs
new file mode 100644
index 000000000..65fdcf8da
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/in/main.rs
@@ -0,0 +1,4 @@
+fn main() {
+ println!("Check that our file is not overwritten")
+}
+
diff --git a/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/mod.rs b/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/mod.rs
new file mode 100644
index 000000000..fe65940db
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/mod.rs
@@ -0,0 +1,22 @@
+use cargo_test_support::compare::assert_ui;
+use cargo_test_support::prelude::*;
+use cargo_test_support::Project;
+
+use cargo_test_support::curr_dir;
+
+#[cargo_test]
+fn case() {
+ let project = Project::from_template(curr_dir!().join("in"));
+ let project_root = &project.root();
+
+ snapbox::cmd::Command::cargo_ui()
+ .arg_line("init --vcs none")
+ .current_dir(project_root)
+ .assert()
+ .success()
+ .stdout_matches_path(curr_dir!().join("stdout.log"))
+ .stderr_matches_path(curr_dir!().join("stderr.log"));
+
+ assert_ui().subset_matches(curr_dir!().join("out"), project_root);
+ assert!(!project_root.join("src").is_dir());
+}
diff --git a/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/out/Cargo.toml b/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/out/Cargo.toml
new file mode 100644
index 000000000..5c6c9158c
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/out/Cargo.toml
@@ -0,0 +1,12 @@
+[package]
+name = "case"
+version = "0.1.0"
+edition = "2021"
+
+# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+
+[dependencies]
+
+[[bin]]
+name = "case"
+path = "main.rs"
diff --git a/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/out/main.rs b/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/out/main.rs
new file mode 100644
index 000000000..65fdcf8da
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/out/main.rs
@@ -0,0 +1,4 @@
+fn main() {
+ println!("Check that our file is not overwritten")
+}
+
diff --git a/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/stderr.log b/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/stderr.log
new file mode 100644
index 000000000..3847e4e4a
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/stderr.log
@@ -0,0 +1 @@
+ Created binary (application) package
diff --git a/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/stdout.log b/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/stdout.log
new file mode 100644
index 000000000..e69de29bb
--- /dev/null
+++ b/src/tools/cargo/tests/testsuite/init/bin_already_exists_implicit_nosrc/stdout.log