summaryrefslogtreecommitdiffstats
path: root/src/tools/clippy/tests/ui-cargo/cargo_rust_version/fail_both_diff
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/clippy/tests/ui-cargo/cargo_rust_version/fail_both_diff')
-rw-r--r--src/tools/clippy/tests/ui-cargo/cargo_rust_version/fail_both_diff/Cargo.stderr21
-rw-r--r--src/tools/clippy/tests/ui-cargo/cargo_rust_version/fail_both_diff/src/main.stderr22
2 files changed, 21 insertions, 22 deletions
diff --git a/src/tools/clippy/tests/ui-cargo/cargo_rust_version/fail_both_diff/Cargo.stderr b/src/tools/clippy/tests/ui-cargo/cargo_rust_version/fail_both_diff/Cargo.stderr
new file mode 100644
index 000000000..dfbf19d33
--- /dev/null
+++ b/src/tools/clippy/tests/ui-cargo/cargo_rust_version/fail_both_diff/Cargo.stderr
@@ -0,0 +1,21 @@
+warning: the MSRV in `clippy.toml` and `Cargo.toml` differ; using `1.59.0` from `clippy.toml`
+
+error: unnecessary structure name repetition
+ --> src/main.rs:6:21
+ |
+6 | pub fn bar() -> Foo {
+ | ^^^ help: use the applicable keyword: `Self`
+ |
+note: the lint level is defined here
+ --> src/main.rs:1:9
+ |
+1 | #![deny(clippy::use_self)]
+ | ^^^^^^^^^^^^^^^^
+
+error: unnecessary structure name repetition
+ --> src/main.rs:7:9
+ |
+7 | Foo
+ | ^^^ help: use the applicable keyword: `Self`
+
+error: could not compile `fail-both-diff` (bin "fail-both-diff") due to 2 previous errors; 1 warning emitted
diff --git a/src/tools/clippy/tests/ui-cargo/cargo_rust_version/fail_both_diff/src/main.stderr b/src/tools/clippy/tests/ui-cargo/cargo_rust_version/fail_both_diff/src/main.stderr
deleted file mode 100644
index 163f8bb35..000000000
--- a/src/tools/clippy/tests/ui-cargo/cargo_rust_version/fail_both_diff/src/main.stderr
+++ /dev/null
@@ -1,22 +0,0 @@
-warning: the MSRV in `clippy.toml` and `Cargo.toml` differ; using `1.59.0` from `clippy.toml`
-
-error: unnecessary structure name repetition
- --> $DIR/main.rs:6:21
- |
-LL | pub fn bar() -> Foo {
- | ^^^ help: use the applicable keyword: `Self`
- |
-note: the lint level is defined here
- --> $DIR/main.rs:1:9
- |
-LL | #![deny(clippy::use_self)]
- | ^^^^^^^^^^^^^^^^
-
-error: unnecessary structure name repetition
- --> $DIR/main.rs:7:9
- |
-LL | Foo
- | ^^^ help: use the applicable keyword: `Self`
-
-error: aborting due to 2 previous errors; 1 warning emitted
-