summaryrefslogtreecommitdiffstats
path: root/src/tools/rust-analyzer/crates/hir-def/Cargo.toml
diff options
context:
space:
mode:
Diffstat (limited to 'src/tools/rust-analyzer/crates/hir-def/Cargo.toml')
-rw-r--r--src/tools/rust-analyzer/crates/hir-def/Cargo.toml23
1 files changed, 11 insertions, 12 deletions
diff --git a/src/tools/rust-analyzer/crates/hir-def/Cargo.toml b/src/tools/rust-analyzer/crates/hir-def/Cargo.toml
index 8cf61ee04..2d1745176 100644
--- a/src/tools/rust-analyzer/crates/hir-def/Cargo.toml
+++ b/src/tools/rust-analyzer/crates/hir-def/Cargo.toml
@@ -12,29 +12,24 @@ rust-version.workspace = true
doctest = false
[dependencies]
-anymap = "1.0.0-beta.2"
arrayvec = "0.7.2"
-bitflags = "2.1.0"
+bitflags.workspace = true
cov-mark = "2.0.0-pre.1"
-# We need to freeze the version of the crate, as the raw-api feature is considered unstable
-dashmap = { version = "=5.4.0", features = ["raw-api"] }
+dashmap.workspace = true
drop_bomb = "0.1.5"
-either = "1.7.0"
+either.workspace = true
fst = { version = "0.4.7", default-features = false }
-indexmap = "2.0.0"
-itertools = "0.10.5"
+indexmap.workspace = true
+itertools.workspace = true
la-arena.workspace = true
once_cell = "1.17.0"
rustc-hash = "1.1.0"
-tracing = "0.1.35"
+tracing.workspace = true
smallvec.workspace = true
hashbrown.workspace = true
triomphe.workspace = true
-rustc_abi.workspace = true
-rustc_index.workspace = true
-rustc_parse_format.workspace = true
-
+rustc-dependencies.workspace = true
# local deps
stdx.workspace = true
@@ -48,8 +43,12 @@ cfg.workspace = true
tt.workspace = true
limit.workspace = true
+
[dev-dependencies]
expect-test = "1.4.0"
# local deps
test-utils.workspace = true
+
+[features]
+in-rust-tree = ["rustc-dependencies/in-rust-tree"]